Sharing Internet Connection on cable-modem Win98

I have two computers with Win98. Both computers are Networked. One has a cable-modem attached to it. How do I get to have the second computer share the same internet connection? All the IP Addresses, Gateways, DNSs etc. were set up on the main computer by the cable company. NetBEUI and TCP/IP are my protocols. Again, how do I get the second computer to use my main computer as a Proxy and access the internet through the same cable-modem?
kiko1234Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

sandman97289Commented:
kiko1234, you can use a feature which is in Windows 98 called Internet Connection Sharing. To enable Internet Connection Sharing go to Start->Settings->Control Panel->Internet Options and go to the connections tab. Now click on sharing under the LAN and internet sharing settings, from here you can enable it. Actually Windows98 has given an excellent help file regarding this feature. To read up on how to exactly configure this go to Start->Help and go to the index tab. Here type in Internet Connection Sharing.

Here you'll get documentation on how to configure Internet Connection plus documentation on what it exactly is.

Hope this helps :-)
0
trekie1Commented:
I could be wrong but I think Internet Connection Sharing is only avalible on win98 second edition    James  
0
rovermCommented:
Download the trail version of WinGate : http://wingate.deerfield.com/ 

Works way better than the W98SE internet sharing, better security !

D'Mzzl!
RoverM
0
Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

lalaevilCommented:
here, i have a suggestion (should be great ^____^) here.

you can download a personal version of Proxy+ (tucows.hkstar.com >> windows98 >> proxy servers >> Proxy+)

then have a setup as below:

server computer network card: (connects to the sub computer)

IP 192.168.0.1
netmask: 255.255.255.0
default gateway: 192.168.0.2

client computer network card: (hehe, then)

IP: 192.168.0.2
netmask 255.255.255.0
default gateway: 192.168.0.1
0
dew_associatesCommented:
lalaevil, you are new to this site, and with that, welcome. However, unlike Newsgroups and Usenets, we observe a protocol or policy at this site with which you should become familiar. Experts do not post proposed answers that are incomplete or that are speculative, nor do they post proposed answers that incorporate the comments of others that have preceded you. By doing so, you block the question from the view of another expert who may have a solution to the problem. Since questioners can accept comments as answers, it is beneficial to the questioner that speculative answers be posted as comments, especially when the issue involves further troubleshooting. Hopefully you will cooperate with us in the future.

Dennis
0
kiko1234Author Commented:
OK, I'm aware of the Internet Connection Sharing, but let me say that this option is not something you can use on cable-modems it seems to be for Dial-Up Connections only (correct me if I'm wrong).

Let me be more specific about my problem. I have once succeded in conecting two networked win98 machines to a single cable-modem on one of the computers. On the client computer I edited the IP Addresses, Subnet Masks, and Gateway properties. I also tinkered with Computer Name and Host options. Suddenly it worked. I was using NetBEUI and TCP/IP as protocols for my network. Now, I don't know if I should have both or just TCP/IP in order to make this work. The IP Address, Gateway, Subnet Mask on my client computer were very similar to the setings on my Server (computer w/ cable-modem) but I forgot what I did. (I'm writing stuff down now). One of the questions two is, do I have to use a Proxy software, because the first time around I created a Proxy out of the Server w/ no software. I don't know what I did. I just hope I'm not confusing you guys. I appreciate any help. Thanks in advance.

lalaevil: I cannot take your answer because it is not the solution and if it was it just doesn't tell me enough. You are wellcome to try again though.
0
dew_associatesCommented:
Kiko, indeed you can share a cable modem, and you can use Win98 ICS to do it too. I've done it with both cable modems and xDSL.

Here's a URL that will help you.

http://duxcw.com/digest/Howto/network/win98se_cab/intro.htm


Let me know if you need any help.

Dennis
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
trekie1Commented:
heres another site that may help...   James
http://www.cablemodemhelp.com/lanconnect.htm
0
kiko1234Author Commented:
Adjusted points to 60
0
kiko1234Author Commented:
I'm very close to getting this going. The web site Dew Associates had sent me to was great but one thing remains a mistery. Why can't I still connect. I have the Client's DNS Enabled with a Client's name as a Host name and DNS Server Search Order is the ISP's DNS server. This two things were done acordingly to what an article in TechNet described. The server (Gatway)computer has it's DNS Enabled as well and the Host name is the one that server has as its name. Both Internet adapters on the server have the same DNS host name as I realized that if I change one the other is changed automaticlly.
I have folowed step by step the instructions from both TechNet and DUX Computer Digest, the web site Dew Associates had sent me to. My Internet Options in the browser are set as told in the article and the two PC do comunicate but the internet conncection through the cable modem is still not being achived.
0
dew_associatesCommented:
Kiko,

Are you certain that you've checked everything? Is ICS, via Network Address Translation (NAT) mapping the LAN Internet Protocol (IP) addresses properly to Internet IP addresses and vice versa?

ICS uses a simplified Dynamic Host Configuration Protocol (DHCP) *and* a Domain Name Server (DNS) proxy which together manage IP addresses and Internet name resolution requests (translates names of computers on the Internet to IP addresses) for client computers on the LAN. Is DHCP and DNS working correctly?
0
kiko1234Author Commented:
Well, how do I find out whether ICS is mapping the LAN Internet Protocol (IP) addresses properly to the internet and vice versa?
DHCP per se is desabled I have assigned static addresses to my LAN. Now on the question of whether my DNS is working properly, I don't know. I know that computers see each other on the LAN and that the server computer get on the web successfuly. The DNS is enabled and both the client and the server have their respective Host names filled in. In fact and to be honest with you guys, I had it woring two days ago, but then the person I'm helping had @home software reinstalled on the client computer which ofcourse erased all the settings that I gave it.

Thanks for sticking here with me boys.
 
0
dew_associatesCommented:
Use the client install disk and run it. Then reset your IP addresses.
0
kiko1234Author Commented:
Sorry it took me so long to credit this points, but I was busy. . .very busy. I just wish to thank every one.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows OS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.