Solved

NIC + settings for RH 6.0

Posted on 2000-02-19
22
333 Views
Last Modified: 2013-12-15
I need to configure my network card (I need to do whatever needs to be done to have RH see it: vendor says it is linux compatible).
I need the card to be set to IP 192.168.1.25 Subnet 255.255.255.0 DNS server 192.168.1.254 Gateway 192.168.1.254 Workgroup Home

Card is Netgear FA310TX

Step by step instructions please!!!!
Kejtar
0
Comment
Question by:Kejtar
  • 12
  • 9
22 Comments
 
LVL 40

Accepted Solution

by:
jlevie earned 300 total points
ID: 2539304
There've been one or more discussions relating to how to get an FA310TX to work under Linux. I believe that which particular revision of the card that you have determines whether or not it will work the drivers that come with Linux or whether you'll need to use the the drivers from Netgear. this note appears on the FA310TX FAQ:

"Yes, we have added linux support recently. The driver is included in version 4.0 or higher driver set. This driver is available for download. It will work with all versions of our FA310 network adapter card. If you have NIC has a version identifier D1 or higher (printed on top right hand corner of the card), please make sure the driver on the supplied driver disk is used instead of the public domain tulip driver."

Since the FAQ is dated 20 Nov 98, it's not clear to me if the current version of the tulip driver (0.91g) available from http://cesdis.gsfc.nasa.gov/linux/drivers/tulip.html incorporates the changes necessary to support the D1 or later versions of the card.

I have seen references to D1's and later not being properly ID'd by the 0.89J version of the tulip driver. Version 0.89H is what ships with RedHat 6.1.

Okay, if your card is being detected, there should be an entry in /proc/pci for an "Ethernet controller" that says it is an FA310. The next step would be to run linuxconf, go to "Config->Networking->Client tasks->Basic host information->Adapter 1", select "Manual" and fill in the blanks for "Primary name", "IP address" and "Netmask". Select eth0 for the "Net Device" and mark the adapter "Enabled". "Accept" the settings and go to "Name server specification". Enter the "default domain" and IP's of the name servers and "Accept" the settings. Then go to "Routing and Gateways->Set defaults". Enter the gateway IP and "Accept"  the settings. Finally click on "Act/Changes" and then click on "Activate the Changes". Quit linuxconf and reboot.

Watch for any error messages as the system comes back up. If everything works there'll be no "Failed" messages.

Check the status of the interface with "ifconfig -a". It should be "UP" and "RUNNING" and be bound to your IP. Next check the default route with "netstat -rn". There should be a destination of 0.0.0.0 (default) with a gateway of 192.168.1.254. Then check the contents of /etc/resolv.conf. Your domain should be in the search line and the nameserver(s) listed.

Try a ping to the gateway, and the dns. Both sould be reachable. Also an "nslookup" of some system. If everything has worked so far you should be "on the net" and ba able to bring up a browser and surf. If you didn't get this far, tell us how exactly how far you got and what error occured.
0
 
LVL 1

Author Comment

by:Kejtar
ID: 2539368
OK, I followed the instructions, and what I found was that the listing in the PCI listed a network card, but had it with a different name.  Then when I did all the changes and rebooted, card failed to initialize (eth0).  Here are the contents of the PCI dealing with the adapter

Bus  0, device  15, function  0:
    Ethernet controller: LiteOn LNE100TX (rev 33).
      Medium devsel.  Fast back-to-back capable.  IRQ 10.  Master Capable.  Latency=64.  
      I/O at 0xe400 [0xe401].
      Non-prefetchable 32 bit memory at 0xeb000000 [0xeb000000].


Kejtar
0
 
LVL 1

Author Comment

by:Kejtar
ID: 2539369
BTW I am using Red Hat 6.0
Kejtar
0
 
LVL 40

Expert Comment

by:jlevie
ID: 2539378
Okay, that looks suspiciously like the tulip driver mis-identifying the card. I'd reccomend opening the case and finding out exactly what you've got, per Netgear's notice. If it looks like one of the late cards (most likely scenario), then you could try either the latest tulip driver, or the Netgear variant. I think I'd try the Netgear driver first, since you are running 6.0 and that OS release matches pretty well with the date in the Netgear FAQ.
0
 
LVL 1

Author Comment

by:Kejtar
ID: 2539408
I tried both the tulip from the nasa website, and the Netgear one.  Still the same entry in the PCI, (I would like to point out that it is grabbing the right IRQ for it).  

Anyways, I am really stuck now.
Kejtar
0
 
LVL 40

Expert Comment

by:jlevie
ID: 2540328
Have you checked to see which version of the card it is? It's possible that the one you have should be ID'ing that way, but I would have expected to see something else. Where is it failing, at boot with a "Failed" notice? What do you see if you do a "ifconfig -a"?
0
 
LVL 1

Author Comment

by:Kejtar
ID: 2563590
I have been running low on time recently, and I did not open my case till now: my card is revision D1...
I will answer the rest of questions by later tomorrow.
Kejtar
0
 
LVL 1

Author Comment

by:Kejtar
ID: 2601514
I was out of town for over a week, so I had no way to work on my problem till now, anyways............

On bootup it says:
initializing lo [SUCESS]
initializaing eth0 [FAILED]
delaying the initialization of eth0
............

Also tulip still sees my networking card as a Ethernet controller: LiteOn LNE100TX (rev 33).
     
Kejtar
P.S.  Like I said, my card revision is D1.
0
 
LVL 1

Author Comment

by:Kejtar
ID: 2601527
Adjusted points to 200
0
 
LVL 40

Expert Comment

by:jlevie
ID: 2602081
What does ifconfig say? And is PnP mode enabled in your bios, if so turn it off.
0
 
LVL 1

Author Comment

by:Kejtar
ID: 2602147
Here is what ifconfig says:
lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:3924  Metric:1
          RX packets:50 errors:0 dropped:0 overruns:0 frame:0
          TX packets:50 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0

and PNP change made no difference either.  Same fail notice
Kejtar
0
Get up to 2TB FREE CLOUD per backup license!

An exclusive Black Friday offer just for Expert Exchange audience! Buy any of our top-rated backup solutions & get up to 2TB free cloud per system! Perform local & cloud backup in the same step, and restore instantly—anytime, anywhere. Grab this deal now before it disappears!

 
LVL 40

Expert Comment

by:jlevie
ID: 2603267
Okay, the kernel is definitely not recognizing the card, as I've suspected. Let me go find the reference that I had before about that card.
0
 
LVL 1

Author Comment

by:Kejtar
ID: 2603423
Adjusted points to 300
0
 
LVL 1

Author Comment

by:Kejtar
ID: 2603424
I'd appreciate it..............  I looked all over the web myself, and some books, and all they describe is the general steps....
Kejtar
0
 

Expert Comment

by:Magician
ID: 2642753
(Not being sarcastic)
Have you read the linux.txt file that comes on your driver disk?

1.  During installation of Linux, make sure that the "C Development"
        selection is choosen under "Component to Install" window.  This will
        copy the C compiler into the system for compiling the driver.

    2.  Also the Network Configuration window during installation, you will
        be asked if you want to configure LAN (not dailup) networking for
        your installed system.  Answer YES.

    3.  Insert the floppy disk with the FA310 driver, and mount the disk into
        the system with the following command:

          mount -t msdos /dev/fd0 /mnt

    4.  Copy the Linux-related files from the disk into the system hard disk
        with the following command.  Four files will be copies: "cctulip",
        "tulip.c", "Copying", and "linux.txt".

          cp /mnt/linux/*.* .

    5.  Compile tulip.c by executing the "cctulip" command at the prompt.
        The following command will be executed.

          gcc -DMODULE -D__KERNEL__ -I/usr/src/linux/net/inet -Wall -Wstrict-prototypes -O6 -c tulip.c

    6.  Find the names of the files in the /lib/modules directory.  You
        might see the following directories.

          eg. "2.0.36-0.7" and "preferred".

    7.  Copy the newly compiled tulip.o into the latest kernel's modules.

          cp tulip.o /lib/modules/2.0.36-0.7/net/tulip.o

    8.  Reboot the system.

    9.  You can check if the driver is properly activating the card using
        the "dmesg" command right after system bootup.

Step by step, there is everything you have to do to make sure that you're using the latest driver.  If this doesn't work, I would recommend getting a new network card.

Hope this helps.
0
 
LVL 40

Expert Comment

by:jlevie
ID: 2642861
Son of a gun, this is the fifth time in the last two weeks that I've found one of my comments that I know I posted missing from a question...

What was supposed to be right after your last comment on the 9th was...

The Netgear card is supported by the the tulip driver. The config options for the card are on http://cesdis.gsfc.nasa.gov/linux/drivers/tulip.html as is the latest (0.91G) version of the driver. The command to compile the driver is the "compile-command" in the comments at the very end of the driver source.

After the driver has been installed in your /lib/modules area, you can try to load it with "insmod tulip.o debug=1 options=0" which would load it in "Auto-select" mode. It may not work all that well (or possibly at all) in auto-select mode. You can force 10Mbps 10baseT with "options=12", and so forth per the table. If you can't use the default option of 0 in your set up, you'll need to add a line to /etc/conf.modules like:

options tulip 12
0
 
LVL 1

Author Comment

by:Kejtar
ID: 2649445
ok, I have downloaded the driver from the website, but for some reason all of the compile commands come up with whole bunch of warnings leading me to believe that the .o file will not be properly setup for my machine.   So what would you all think about me trying to run an installation of redhat as an upgrade, and provide it with the path to the network card tulip driver during install?

Kejtar
0
 
LVL 40

Expert Comment

by:jlevie
ID: 2650480
I think 6.1 has a late enough tulip driver to work as is, although you might have to specify a media option in /etc/conf.modules.

What warnings did you get. Most of the time warnings are just that and don't affect the compiled .o file.
0
 
LVL 1

Author Comment

by:Kejtar
ID: 2652139
Is there any way to dump the warning messages into a temp file while compiling?
Kejtar
0
 
LVL 40

Expert Comment

by:jlevie
ID: 2653057
Yep, there is. If I want the results to be placed in the file /tmp/gcc-results, I'd do:

gcc -o gork gork.c >/tmp/gcc-results 2>&1

The bit with 2>&1 causes both stdout and stderr to become the same stream, so everything goes into the results file.
0
 
LVL 1

Author Comment

by:Kejtar
ID: 2695697
A for persistence and helpfullness.... and of course for correctness.

As a side note, I took a little bit different approach to it to solve it though.  What I ended up doing is downloading RH 6.2 and installing it.  Then during install I have chose one of the DEC network cards and it work ( dec card has the same parameters and tulip drivers as mine.)
Thanks for all your help
Kejtar
0
 
LVL 40

Expert Comment

by:jlevie
ID: 2696238
I believe that worked because 6.2 has the latest tulip driver. We probably could have sorted out the difficulty with 6.1, but 6.2 is a bit nicer in several other respects (and it does have a later kernel...) so it's a good solution also.
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

Daily system administration tasks often require administrators to connect remote systems. But allowing these remote systems to accept passwords makes these systems vulnerable to the risk of brute-force password guessing attacks. Furthermore there ar…
Introduction We as admins face situation where we need to redirect websites to another. This may be required as a part of an upgrade keeping the old URL but website should be served from new URL. This document would brief you on different ways ca…
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

21 Experts available now in Live!

Get 1:1 Help Now