Solved

Changin login prompt

Posted on 2000-02-21
6
249 Views
Last Modified: 2013-12-16
I am setting up a  Linux dialup server, and would like for Windoze users to be able to log in without having to use a script. I'm not sure exactly why the Windoze machines will not log in without a script, but I believe it has to do with the login prompt that's presented by the dialup server. Currently it is "<machine name> login:" I believe if it would be just "login:" the win machines would login automatically. If I'm wrong on this please let me know, if not, please advise on how to change the login prompt.
Thank you,
0
Comment
Question by:tibori
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
6 Comments
 

Expert Comment

by:i_wichmann
ID: 2543690
/etc/issue.net is the configuration-file you ar looking for
0
 
LVL 3

Author Comment

by:tibori
ID: 2543749
This file only has the first set of information in it, specifically:
"Redhat Release 6.1(Cartman)
Kernel 2.2.12-20 on an i586"

It doesn't contain the login prompt. Do I need to edit this or the script in rc.local to change the prompt?
0
 
LVL 3

Author Comment

by:tibori
ID: 2544078
I need the config file to change the actual login prompt from "<machine name> login:" to just "login:". I think it's a parameter either under rc.sysinit or something passed to /bin/login but I'm not sure
0
Ransomware: The New Cyber Threat & How to Stop It

This infographic explains ransomware, type of malware that blocks access to your files or your systems and holds them hostage until a ransom is paid. It also examines the different types of ransomware and explains what you can do to thwart this sinister online threat.  

 
LVL 21

Expert Comment

by:tfewster
ID: 2544134
Have a look in /etc/services: the listeners defined in there can be started up with various options (e.g. telnetd can be started with -b /path/newbanner)

You'll still need to look at the man pages for the various listener services to see what the options are...
0
 
LVL 3

Accepted Solution

by:
monas earned 20 total points
ID: 2546993
tibori,

      First. I doubt that MS will be able to work without script even if you will achieve that your RH box will say only "login:". This is due to fact that all windows based dialup servers do not provide login:/password: prompts. They get this information incapsulated into PPP messages. IMHO if you want to go without script - you should provide the same schema. Let's try to achieve this...

      First - you need to start from program that "picks your phone". I don't have RH at hand so I could not say for sure, but under linux all these programs  are named *getty. Take a process list and search for exact name "ps -ax|grep etty"

      Most likely this program will be started "from inittab" - so to do any changes on it - you may need to edit /etc/inittab and to commit changes - issue command "telinit q".

      For dialup line handling I do use mgetty. It's config files on my system are in /usr/local/etc/mgetty+sendfax directory. And if you uncoment line /AutoPPP/ you may achieve that this program will start ppp deamon upon receiving a call.

      When you went so far - you _MUST_ configure your PPP to require that called authenticate itself before transfering information. To do this - look into /etc/ppp directory. There is file "options". Make sure you uncomment "auth". Authentication method is up to you, but I would recoment uncommenting "+chap" option.

      This is [IMHO] way to go. Good Look!
0
 
LVL 3

Author Comment

by:tibori
ID: 2547686
Sadly, I think you're right. I've played around with AutoPPP already, but I haven't been able to work, probably because the mgetty rpm I used did not have AutoPPP compiled into it by default. Anyways, I HAVE been able to change the login prompt to just login: and you're right it doesn't work. Just for reference to others though the way to change the login prompt for mgetty is either by putting "login-prompt <login prompt>" into the /etc/mgetty+sendfax/mgetty.config file or by passing it the -p <loginprompt> option through the command line. The default prompt: <machine name login:> is precompiled into the kernel. The nice thing about this command is that you can change the login prompt for each modem you have and add all kinds of information to it.
monas: I will try the auth option and get back to you.
Thanks
0

Featured Post

[Webinar] Code, Load, and Grow

Managing multiple websites, servers, applications, and security on a daily basis? Join us for a webinar on May 25th to learn how to simplify administration and management of virtual hosts for IT admins, create a secure environment, and deploy code more effectively and frequently.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Network Interface Card (NIC) bonding, also known as link aggregation, NIC teaming and trunking, is an important concept to understand and implement in any environment where high availability is of concern. Using this feature, a server administrator …
SSH (Secure Shell) - Tips and Tricks As you all know SSH(Secure Shell) is a network protocol, which we use to access/transfer files securely between two networked devices. SSH was actually designed as a replacement for insecure protocols that sen…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial

742 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question