Solved

undoing runlevel set to auto start X at bootup

Posted on 2000-02-22
5
286 Views
Last Modified: 2013-12-15
I have the runlevel set so it launches the graphical (X) login when I boot. I was messing with the display settings yesterday and crashed the system. I had to hard reboot. When the system came up, the graphical parameters were invalid so it couldn't boot into X but I can't get a text login prompt. I tried hitting Ctrl-Alt-Fx keys but nothing. The screen just keeps flickering.

i'm not on a network so I can't login remotely and change the runlevel. Is there any way when I'm booting up to break out before it tries to start the X login? I tried ctrl-alt-backspace but it doesn't kill the X server.

thanks.
0
Comment
Question by:nicholso
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
5 Comments
 
LVL 1

Expert Comment

by:bcoleman
ID: 2546955
Have you tried your boot disk?  It should bring you to a text based system login for root, where you could change the runlevel that way.
0
 
LVL 3

Expert Comment

by:iharding
ID: 2546966
If you are using LILO, you can send the bootloader the following command to boot into single user mode:

LILO: linux 1
0
 
LVL 40

Expert Comment

by:jlevie
ID: 2547133
Or you can use "linux single" at the lilo prompt. The graphical login is most likely being started from /etc/inittab and once up in single user mode you can comment out that line (probably looks something like "x:5:respawn:/etc/X11/prefdm -nodaemon") and then be able to all the way to multi user mode, if need be.

You ought to be able to fix the X config problem in single user mode with Xconfigurator o xf86config... But you probably already knew that...
0
 

Author Comment

by:nicholso
ID: 2547302
Thanks, jharding. That's what I needed to know. Also thanks for the help jlevie, yeah I already knew about inittab, I'm familiar with how the runlevel stuff works but just needed to get a text prompt.

Post a dummy answer jharding and i'll give you the points.
0
 
LVL 3

Accepted Solution

by:
iharding earned 100 total points
ID: 2548238
You are welcome.
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Postfix issues with spam/auth attempts under NAT 9 131
Weird Samba Connectivity Issue... 7 65
I NEED A "BARE" LINUX ... 9 86
Enable SPF on IMSVA 6 18
Using 'screen' for session sharing, The Simple Edition Step 1: user starts session with command: screen Step 2: other user (logged in with same user account) connects with command: screen -x Done. Both users are connected to the same CLI sessio…
Introduction We as admins face situation where we need to redirect websites to another. This may be required as a part of an upgrade keeping the old URL but website should be served from new URL. This document would brief you on different ways ca…
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

763 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question