Solved

sound not working

Posted on 2000-02-23
10
234 Views
Last Modified: 2013-12-15
I have a sound card with an AD1816 chip.
Under RH5.1 there were no problems with this, however, since installing RH6.0 there is no sound at all.  

Linux always says "device or resource busy".  Is there any workaround for this problem?

Thanks for any answer.
0
Comment
Question by:ppblue
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
10 Comments
 
LVL 1

Expert Comment

by:toneus
ID: 2549689
Have you tried to use sndconfig (the soundconfig tool) to resetup your soundcard ??

Ton
0
 
LVL 2

Expert Comment

by:bernardh
ID: 2552541
some variable names have changed from 2.0.x to 2.2.5 kernels.try to edit the /etc/conf.modules and change 'dma=x,y' to 'dma=x dma2=y' or to 'dma=x dma16=y' (for SB16 compatible sound cards).
0
 
LVL 2

Author Comment

by:ppblue
ID: 2556405
The sound card configuration was the first I tried...useless.

bernard:
The values were already configured as you mention, in my file.

The problem remains:
I still get the"device or resource busy" message during startup.  IRQ and DMA are set as specified by the manufacturer.
0
Back Up Your Microsoft Windows Server®

Back up all your Microsoft Windows Server – on-premises, in remote locations, in private and hybrid clouds. Your entire Windows Server will be backed up in one easy step with patented, block-level disk imaging. We achieve RTOs (recovery time objectives) as low as 15 seconds.

 

Expert Comment

by:WhiteFalcon022100
ID: 2557065
I think the problem is the same I have had with my sound card.
In the new Kernel there is the OSS fully implemented and you tried to initialyse the sound card two times.

One time you have configured the sound card in teh kernel, and so it tries two initialise the sound card with the kernel.
The second time you initialise the sound card with your isapnp.conf. Try to edit your isapnp.conf that it do not try to initalise the sound card.

Then it should work.


0
 
LVL 2

Expert Comment

by:bernardh
ID: 2559121
try the advanced linux sound architecture. this has fixed many sound configuration woes as many sound cards are supported.

 download three files (driver, library and utils) from www.alsa-project.org.

installation is a flash. documentation and everything can be found on the site.

0
 
LVL 2

Accepted Solution

by:
nirsim earned 200 total points
ID: 2561286
Hi There,

  Try the following procedure:

1. goto /etc
2. look for a file called isapnp.conf
3. if it's there, edit it. If not, it could be copied from a location
    in /usr/[somepath] (do a find to get it)
4. add the following line to the start of it
    (LDVERIFY N)
5. now run sndconfig again

this should solve the problem, it usually helped me.

Best regards,
  Nir Simionovich
  artNET experts, Ltd
  Israel
0
 
LVL 3

Expert Comment

by:freesource
ID: 2573634
Sometimes when you see this "device or resource busy", it means exactly that.  Unless other hardware is using the same IRQ as the sound card, another possiblity is that there is already a program running utilizing the sound card.  For instance: Network Audio System (NAS) is running as a daemon.
0
 

Expert Comment

by:high_flyer021700
ID: 2624849
hey!

this really sounds stupid but i did it this way....i installed 5.2...ran sndconfig...got the sound thing configured....copied the /etc/conf.modules file to windows partition...installed 6.1....overwrote conf.modules to /etc/...

tiresome...hey...it works...
0
 
LVL 2

Author Comment

by:ppblue
ID: 2857570
Answer accepted
0
 
LVL 2

Author Comment

by:ppblue
ID: 2857571
I am afraid that all the suggestions did not work. I would like to close the problem for the moment and wait until the next upgrade to see what happens.

Thank you all.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Setting up Secure Ubuntu server on VMware 1.      Insert the Ubuntu Server distribution CD or attach the ISO of the CD which is in the “Datastore”. Note that it is important to install the x64 edition on servers, not the X86 editions. 2.      Power on th…
In the first part of this tutorial we will cover the prerequisites for installing SQL Server vNext on Linux.
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

734 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question