Error adding another 3-Com NIc Card

I am running RH 6.0
I have a 3-Com 3c509b NIC(ISA) in my machine now. It worked fine. I just put another card (the exact same one) . I reboot and i get:

 eth0: Inifinite loop in interrupt, Status 2001.

 I know this is an IRQ/IO  problem, but how can I get into to fix it.

Both cards are ISA and I do not see any jumpers on them.  How can I specify one of the cards to use a different IRQ/IO?
kipper7Asked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
dcavanaughConnect With a Mentor Commented:
If you are looking for information on the io addresses and ports that are already being used, try these commands:

cat /proc/ioports
cat /proc/interrupts

In conf.modules, I suggest you specify the io and irq.  The following example assumes you have cards at 03x300/5 and 0x310/10.  Your actual mileage may vary.

alias eth0 3c59x
alias eth1 3c59x
options 3c59x io=0x300,0x310 irq=5,10

Jlevie is right about needing the 3com setup disk.  The program is called 3c5x9cfg.exe and you can get it from http://www.3com.com if necessary.  While you're at it, force the media type to UTP.  Auto-selection of media type is a common problem on the 3c509.  I don't remember if that card is capable of full-duplex or not.  You probably want to force half-duplex.  Shut off the power after you change the card configuration and exit the utility.

Another common problem is ROM BIOS on PCI+ISA boards.  If you still have problems, go into BIOS setup and look for a "PCI Bus Configuration" section.  Force the interrupts from "auto" to "manual" and then you can specify "Legacy/ISA" for your NIC card interrupts.  
0
 
jlevieCommented:
You have to use a 3Com utility to configure the card. The utility typically is incuded on the first diskette of the set that ships with the drives and you'll need a bootable dos diskette to use it. If you don't have the diskettes, you can download the configuration tool from 3Com's site.

Since those are 3c505b's you'll want to turn off PnP suuport in the cards when you set the IRQ & I?O port. Also, you'll need to modify /etc/conf.modules to support bot of the cards, take a lookk at the Ethernet HowTo for details.
0
 
lewisgCommented:
Both jlevie and dcavanaugh have said just about all that needs to be said Hovever I just can't resist...

For RH all that needs to be in conf.modules is the following:

alias eth0 3c509
alias eth1 3c509

When you set up the cards with 3c5x9.cfg you can only have one card at a time in the machine. I use a bunch of these cards and my favorite settings are:

1st card - IRQ:5 IO:300 (assuming no soundcard or LPT2)
2nd card - IRQ:10 IO:240
common settings: no modem, server optimization, and as has been noted by dcavanaugh if the card is a combo card (more than one type of connector on the back) BE SURE to set the tranceiver to the correct type. I guess there was a reason for the IRQ/IO settings when I started but now they are just in the old & reliable category.

After you set up a card it is a good idea to write the IRQ/IO on the back where it will be visible from outside the case!

I am sure there is some logic to the way linux decides which card is eth0 or eth1. The most foolproof way I have found to sort them out if by running ifconfig (/sbin/ifconfig). It will give you bunches of information in addition to the IRQ/IO settings.

I have never had a problem with a 3c509 and I think everyone should keep one in their toolkit for troubleshooting.
0
 
kipper7Author Commented:
I figured it out in the meantime. I simply added disabled pnp in the BIOS and added and append=  ether..blah blah to lilo.conf.  Then went in and configured the card.
Works fine..thanks anyway
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.