[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 373
  • Last Modified:

Keyboard is not working properly

I have installed SCO Unix 5.0.5 in a IBM Netfinity P-III server and network is on ethernet and using TCP/IP protocol. We ahve successfully connected the DOS 6.22 workstation with SCO system via third party telnet software. But when we try to run Foxpro for Unix version from the terminal the key BACKSPACE, DELETE, CTRL+T/Y does not work and the graphics screen of the foxpro looks shattered. When log in prompt shows on the terminal at that time if we press BACKSPACE to delete any character the cursor goes to next line and one column wider than the prevoius line.
For your information terminal type is VT-100.
Can anyone solve these problems.
Thanks
0
tauhid_bd
Asked:
tauhid_bd
  • 3
  • 2
1 Solution
 
tfewsterCommented:
Terminal type doesn't get set (at the Unix end) until you've logged in, so you can expect some odd results from BACKSPACE etc. If you log in to a Unix shell, does BACKSPACE work then? Does "clear" clear the screen?

If not, do "echo $TERM" while logged in to check the terminal type set at the Unix end & double check the setting for the terminal emulator.

You can set BACKSPACE up manually with
stty erase BACKSPACE (& include it in your startup files).

Which telnet/terminal emulator software are you using?
0
 
tauhid_bdAuthor Commented:
When I logged on on Unix from the terminal BACKSPACE key does not work properly and 'clear' commands does not clear the screen.

I will try with this "echo $TERM" command.
I am using NSCA's telnet for DOS and sometime NUPOP. Nupop is mailing software under DOS>
0
 
tfewsterCommented:
OK, if the BACKSPACE key & "clear" command don't work at the Unix command line, there's a mismatch in the terminal type. I'm not familiar with the NSCA utilities, so I can't tell you how to check/set the emulation type at the PC  end - if you don't have the manuals it may be easier to experiment at the Unix  end.

Set the terminal type in Unix with "TERM=vt100;export TERM" (Or "setenv TERM  vt100" if you  use the c-shell).

Once we've got the right terminal type, we need to make sure it gets set correctly when you log in.

2 other things that would be worth trying (if possible); If you have a VT100 terminal, try connecting that in place of the PC. If you have a Win95/98/NT PC, try telnet on that and see if you get the same results.

Let me know how you get on
Tim
 
0
 
tauhid_bdAuthor Commented:
Let me try on to export the VT-100 terminal. I will let you know within few days.
By the way do you any other software in your knowledge which can connect a DOS machine to a windows machine ?
0
 
tfewsterCommented:
As you haven't come back to me, I assume setting the terminal type resolved the problem.

You can set this automatically when the user logs in by putting the command in their .profile or .cshrc file.

If the user uses other terminals, or if other people use that terminal, you may need some additional code in these files to test the terminal type before resetting it, e.g.

if [ $TERM = "unknown" ]
then
  TERM=vt100;export TERM
fi

To give you a more definite answer I need to know:
- What shell the user(s) use;
- What "echo $TERM" reports on that terminal and others.

Regards, Tim
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now