Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

browsing samba server with Win95

Posted on 2000-02-23
6
Medium Priority
?
263 Views
Last Modified: 2010-03-18
I have a linux box with Redhat 6.1 installed and a Win95 box networked together.  I can mount the windows box on the linux box using smbmount fine and dandy, but when I try to look at the contents of my linux box, I can see the samba server and the name for it in network neighborhood, but when I try to look at it, is give me the message "\\linux is not available, the network is busy"  can anyone help?  I have samba started already.

Thanks
0
Comment
Question by:mattman
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
6 Comments
 
LVL 10

Expert Comment

by:rbr
ID: 2553446
Post your smb.conf file pls.
0
 

Author Comment

by:mattman
ID: 2556624
I erased my smb.conf file and put in the [global] [homes] and [printers] sections so linuxconf could configure it.  Then I set everything like disk shares and stuff up and now I can see the samba server on the Win95 box, but it still does the same thing when I double-click it and try to look at the contents, except now it says

"//Matt is inaccessible

The specified computer did not recieve your request, please try again later."

where //Matt is the samba server.

Here is a copy of my smb.conf file.[global]
    unix password sync = yes
    comment = linux
    workgroup = Despain
    encrypt passwords = yes
    security = user
    map to guest = never
    password level = 0
    null passwords = no
    allow hosts = despains
    os level = 0
    preferred master = no
    domain master = no
    wins support = no
    dead time = 0
    debug level = 0
    load printers = no
   


[homes]

[printers]
[linux]
    browseable = yes
    path = /windows
    public = yes
    guest only = no
    writable = yes
    only user = no
    allow hosts = despains
    user = despains
    valid users = despains


0
 
LVL 1

Accepted Solution

by:
mmips earned 200 total points
ID: 2562670
Questions.

1. does the linux machine have a user that has the same username and password as the win95 machine? If not you can create a user map file and place it in the /etc directory. Name it username.map. Use the following format:

root = administrator admin
userName = someOtherUser anotherUser

Then add an entry to the global section :

username map = /etc/username.map

2. is the win95 workgroup name Despain?

Now, in the global section add an entry:

netbios name = YourServerName

in the allow hosts entry use a whitespace separated list of ip's...i.e.

hosts allow = 127.0.0.1 [Your IP 192.168.1. leave off the last to allow all machines on your local net access]

Since you have encrypt passwords = Yes, Did you create the smbpasswd file?

Have you added all network computer names/IP addresses to the /etc/hosts file.



0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 1

Expert Comment

by:mmips
ID: 2562675
As a second example here is a simple working smb conf file from our test RH6.1 server.

# Global parameters
[global]
      workgroup = HOME
      netbios name = EINSTEIN {Your Computer Name goes here}
      interfaces = 192.168.100.59/255.255.255.0 {Your Linux box IP goes here}
      security = SERVER
      encrypt passwords = Yes
      hosts allow = 192.168.100. {Only allow computers on my subnet}

[All]
      path = / {This exports all directories}
      read only = No
0
 

Expert Comment

by:lugnut1221
ID: 2565307
try smbadduser linuxname:NTname

so for instance if your log on name for windows is joe then use

smbadduser joe:joe
it will ask you to enter the password you want to use.  Now just log on to the windows box using joe and the password and you should be fine
0
 

Author Comment

by:mattman
ID: 2567055
Thanks a lot, everything works great.  I'd spent about 3 weeks on this problem before I got your answer, thanks again.
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…
Visualize your data even better in Access queries. Given a date and a value, this lesson shows how to compare that value with the previous value, calculate the difference, and display a circle if the value is the same, an up triangle if it increased…
Suggested Courses

618 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question