• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 395
  • Last Modified:

ppp problem

I had dial up working perfectly since recently. Without any interference of mine the dial up
script failed to work. I have tried to debug it to locate the problem examining the log file
and it says modprobe: can't locate module ppp-compress-21
                modprobe: can't locate module ppp-compress-26
                modprobe: can't locate module ppp-compress-24
What is wrong. I doubt I mistakenly erased those modules. I even suspect my ISP
changed the login procedure, because before that problem I was able to connect manually
using minicom then ISP provided me with login prompt, but now all I see when I get
connected with minicom are some meaningless characters like my ISP would fire pppd
imediately the modems get connected.
0
Malensek
Asked:
Malensek
  • 4
  • 2
1 Solution
 
jyu_88Commented:
Add the following lines to your /etc/modules.conf:
 
alias ppp-compress-21 bsd_comp
alias ppp-compress-24 ppp_deflate
alias ppp-compress-26 ppp_deflate

The fact that your ISP won't give terminal login but  only PPP, is not really relevant.
0
 
jyu_88Commented:
or /etc/conf.modules as on RedHat
0
 
MalensekAuthor Commented:
Thanx for the answer, but I would really like to know what could caused that problem (my mistake or...).
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
jyu_88Commented:
new kernel? new init package?

A far-stretching story: this problem always exists. However, your ISP didnot support compression so there's no compression negotiation thus no loading compression module on your end. The recent change on your ISP may warrant compression module loading on your end thus the problem.
0
 
MalensekAuthor Commented:
**** happens, I am still not able to connect to my ISP. After the line is established I get a remote response : ^FM-eM-)5M-H^C^DM-@#^B^F then the modem waits a while and then hangs up.
0
 
jyu_88Commented:
your chat script probably still expects to do a terminal-style login first while your ISP has eliminated the terminal login part and are waiting for PPP request right after you get 'CONNECT blah blah 38400 orwhatever speed'.  The garbage is probably from the miscommni. and  it will possibly error out 'line dirty/not clean, whatever...'.

try to remove from the chat file the lines attempting to do the login, while add 'user yourISPuid' in the options file, assume your pap-secret or chap-secrets is setup.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 4
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now