Solved

RH6.0 network problems...

Posted on 2000-02-24
9
459 Views
Last Modified: 2013-12-15
I just installed rh6.0 and I have problems configuring the 2 3c509 ethernet cards. Just for now, I'm using the ip-addresses 10.100.66.57 and 10.100.66.58 with submask 255.255.252.0.
pinging to both addresses works. (to 127.0.0.1 also). But pinging to a computer on the local network works not.
With ifconfig, i can only see eth0 and lo, not eth1. When I disable one of the cards, using netconf, pinging from the other computer works, but when I ping from the linuxbox to the other computer, ping receives the packets twice!! pinging to the two addresses 57 and 58 works fine. (no double receives).
When disabling eth0 with netconf, ifconfig shows eth1 and lo, as expected.

Any Idea's? Please comments only, I will decide hwo's comment is worth the points.
0
Comment
Question by:940961sl
9 Comments
 
LVL 40

Expert Comment

by:jlevie
Comment Utility
Well of course. You can't have two NIC's configured for the same network & protocols. You set them boot up to be in 10.100.66.0/24 network.
0
 
LVL 1

Author Comment

by:940961sl
Comment Utility
I believe I tried it with 2 different network addresses before, with the same result, but I'll doublecheck. In fact, at the end, one card will listen to a dhcp server, and the second will be something like 192.168.1.1, but in this little testenvironment, i don't have a dhcp server and the network has address 10.100.66 so that's why I tried those two address. I'll change them.

In the mean time, any other suggestions?
0
 
LVL 40

Accepted Solution

by:
jlevie earned 200 total points
Comment Utility
Have you configured each of the 3c509's for different IRQ's and I/O ports and properly aliased them in /etc/modules.conf (see the section on 2 NIC's in http://howto.tucows.com/LDP/HOWTO/Ethernet-HOWTO.html). Also if the cards are 3c905b's you need to disable PnP on the cards. You configure the cards with 3Com's configuration tool (3c5x9cfg.exe), typically supplied on diskette with the cards and also available from their web site (http://support.3com.com/infodeli/tools/nic/3c509.htm#ship)
0
 
LVL 1

Expert Comment

by:tknayak
Comment Utility
what ur modprobe eth1 says?
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 
LVL 2

Expert Comment

by:nirsim
Comment Utility
Hi All,

  You are shooting at the wrong target. The 3c509 card is an ISA based NIC, with which RH6.0 has serious problems. Which means the following, due to an error in bridge.c in the RH6.0 distribution, it can't handle ISA based ethernet cards. I know this cause I suffered from it myself, and only a visit to www.redhat.com had given me the answer.

  My advice is, move to RH6.1

Regards,
  Nir Simionovich
  artNET Experts, Ltd
  Israel
0
 
LVL 40

Expert Comment

by:jlevie
Comment Utility
Let's not be too hasty... the 3c509 is on the HCL for RH 6.0 and I know that others have and are using it successfully. I may not be searching for the right thing, but I can't find anything on RedHat's site that indicates a problem... nirsim, wanna provide a reference?
0
 
LVL 1

Author Comment

by:940961sl
Comment Utility
Thanks for the response.
I solved the problem now. It was not due to the fact that the addresses belonged to the same network address, and it was not because RH6.0 can't work with ISA based NIC's. But it was like jlevie's second responce : both the cards were on irq 10, io-address 300. The cards i have came from a friend without any disks or documentation so I didn't know how to check or how to change the irq and io-address. 3c5x9cfg.exe did the truc. jlevie, please answer the question because i don't see the accept comment as an answer button anywhere...

And please, check out my next question :-)
0
 
LVL 1

Author Comment

by:940961sl
Comment Utility
Sorry nirsim,
I asked not to answer the question, and your aswer is totally wrong, so I have to reject it...
0
 
LVL 1

Author Comment

by:940961sl
Comment Utility
Aha, thats why I didn't see the accept comment as answer ...
0

Featured Post

IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

If you have a server on collocation with the super-fast CPU, that doesn't mean that you get it running at full power. Here is a preamble. When doing inventory of Linux servers, that I'm administering, I've found that some of them are running on l…
Using 'screen' for session sharing, The Simple Edition Step 1: user starts session with command: screen Step 2: other user (logged in with same user account) connects with command: screen -x Done. Both users are connected to the same CLI sessio…
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

744 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now