Solved

Dual boot Win98 SE and Winnt 4

Posted on 2000-02-24
13
465 Views
Last Modified: 2013-12-28
I have a delicate problem.
My computer that is installet with a dual boot Win98 SE (Second Edition) and Winnt 4 Wks will no longer boot up in Win98 SE.

How can I boot in Safe mode in Win98 SE?

First when I boot my computer I can shift between Win98 and Winnt, but when I choose Win98 it just starts as usual, but that don´t work, so I have to switch to Safe Mode.

Any solution?
0
Comment
Question by:qubiac
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 2
  • 2
  • +4
13 Comments
 

Expert Comment

by:ScottHinckley
ID: 2555128
Assuming that it does try to boot into Win98 but then dies.
Select the Win98 boot, then hit F8 to get the Win98 boot menu. Choose safe mode.
0
 

Author Comment

by:qubiac
ID: 2555816
I tried to hit F8, but nothing happens.
I even tried to hti F5 to load without any drivers, but again, nothing.
I even tried to hold the shift key when Win98 starts up, but again nothing.
It just hangs.
0
 
LVL 2

Expert Comment

by:AdamWoodland
ID: 2555935
The way I get into Safe Mode with Win98 on my quad boot machine is select the Win98 option in the list and as soon as you press enter, press F8 immediately (and a few more times incase the timing matters, but I never had aproblem with that yet). That sould bring up the F8 options that you are wanting.

If this isn't the correct situation that you are talking about, then reject this answer and possibly explain a little more detail and I will see what I can do.
0
Portable, direct connect server access

The ATEN CV211 connects a laptop directly to any server allowing you instant access to perform data maintenance and local operations, for quick troubleshooting, updating, service and repair.

 
LVL 1

Expert Comment

by:christalnet
ID: 2555940
it would sound as though you have written a data bit across your mbr that should not be there, try loading a boot manager such as pqboot or commander and see if you dont get the options you need,if all else fails,,format/mbr to restore the boot record to default, let me know if i can help you, been doing dual os a while now (christalnet@msn.com)
0
 
LVL 2

Expert Comment

by:wardog
ID: 2557693
I'd be willing to be that WIN98 is upset about the MBR change.  When you go into Safe Mode,  Open MSCONFIG --> Advanced Options,  force compatability mode disk access.  With this box checked,  hit OK to close MSCONFIG and it should reboot into normal mode.

I suspect that this will get you into normal mode, but then we'd have to figure out how to get it out of compatability mode.  Just post back if that gets you in.

Also, FORMAT /MBR isn't a legal command,  as far as I remember.  It would be a similar one that I know... but DON'T DO IT!!! NT will not boot if you do.

One more thing,  if you want to bring up the menu,  select Windows on the NT boot menu with the arrow keys.  Put your right index finger above the enter key and your left above the CTRL key.  IMMEDIATELY after you hit the enter key hit and hold the CTRL key.  It should bring up the 98 startup menu.

--Wardog


0
 
LVL 2

Expert Comment

by:AdamWoodland
ID: 2558023
Providing NT was installed after 98, the boot sector will be fine from that point of view (but another program may possibly have modified the boot sectors, e.g. a virus)

NT is 'W95 Happy' meaning it's booting process can handle both OS fine (this also extends to W98, but W98 is also 'NT Happy', but I haven't had any luck in this department)
0
 

Author Comment

by:qubiac
ID: 2558128
I have tried it, but it doesn´t work.
Though I will try the other solutions that I have got from Wardog.
We´ll se if it works.

/Qubiac
0
 
LVL 1

Expert Comment

by:christalnet
ID: 2558383
just use a boot manager and you won't have to concern yourself with what is "happy" or not, the boot manager will get you the options you need. problems like this are why we sit down and write programs for you to use with other os's
0
 

Expert Comment

by:fits000
ID: 2559015
Allow yourself to boot into Win98 as best as it will allow. When you get to the desktop, launch a DOS box. From the root of your C:\ drive, type the following;


attrib -r -h -s MSDOS.SYS


Next, use either notepad or edit (from DOS) to edit MSDOS.SYS. Under the [Options] section add a new line. It should look exactly like this;

BootMenu=1

After you save the file, type the following command from the DOS box at root of C:\,

attrib +r +h +s MSDOS.SYS

Finally, exit the DOS box and restart the PC. Now, when you choose the Win98 OS, you should get the menu of boot options that will include SAFE MODE.
0
 

Author Comment

by:qubiac
ID: 2560502
Well, I can´t access the DOS shell, because I can´t boot into my Win98. It just hangs when I´m booting up.

/Qubiac
0
 
LVL 2

Expert Comment

by:wardog
ID: 2560857
The computer locks as soon as you try the WIN98 option? Okay,  there's several reasons for this.  If you converted the boot partition to NTFS 98 won't boot.  Also if the files IO.SYS, BOOTSECT.DOS, MSDOS.SYS, or COMMAND.COM , or BOOT.INI were corrupted it won't either.

MSDOS.SYS and COMMAND.COM aren't the victims because they would generate error messages where the other two wouldn't necessarily do so.


IO.SYS could be copied from a WIN98 startup disk to C:\.

BOOT.INI should have the correct ARC name for Windows listed in there.  It looks something like "Windows = "C:\"",
but check your NT documentation to make 100% sure that's correct.  (Been a while since I've used NT4)

BOOTSECT.DOS is an image of a Windows boot sector,  and can't just be recreated. To fix this you would need to rerun setup for Windows 98.  Unfortunately,  while it is supposed to see NT on the drive and set itself up without hosing NT's boot sector,  I'd have my recovery disks for NT updated and ready just in case.


0
 

Accepted Solution

by:
foulc earned 20 total points
ID: 2564032
You may try to restall the system again to solve the problem.
I think the error is casue by the improper way of installation in WinNT.
I suggeest you destroy the partition with NT, by a fdisk command . than with a startup disk of win98 use the command fdisk /mbr
( To wardog, not format , is fdisk, they both are not legel command, as Microsoft claimed, but that is useful )
than reinstall WinNT in Win98 enviroment, but Windows, Normal Mode.
After the installation of WinNT , the OS Loader will prompt you to select , if you want to enter NT, NT vga mode , or Win98,
to enter safe mode , holding shift as you select Win98 , Till the message himem.sys ..... appears.

--Holy, Foulc
0
 

Author Comment

by:qubiac
ID: 2568430
Now it works, I found tried once more to hold down the SHIFT-key as I choosed to boot up into Win98.

The problem was an GFX driver that was incorrect installed. But now it is fixed, and it works great!

Thanks all for your help.

/Qubiac

Special thanks for foulc.

0

Featured Post

Don't miss ATEN at NAB Show April 24-27!

Visit ATEN at NAB Show to learn how our "Seamlessly Entertaining" solutions deliver fast, precise video streaming without delays for the broadcasting and media environment. ATEN will showcase its 16x16 Modular Matrix Switch (VM1600) and KVM Over IP Solution (KE6900 series).

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When you start your Windows 10 PC and got an "Operating system not found" error or just saw  "Auto repair for startup" or a blinking cursor with black screen. A loop for Auto repair will start but fix nothing.  You will be panic as there are no back…
A project that enables an administrator to perform actions within a user session context not just at the time of login but any time later on day(s) or week(s) later.
Windows 8 comes with a dramatically different user interface known as Metro. Notably missing from the new interface is a Start button and Start Menu. Many users do not like it, much preferring the interface of earlier versions — Windows 7, Windows X…
Windows 10 is mostly good. However the one thing that annoys me is how many clicks you have to do to dial a VPN connection. You have to go to settings from the start menu, (2 clicks), Network and Internet (1 click), Click VPN (another click) then fi…

756 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question