Solved

APACHE - PASSWORD/VIRTUAL HOST PRBLM ---)

Posted on 2000-02-24
8
230 Views
Last Modified: 2013-11-15
I am currently running APACHE as a web server and have configured .htaccess security files and the have worked propperly, that is they ask for a password when you come to a restricted area of the webpage. BUT ever since I have installed ANY virtual hosts it has not worked AT ALL ANYWHERE although the virtual host does. PLEASE SOMEONE HELP ME... thanks in advanced...
0
Comment
Question by:TENSOR
  • 5
  • 3
8 Comments
 
LVL 40

Expert Comment

by:jlevie
ID: 2556602
Do you mean that all user authentication stopped working, real and virtual instances? Or do you mean that the virtual hosts aren't honoring .htaccess files in their respective htdocs directories? Being able to see one of your virtual host config sections would help a lot in our being able to solve this problem.
0
 

Author Comment

by:TENSOR
ID: 2556696
############## THIS SECTION WAS ADDED BY SENTHIL - ###########
NameVirtualHost 63.194.81.67
<VirtualHost 63.194.81.67>
ServerName www.v-solve.com
DocumentRoot /somewhere/abc/html/
AccessFileName .htaccess
</VirtualHost>
########## LELANDSD.COM - SENTHIL #############################
<VirtualHost 63.194.81.67>
ServerAdmin fatalerror404@hotmail.com
ServerName www.lelandsd.com
DocumentRoot /somewhere/else/lelandsd/
AccessFileName .htaccess
</VirtualHost>
<VirtualHost 63.194.81.67>
ServerAdmin fatalerror404@hotmail.com
ServerName lelandsd.com
DocumentRoot /somewhere/else/lelandsd/
AccessFileName .htaccess
</VirtualHost>
################################################
0
 

Author Comment

by:TENSOR
ID: 2556698
Edited text of question.
0
 
LVL 40

Expert Comment

by:jlevie
ID: 2557334
First, you don't need to the "AccessFile" directive in each virtual host section. It's sufficient to declare it once in the global section. Typically one wants to have at the global level a piece like:

AccessFileName .htaccess
<Files ~ "^\.ht">
    Order allow,deny
    Deny from all
</Files>

Which defines the htaccess file name and prevents those files from being seen if the document directory is browseable.

The reason that your virtual hosts aren't requiring user authentication is that you've not told Apache to do so. Each directory to be protected must allow user authentication to be set up with an "AllowOverride Authconfig" directive. Also, there's a couple of other directives one should typically apply to a directory (especially a document root). So one of you virtual hosts should look like:

<VirtualHost 63.194.81.67>
ServerName www.v-solve.com 
DocumentRoot /somewhere/abc/html/
<Directory />
    Options Indexes FollowSymLinks
    AllowOverride AuthConfig
    Order allow,deny
    Allow from all
</Directory>
</VirtualHost>
0
Ransomware-A Revenue Bonanza for Service Providers

Ransomware – malware that gets on your customers’ computers, encrypts their data, and extorts a hefty ransom for the decryption keys – is a surging new threat.  The purpose of this eBook is to educate the reader about ransomware attacks.

 

Author Comment

by:TENSOR
ID: 2560161
Please post your awnsers as comments as the future, If they work I will acept it as an awnser...
0
 

Author Comment

by:TENSOR
ID: 2560185
I meant to accept that...please write it again and I will accept...
0
 
LVL 40

Accepted Solution

by:
jlevie earned 100 total points
ID: 2560295
First, you don't need to the "AccessFile" directive in each virtual host section. It's sufficient to declare it once in the global section. Typically one wants to have at the global level a piece like:

AccessFileName .htaccess
<Files ~ "^\.ht">
   Order allow,deny
   Deny from all
</Files>

Which defines the htaccess file name and prevents those files from being seen if the document directory is browseable.

The reason that your virtual hosts aren't requiring user authentication is that you've not told Apache to do so. Each directory to be protected must allow user authentication to be set up with an "AllowOverride Authconfig" directive. Also, there's a couple of other directives one should typically apply to a directory (especially a document root). So one of you virtual hosts should look like:

<VirtualHost 63.194.81.67>
  ServerName www.v-solve.com 
  DocumentRoot /somewhere/abc/html/
    <Directory />
      Options Indexes FollowSymLinks
      AllowOverride AuthConfig
      Order allow,deny
      Allow from all
  </Directory>
</VirtualHost>
0
 

Author Comment

by:TENSOR
ID: 2560401
thanks!
0

Featured Post

Backup Your Microsoft Windows Server®

Backup all your Microsoft Windows Server – on-premises, in remote locations, in private and hybrid clouds. Your entire Windows Server will be backed up in one easy step with patented, block-level disk imaging. We achieve RTOs (recovery time objectives) as low as 15 seconds.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
iptables limit connection per ip correct way ? 2 84
Linux Login using LDAP or Active Directory 4 110
Redirect mail server from IP to IP 2 90
restoring image to a different pc 20 102
By default, Carbonite Server Backup manages your encryption key for you using Advanced Encryption Standard (AES) 128-bit encryption. If you choose to manage your private encryption key, your backups will be encrypted using AES 256-bit encryption.
How to update Firmware and Bios in Dell Equalogic PS6000 Arrays and Hard Disks firmware update.
This tutorial will walk an individual through the steps necessary to enable the VMware\Hyper-V licensed feature of Backup Exec 2012. In addition, how to add a VMware server and configure a backup job. The first step is to acquire the necessary licen…
To efficiently enable the rotation of USB drives for backups, storage pools need to be created. This way no matter which USB drive is installed, the backups will successfully write without any administrative intervention. Multiple USB devices need t…

932 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now