Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1508
  • Last Modified:

Selected collating sequence not supported

I want to open an Access database in German windows that was created in English windows. I get the error message 'selected collating sequence not supported by the operating system'.
The Help file doesn't help, because there isn't a Paradox key in the Windows registry. At least not where the Help file says it should be.

Does anyone have a solution to this problem?
0
Richard3
Asked:
Richard3
1 Solution
 
TrygveCommented:
Create a file called FixCollatingProblem1.Reg and copy/paste this into it

REGEDIT4

[HKEY_LOCAL_MACHINE\Software\Microsoft\Jet\3.5\Engines\Paradox]
"CollatingSequence"="Ascii"

Then create another file called FixCollatingProblem2.Reg and copy/paste this into it

REGEDIT4

[HKEY_LOCAL_MACHINE\Software\Microsoft\Jet\3.5\Engines\Paradox]
"CollatingSequence"="International"

Now, try running the second one by doubleclicking on it, restart the machine and it should work. If that did not help, run the other file.

Now later on, if you get the problem run the file that changes the registry key.
0
 
TrygveCommented:
Access somehow needs this key to be able to read those "foreign" tables. I get this problem every time I receive MDBs from Sweden, which should be similar enough to my Norwegian tables...

You can also go directly into the registry and set the key if you are familiar with RegEdit. Remember to restart.
0
 
BrianWrenCommented:
What a pain...  I guess if you know what to do none of it's really hard, but still, what a pain...
0
Free Backup Tool for VMware and Hyper-V

Restore full virtual machine or individual guest files from 19 common file systems directly from the backup file. Schedule VM backups with PowerShell scripts. Set desired time, lean back and let the script to notify you via email upon completion.  

 
TrygveCommented:
Copy/Paste into a file with a spesified name and the execute the file can't be that hard? But I know what you mean, why do MS give us these puzzles? What effect should a Paradox setting have on Access?
0
 
Richard3Author Commented:
Thanks Trygve

but I went into regedit and like I said there was no Paradox key in my German windows - there isn't in my English windows either. I made a key, called it "Paradox" and gave it a string value "CollatingSequence" = "International". It didn't work so I changed it to Ascii. Again no luck.
There was a key called Xbase with a "CollatingSequence" so I changed that to. Didn't work.

I made this database in English NT4.
It works in Polish win95 but not in German or Dutch win95. My customers there need to use it and they know even less about windows registery than I do.

I think I'll have to reconstruct the database in German windows and import the data using Excel files.
I don't know so much about Databases but all this seems pretty ridiculous to me.
0
 
TrygveCommented:
Did you restart between each attempt? If you forgot then try again.
0
 
Richard3Author Commented:
Yes, several times
0
 
TrygveCommented:
Are your application MDB set up with "General" as the Database sort order? If not, you can get problems as the different language versions will try to force their sorting on the data.
0
 
TrygveCommented:
Also: Are the tables linked into the application MDB or do you keep all objects within one MDB

If you have one MDB, then you should try moving the non-table-objects into a separate MDB, link the tables from the table-mdb and then copy the application MDB to your clients computers.
0
 
Richard3Author Commented:
Thank you Trygve

You have helped me in a round about way to a working database in English and German windows.
I don't think linking the tables will help because my clients aren't connected to my computer. However by simply copying all the tables, queries and forms into a new database it now works in German windows whether the "CollatingSequence" is set to "Ascii" or "International". I checked the sort order and it was set to "Polish". Copying and pasting into a new database works if it's set to "Polish" or "General"
0
 
TrygveCommented:
Good for you!
0
 
ikeaitCommented:
Hello all.

I had this problem with a program I received with sound level meter I got.  Program called VoiceLAB from Smartsensor, meter called AR834.

I did not get this to work, no mater what I changed in the registry, first error was a strange MDAC error, regarding 2.80 or 2.81, even found Windows XP SP1 to test on, still not working.  The I installed Office 2003 and 2007, no matter.

Finally, I just opened the database in Office 2007, saved it again under a diffrent name in a Access 2000 format.  Worked like a charm.  

Hope this helps somebody... :)

Regards,
Olvir Sveinsson
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now