Solved

HP DeskJet 712C Spooling Problem

Posted on 2000-02-26
9
543 Views
Last Modified: 2013-12-15
I have recently changed an HP 712C from being routed through a MicroTek C3 scanner, to being direct to the parallel port. I have installed the latest version (10.3) of the printer driver, and the cable shows to be a IEEE 1284-1994 compliant, but I still am having problems with the spooling32 locking up after every print.  There shows to be a document pending in the spool. I am unable to view the printer folder afterwards, and the printer icon remains in the systray.  I am forced to reboot. I have tried to switch from bidirectional to no bidirectional, but neither helps. Ideas?  Thanks.
0
Comment
Question by:dlee022500
9 Comments
 
LVL 7

Expert Comment

by:sorgie
Comment Utility
Have you tried switching to EPP(enhanced parallel port) in your Bios.
0
 
LVL 21

Expert Comment

by:briancassin
Comment Utility
dlee I have posted a response to your scanners question in the scanners section regarding this I am also one of the experts in HP printer topics Printers topic catagory.... If you are getting a spool32 error it has to do with the microtek scanners drivers you will need to completely uninstall the microtek scanner and then go into your system files and comment out the microtek scanner driver and go to start find files or folders and delete the microtek files that were not released by the uninstall... ir could also be the installation of your new HP scanner there are known issues with that too

take a look at my other response to your scanners question for more detailed info. on how to modify your system files.

here is some additional info. on spool32 errors but I am cutting to the chase on it because I am pretty certain it is the previous scanner


here is the additional info. see this microsoft article on spool32 errors

http://support.microsoft.com/support/kb/articles/Q191/9/49.ASP?LNG=ENG&SA=ALLKB&FR=0

also see this

HP ScanJet Scanners - In Windows 98, Installation of Scanner Causes Communication Problem with HP DeskJet Printer
Introduction
The HP DeskJet printer works fine on the parallel port until an HP ScanJet is installed on the USB port. The printer is then unable to establish bidirectional communication. Or, it prints the first two lines correctly, but then prints page after page of random characters.

Instructions
Close the HP Scan Monitor by following the steps below.


--------------------------------------------------------------------------------

NOTE: The following steps will disable the green button(s) on the front of the scanner.


--------------------------------------------------------------------------------

Part 1
Click Start, Settings, and Control Panel.
Double-click the Scanners and Cameras icon.
Highlight the correct scanner.
Choose Properties and then choose the Events tab.
Place a check mark beside Disable Device Events at the bottom of the window. Choose OK and close the Control Panel.
Part 2
Click Start and Run.
Type MSCONFIG on the Open line and click OK.
Choose the Startup tab.
Remove the check mark from HP Scan Monitor.
Choose Apply and OK. A message will appear, stating that you need to restart Windows. Choose OK.
To launch the scanner software after it has been turned off
Click Start and Programs.
Click HP ScanJet/PrecisionScan Pro to launch the software.
 
here is some more info.



http://www.hp.com/cposupport/scanners/support_doc/bps03351.html

http://www.hp.com/cposupport/scanners/support_doc/bps03412.html
0
 

Author Comment

by:dlee022500
Comment Utility
Brian -- I am really feeling stupid, here.  I have considered myself somwhat proficient on computers and networks, until now.  I have tried everything you have provided, including renaming the DRVWPPQT.VXD file as suggested.  I uninstalled both the printer and the scanner as suggested, rebooted and closed everything but Explorer and Systray. I reinstalled the printer, and STILL it does not work. From WORD2000 I print a doc, it takes forever to get the print menu up, it does however, give me a nice print, but then it leaves the printer icon in the systray.  When I exit WORD, back to the desktop, I cannot launch the icon from the systray.  It does show that "1 Document(s) pending".  I then try to bring up the Printer Folders from Settings, and it takes forever to bring up the Printer Menu, just to show no printers. Just a blank floder with "Add Printer" icon. I close back to the desktop, and go to shut down.  The system freezes, then displays an error message entitled Spooler Process, and I have to power off manually.  As a recap. I am running Win 98, on a MICRON MAX, 450mh, 128ram, Pentium II.  I am running the scanner thru the USB, and the printer off the parallel.  The original configuration when shipped included the HP 712C DeskJet and a Microtek SlimScan.  The Microtek was connected to the parallel port and the printer was connected to the scanner.  In the System folder, there was a line where Microtek had a SCSI interface configured, but I have removed that two days ago.  I have changed the BIOS to read ECP on the port, but no use.  I don't know what else to do, but throw away this pathtic HP printer and realize that HP and MICRON found a way to sell HP's overstock of discontinued printers to fools like me.  I use to think HP was the best in printers and scanners, but I will definitely make new recommendations to my federal office in purchases in the future.  I hate top keep taking up your time with this problem, but I certainly appreciate your assistance.  Dlee
0
 
LVL 17

Expert Comment

by:rayt333
Comment Utility
Since what you have tried has not worked, lets try removing the printer and the port both and install them again.
First uninstall any HP software, open the printer window and delete the HP if it is still listed there, then go into Device Mananger and remove the printer port. Unhook the printer for now.

Now before you shutdown lets run SFC (System File Checker) to make sure there is no missing or corrupted files, Go to Start, Run, type SFC and hit enter, let it check your system and replace any files it needs to. Make sure you have the Win98 disk handy.

When this is done then reboot and let windows reinstall the printer port (if it don't that is fine) then shutdown and hook the printer back up and reboot, when it finds the printer just click cancel when it asks to install the driver, after it is finished booting up then run the setup program for the printer and follow the direction on screen and see what happens.
0
Better Security Awareness With Threat Intelligence

See how one of the leading financial services organizations uses Recorded Future as part of a holistic threat intelligence program to promote security awareness and proactively and efficiently identify threats.

 
LVL 21

Expert Comment

by:briancassin
Comment Utility
dlee try rayt333's suggestion then if you are still getting the same result slow print  lockups etc.... right click on the desktop select properties then go to settings tab click on advanced then go to the adapter tab write down the name next to the picture of the chipboard. Next go to the performance tab and drop it to none apply it and reboot try printing again let me know what the result is also please post what video card you have
0
 

Author Comment

by:dlee022500
Comment Utility
rayt333 and brian - I have followed rayt333's advice.  Two things - When rebooting, the system did not load a driver for LPT1, but it is shown in Device Mgr.  Also, after rebooting again, the system did not recognize the printer attached.

Two additional things - In viewing my BIOS I have noticed that it is not set up for PNP. Also, I was running Norton Systemworks 2000, but followed brians's directions and closed all programs except Explorer and Systray.  Tonight I have uninstalled Norton completely, and will reinstall afterwards.

Could PNP be a problem? Thanks so much.
Dlee
0
 
LVL 21

Accepted Solution

by:
briancassin earned 0 total points
Comment Utility
dlee yes activate your PNP because you removed the parallel port and windows PNP is not active windows is not looking for it and is expecting you to manually set all of the stuff for it go back into your bios activate PNP and go to device manager then remove the lpt1 port again and reboot that should reinstall it correctly
0
 

Author Comment

by:dlee022500
Comment Utility
Brian and rayt333: Thansk to both of you for everything. My system is restored and operating perfect.  AFter uninstalling SystemWorks 2000, and performing the directions you provided, I was able to get everything set up.  The only problem encountered was an SPOOL32 error in the ISM.DLL module.  I renamed the ImageServer folder to Image, rebooted, and everything works great.  I have reinstalled the scanner and it works perfect, as well as all of my graphics applications, and analysis programs involving printers.  I can't thank you enough for keeping me focused on this issue.  I'm not sure how this Expert Exchange works, but if I can generate points for you somehow, just let me know what I can do.  Your assistance is greatly appreciated more than you know.  Thank everyone so much for the help. Dlee
0
 

Author Comment

by:dlee022500
Comment Utility
The best support I have seen.  Everyone was truly helpful and very innovative in topics to research.  I have learned much, and congratulate everyone on their dedication to this type of forum.  Thank you so much.
Dennis L. Lee
Ft. Worth, Texas
0

Featured Post

Enabling OSINT in Activity Based Intelligence

Activity based intelligence (ABI) requires access to all available sources of data. Recorded Future allows analysts to observe structured data on the open, deep, and dark web.

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
RDP Servers:  replacing a printer 3 49
How to silent print from safari browser 6 134
canon dr 2010c duplex scan 8 63
LaserJet 4250 5 29
When I recently replaced my image transfer kit on my office HP color laserjet 5550dn printer, I had a slight problem.  The left bracket that holds the transfer kit got stuck in the upright locked position instead of being at a 45 degree angle facing…
Printers have changed substantially in the last 30 or so years, not just in technical capabilities but in cost and usage as well.  Printers were originally used for interfacing with the operator, not necessarily for printing copy or pictures. In …
Internet Business Fax to Email Made Easy - With eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now