Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people, just like you, are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions

post recompile module problems

Posted on 2000-02-26
Last Modified: 2010-08-05
ok, i recompiled my kernel.. ran make modules and make modules_install

no errors

now when i boot up or run depmod  i get a bunch of errors about unsolved or whatever symbols.... and then it lists the module.. but they are all mods that i don't use and didn't include in my kernel... it doesn't seem to effect anything, but it is annoying and i like my computer to be problem free

Question by:djtansey
  • 6
  • 4
  • 3
  • +1

Expert Comment

ID: 2562056
did you move the systemmap from /usr/src/linux to /boot and make proper link to it?
mv /usr/src/linux/Systemmap /boot/Systemmap-2.2.15
cd /boot
ln -s Systemmap-2.2.15 Systemmap

Author Comment

ID: 2562135
systemmap == vmlinuz ?
LVL 15

Expert Comment

ID: 2562634

   No!  systemmap is not vmlinuz.  The file is located in the root of the kernel source tree. (/usr/src/linux). And the file name is : System.map

   If you checked the /boot directory, the current System.map is a symbolic link to Syatem.map-2.x.x.  You can safely delete the file and copy the one from /usr/src/linux (after the compilation).

   cp /usr/src/linux/System.map /boot/System.map

   In this case the old System.map-whatever will be around in case there is any problem with the newly compiled kernel.

   The old modules directory is safe to be removed.  (I tend to rm -rf /usr/lib/modules/xx.xx.xx <-- kernel version before I did a make modules and make modules_install.  Just to make sure that the old modules is not around.  Renaming it is a better option though).

good luck,

What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.


Author Comment

ID: 2563213
Adjusted points to 51

Author Comment

ID: 2563214
nope.. did all of that and then it still did not work.. here, do this for me.. write out the steps i should take when compiling and after compiling.. i  saved the configuration... no problem to compile again... (e.g





Accepted Solution

jyu_88 earned 51 total points
ID: 2563788
cd /usr/src/linux
make clean
make Xconfig
make bzImage
cp System.map /boot/System.map-2.2.15-4
cp arch/i386/boot/bzImage /boot/vmlinuz-2.2.15-4
make modules
move /lib/modules/2.2.15 /lib/modules/2.2.15.old
mkdir /lib/modules/2.2.15
make modules_install
cd /boot
ln -sf System.map-2.2.15-4 System.map
# edit your lilo.conf to reflect new kernel image
vi /etc/lilo.conf
# dry run lilo
/sbin/lilo -t -v
# run lilo for real, if no error above
/sbin/lilo -v
init 6

If problem sticks, post the following here:
1. cat /etc/conf.modules
2. depmod -a
3. errors from the boot up.

Expert Comment

ID: 2565057
The last one from jyu_88 will also do it, but it would suffice to remove all old modules from /lib/modules/2.2.15/*/

Just clean out /lib/modules/2.2.15/ completely and do a make modules_install again, followed by a "depmod -a".

Author Comment

ID: 2570240
ok.. that last answer almost worked.. but there is still one module that gives me the same error... can i just delete it.. it was built by make modules_install...

what causes the error anyway?


Expert Comment

ID: 2570316
if you post the exact error for unresolved symbols, folks can tell which is misunderstood by the kernel module utilties, it should be able to deal with by establish alias in /etc/conf.modules most of the times if you didn't really leave out something for the module.

The way I guess is the modutiles packages are ready for the kernel it is shipped together with and maybe some reasonable bug fix, but may not be ready for every changes made to the latest kernel.

Expert Comment

ID: 2572151
The error is caused by the fact that some symbols your old modules ask for are no longer present in your new kernel. That's what unresolved means.

Don't delete that last annoying module just yet. Which module is it? Can you tell us how you configured he kernel for this module? Seeing the relevant settings for this module from /usr/src/linux/.config would be nice.

Author Comment

ID: 2574905

i don't know what it does, so i can't find it in .config...      

Expert Comment

ID: 2574946
Never heard of it.

As a practical solution try loading all (top) modules one at a time using modprobe, and find out if it gets loaded as a dependency at sometime. If not, move it to somewhere safe and wait for some trouble starting to happen (or not).

Expert Comment

ID: 2574963
Wait, one more thought.

Look at a listing of /usr/src/linux/modules. It contains symlinks to all your modules in the kernel source tree. If you can't find it there I think you can safely move it out of /lib/modules/... and see what happens. Else follow the link and it will give you an idea what it is for.

Author Comment

ID: 2590350
Thanks a lot man... i finally found what i needed in my kernel, and when i recompompiled (about the 5th time) it worked perfectly! Thanks a ton

now my computer boots in 25 second :)

That is pretty good for a 266 PII... 64 mb of ram... (that is from LILO to Login:)


Featured Post

Back Up Your Microsoft Windows Server®

Back up all your Microsoft Windows Server – on-premises, in remote locations, in private and hybrid clouds. Your entire Windows Server will be backed up in one easy step with patented, block-level disk imaging. We achieve RTOs (recovery time objectives) as low as 15 seconds.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
linux(debian) mouse poor performance 4 61
ftp to port 21 4 53
winscp 000webhost.com 6 72
Running linux commands into linux system remotely using powershell 6 38
Using 'screen' for session sharing, The Simple Edition Step 1: user starts session with command: screen Step 2: other user (logged in with same user account) connects with command: screen -x Done. Both users are connected to the same CLI sessio…
Little introduction about CP: CP is a command on linux that use to copy files and folder from one location to another location. Example usage of CP as follow: cp /myfoder /pathto/destination/folder/ cp abc.tar.gz /pathto/destination/folder/ab…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

790 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question