• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 303
  • Last Modified:

RH6.0 firewall problems...

Of course I didn't install two network cards just for fun... (see my previous question.). I wanted to install ip-masqerating and a firewall. Now, the ip-masq works fine, i followed the mini-howto on ip-masqerating. except for one thing : the doc says to put all the commands in 1 file called /etc/rc.d/rc.firewall. and make the file excecutable with chmod 700. Done that, and it works fine, but why is this file not automaticaly excecuted at startup time, like the doc says???

BTW : I can excecute the file, all i have to do is log in and type /etc/rc.d/rc.firewall and everything works fine, but I don't want to type the command every reboot...

(I think this should be an easy one)
0
940961sl
Asked:
940961sl
1 Solution
 
940961slAuthor Commented:
Sorry, I forgot,
Comments only, please. Answers will be rejected, and rejected answers don't have a accept comment as answer button :-)
0
 
nirsimCommented:
Hi There,

  Here is a simple solution to your problem:

1. copy the file to /etc/rc.d/init.d/firewall
2. mark it as an executable file
3. goto /etc/rc.d/rc3.d/
4. create a symbolic link from S86firewall to /etc/rc.d/init.d/firewall.rc
5. if you are using X-windows as your default runlever, do the same
    only in /etc/rc.d/rc5.d/

  This should run your firewall settings at startup. Please note, the rc.firewall file you created should have been run automaticly from the rc.local script. If it doesn't, that means that some of the lines in rc.local are commented out, which makes it impossible to run other rc.* scripts at run time.

Best regards,
  Nir Simionovich
  artNET experts Ltd.
  Israel
  http://www.artnet.co.il
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now