[2 days left] What’s wrong with your cloud strategy? Learn why multicloud solutions matter with Nimble Storage.Register Now

x
?
Solved

Anonymous FTP fails

Posted on 2000-02-28
5
Medium Priority
?
284 Views
Last Modified: 2013-12-28
I can not set up my FTP site so that anonymous FTP works as usual from an Internet explorer browser running on a remote computer. The remote workstation sees perfectly the directory structure of the ftp site, but when the user double clicks on an EXE file, an error '(111) Connection refused' appears instead of the common dialog 'What do you want to do? Download the file or remotely execute it?'.
I think the problem is not with the browser configuration, because the same operation works perfectly when downloading from other sites (for instance, ftp.microsoft.com).

The FTP site is active, an it's configured to allow anonymous access.

Thanks in advance,

Octavio
0
Comment
Question by:octavioh
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
5 Comments
 
LVL 2

Expert Comment

by:gikam
ID: 2565089
in the server u must set permisions to read on that file for the user INETUSER or alike
0
 

Author Comment

by:octavioh
ID: 2565471
Thanks, Gikam!

Seems like I have found the source of the problem. Under Control Panel | Network |Protocols | TCP-IP | Advanced | Enable security somebody had set the protocol to accept only connections thru port 21 (FTP) and 80 (HTTP). After setting the option to 'All ports' everything started working.

Using a Netscape Navigator instead of IE, I saw that the browser was accessing a ¿random? port when I clicked on the ftp link.

What I don't know yet is why these ports are needed at all.

Regards,

Octavio
0
 
LVL 23

Accepted Solution

by:
Tim Holman earned 400 total points
ID: 2569364
FTP needs port 20 open to transfer data, and port 21 open to browse and perform FTP commands.
If you'd have just opened port 20, instead of everything, it would have worked for you.
The 'random' ports you're talking about are normal - once the local machine and destination machine know what sort of session they need to establish, they continue communication at a higher port, so that the ports (especially the server ones) are freed up for another client to use.
0
 

Author Comment

by:octavioh
ID: 2569555
Adjusted points to 100
0
 

Author Comment

by:octavioh
ID: 2569556
A lot of thanks!
0

Featured Post

On Demand Webinar: Networking for the Cloud Era

Did you know SD-WANs can improve network connectivity? Check out this webinar to learn how an SD-WAN simplified, one-click tool can help you migrate and manage data in the cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Ever visit a website where you spotted a really cool looking Font, yet couldn't figure out which font family it belonged to, or how to get a copy of it for your own use? This article explains the process of doing exactly that, as well as showing how…
Sometimes clients can lose connectivity with the Lotus Notes Domino Server, but there's not always an obvious answer as to why it happens.   Read this article to follow one of the first experiences I had with Lotus Notes on a client's machine, my…
As developers, we are not limited to the functions provided by the VBA language. In addition, we can call the functions that are part of the Windows operating system. These functions are part of the Windows API (Application Programming Interface). U…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

649 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question