Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win


Audio PCI problem

Posted on 2000-02-29
Medium Priority
Last Modified: 2013-12-28
Upon rebooting, following a faultless install of Windows 98, I got "The AudioPCI interrupt has been routed incorrectly by the system. Sound inactive. Use Automatic Settings in the Device Manager". The soundcard is a Creative Labs PCI 128 which I've been using with Windows 95 for more than a year. And of course "Automatic Settings" was already set in Device Manager, but manual configuration is disallowed anyway.

Re-installing the both the card and the drivers have made no difference.

Any thoughts?
Question by:rod_jones
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions

Expert Comment

ID: 2568428
You could try going into the bios setup and reseting PCI bus so it reshuffles the irq's etc...good old Plug & Pray..


Expert Comment

ID: 2569539
Reboot to safe mode (hold down left shift while booting) and check device manager for any duplicates or problems.  Remove all instances of duplicates and anything with ? or ! and reboot.  Reinstall what it prompts you for.

Accepted Solution

Ajnin earned 400 total points
ID: 2570759
If the BIOS setting doesn't work. Maybe try putting the card in a different PCI slot this sometimes will cause a new IRQ to be assigned.
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.


Expert Comment

ID: 2571164
There was a "Funky" disk for the PCI 128. And I don't know if the new drivers have been posted yet for it to work properly. The ones they had on the FTP site wer wrong.

Order a new drivers disk from Creative, Remove the card, and remove any DOS settings manually from Autoexec or Config sys files.

I know it sounds weird, but, I bought the card when it first came out, used the CD that came with it and it worked fine for 8 months. I reloaded the OS used the same disk (In fact I had a collection of them by then) and it just simply bugged out. Creative Labs assured me that the wrong disk was packed in the box, they know about it, and they sent me a new disk and it works fine now.

The Original disk packed with it has
CLI Part#1713330715 and they is wrong

It should be: 1713330956 and it is the same CD for the Ensonic Cards.

It was weird, but the same thing you are saying happened to me, and I know it makes no sense......

Creative is very slow mailing it out, it took 3 phone calls and 3 weeks to get a CD in their hands, then they finally sent it to me. Apearently, they claim that they do not have any software in the building, it has to go through other channels.....

Good Luck

The disk is only 80MB if you have a hard time getting one and have an ISDN or ADSL line I can upload it to you.


Expert Comment

ID: 2571281
I would look for device conflicts start-settings-control panel-system-device manager tab and look for the yellow !. If you find something go to properties-resources and change to a non conflicting resource. - if it lets you.
WIN98 may have rearranged things for you. By the way, what were you running before.

Expert Comment

ID: 2583344
Uninstall Creative labs pci 128 drivers
and then goto bios setup hit del/F10 at startup. And look that plug and play os is enabled and irqs are set to pci
Download latest pci 128 drivers. from

install them...

Expert Comment

ID: 2583366
Hmmmmm sounds almost like what I said......

Allthough I would request the disk, because I had this same exact problem 2 months ago,and creative told me NOT to use the drivers on the web site because they were wrong. Why it was working fine for almost a year, and only till I reloaded an OS and used the same disk I used to install at the beginning it came up to be a driver problem is everyones mystery. For whatever reason they said they have not removed the wrong drivers from the FTP site.

Maybe they change them by now, maybe not. If it still does not work, request a PCI128 install disk from creative labs.

Did you check the numbers that I posted above to see if they were the same part numbers? They are written on the CD-ROM.

Author Comment

ID: 2587095
I'm not really sure why canUCme's response is a 'proposed answer' and all the others are merely comments. It was ajnin's suggestion that worked...

I had tried most suggestions but to no avail. I didn't actually try canUCme's because as a result of MnNCOMM's suggestion, I had already obtained the latest drivers from Creative, but they made no difference.

I finally tried ajnin's suggestion of swapping PCI slots (with my 3D graphics card), and to my complete amazement, it worked. The card is now happily working on IRQ 10, and the problematic IRQ (11) is apparently unused...

And thanks to all suggestions!

Expert Comment

ID: 2588692
Good for you!! I'm currently using two sb pci cards under windows wich should be imposible...Works fine..


Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

A small collection of useful tips and tricks for Windows 10 users that I decided to write as a result of recent questions that were asked and answered at Experts Exchange. Two short video tutorials included. Enjoy..
Ever visit a website where you spotted a really cool looking Font, yet couldn't figure out which font family it belonged to, or how to get a copy of it for your own use? This article explains the process of doing exactly that, as well as showing how…
This Micro Tutorial will give you a basic overview of Windows DVD Burner through its features and interface. This will be demonstrated using Windows 7 operating system.
The viewer will learn how to successfully create a multiboot device using the SARDU utility on Windows 7. Start the SARDU utility: Change the image directory to wherever you store your ISOs, this will prevent you from having 2 copies of an ISO wit…

604 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question