Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1715
  • Last Modified:

ORA-09352 - (SID) has not been started

As a beginner in the field, I have a starting question:

My ORACLE DB is installed on Windows NT along with a user application. The app runs well but if I want to enter svrmgr23 this error appear:
ORA-09352: OracleService (SID) has not been started.
In services the 3 Oracle components start automatic and I've seen ORACLE_SID set.

What's the mater ?

 
0
moia
Asked:
moia
  • 3
  • 2
1 Solution
 
banickiCommented:
You said your two services are started?
-OracleServiceXXXX where XXXX is your SID
-OracleTNSListner
Right?

You said you went to a DOS Prompt and set the OracleSID.
-set oracle_sid
 = XXXX  where XXXX is your SID
Then you try to start Server Manager
-svrmgr23
and you get a ORA-09325

What is you SID
jTell us what service are running that start with Oracle.

Terry
 
0
 
crsankarCommented:
Try this

Go to the ms-dos prompt

type this at the command prompt

SET ORACLE_SID=<sid>

substitute <sid> with the name of the instance that you want to work with

svrmgr23

If you still have problems,

type

connect internal

show parameter db_name

verify it is the correct database

and then issue

startup pfile=<name of your param file>




0
 
moiaAuthor Commented:
Thank you Terry.

Actually, there are three services starting automatic:

OracleServiceGFPC
OracleStartGFPC
OracleTNSListener

My Oracle_sid is GFPC and the database is the same (set in init.ora)
I set again in DOS prompt, then started ServerManager and it works, but if I start SQLplus the same error appears.

In NT environment system variable the only varible set is ORACLE_HOME. How could I add ORACLE_SID to appear at startup ?
0
The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

 
banickiCommented:
do this on your oracle server.
You have to set ORACLE_SID in the NT registry.  
-go to a command prompt (or start>run)
-type regedt32
-find the hkey_local_machine on local maching
-drill down, software>oracle
-make sure you have a view of tree and data, data on the right half of screen
-edit>add value>
-in you add value pop up window, enter a value name of ORACLE_SID, data type of
REG_SZ or REG_EXPAND_SZ, then click ok
-a string editor window will pop up
-enter your sid in the string field
-close the window, will save your value
-this action will cause this to be you default destination. example bring up an OEM signon window and leave the service empty.
0
 
banickiCommented:
I am assuming you have only one oracle instance on this nt server.  setting the default SID makes life difficult if you have two instances on one server.
Terry
0
 
moiaAuthor Commented:
Thanks Terry. I modified the registry and everything seems to be OK.

See you
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now