Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Can't telnet or FTP to linux

Posted on 2000-03-01
12
Medium Priority
?
425 Views
Last Modified: 2010-03-18
When I try to telnet or FTP to my server
I get a error "Connection close by foreign host. I just used the standard install of linux 6.1

Please help!!
lonnie
0
Comment
Question by:sbsys
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
  • 2
  • +3
12 Comments
 
LVL 15

Expert Comment

by:samri
ID: 2576812
sbsys,

 What login id do you use for both session (telnet and ftp)?

0
 
LVL 1

Expert Comment

by:bcoleman
ID: 2577257
Can you ping your server?
0
 
LVL 40

Expert Comment

by:jlevie
ID: 2577651
You'll get that kind of an error from telnet and ftp if the user's shell as specified in the password file isn't a valid shell. Can you login as that user on the console screen?
0
Major Serverless Shift

Comparison of major players like AWS, Microsoft Azure, IBM Bluemix, and Google Cloud Platform

 

Author Comment

by:sbsys
ID: 2577988
I can ping the server and I log as root on the console.
0
 
LVL 1

Expert Comment

by:bcoleman
ID: 2578160
Are the ftpd and in.telnetd daemons running out of inetd?
0
 
LVL 40

Expert Comment

by:jlevie
ID: 2578252
Are you trying to telnet or ftp in as root? Linux has remote root access disabled by default and that will also cause the "Connection close by foreign host"
Create an ordinary user accout for remote access then use su to gain root privs.
0
 
LVL 3

Expert Comment

by:jyu_88
ID: 2578757
you don't necessarily have ftp server running/installed.
check whether you have ftp server package by 'rpm -aq |grpe ftpd'
Check if ftpd is running, 'ps -alef | grep ftpd' if standalone, or ps -alef|grep inetd' and grep ftpd /etc/inetd.conf'.
0
 
LVL 40

Accepted Solution

by:
jlevie earned 60 total points
ID: 2578862
Don't bother to look for ftp via ps -ef, it won't be there unless someone already has an ftp session open as the ftp daemon is started on demand from /etc/inetd.conf. Since I don't know what Linux distribution you have I don't know if it would have been installed by default. If it was installed there will be either an ftpd or in.ftpd, typically in /use/sbin.
0
 

Author Comment

by:sbsys
ID: 2578981
The information that I received from both of you has been extremely helpful, but unfortunately, I can only choose one answer.  I would like to thank you both for sharing your knowledge.  It is truly to my regret that I can only send the points to one of you.

Sincerely,
sbsys
0
 

Expert Comment

by:kookkai
ID: 2587263
Setup again :D
0
 

Author Comment

by:sbsys
ID: 2599073
I re-install Linux and now I can logon as anonymous, I can "download" to my PC but when I try to upload I get an error "553 dog.jpg Permission denied [UPLOAD]  Please if anyone wish to answer this, explain it very very simple and in detail.
0
 
LVL 40

Expert Comment

by:jlevie
ID: 2599118
That's as it should be. Permitting uploads from an anonymous FTP login is considered very dangerous, so it's normally disabled by default. The best solution is to use an ordinary user account for ftp. If you haven't created one for yourself, it's easy enough to do with linuxconf.

I'm going to guess that you might be using RedHat 6.1, correct? Did you install wu-ftp or just anonftp when you re-installed the OS?
0

Featured Post

Fill in the form and get your FREE NFR key NOW!

Veeam® is happy to provide a FREE NFR server license to certified engineers, trainers, and bloggers.  It allows for the non‑production use of Veeam Agent for Microsoft Windows. This license is valid for five workstations and two servers.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…
We’ve all felt that sense of false security before—locking down external access to a database or component and feeling like we’ve done all we need to do to secure company data. But that feeling is fleeting. Attacks these days can happen in many w…

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question