Solved

Red Hat 6.1 Home Network Help!

Posted on 2000-03-02
11
258 Views
Last Modified: 2010-03-18
<pre>
Hello All,

I recently purchased a computer on which I installed Redhat Linux 6.1. I installed the network card, assigned it an IP and subnet proper to my existing PCs, yet I am unable to ping it from another PC or ping another PC from it (it doesn't exist on the network, period).  This is a private network which will not be going on the internet anytime soon.  The solution to this problem would be greatly appreciated.  Please read my specs before responding:

(If this information becomes garbled, please go to:
http://www.supertom.com/networkhelp.htm
to read further

Machine 1:
-Windows 98
-ip: 192.168.1.1
-subnet: 255.255.255.0
-tcp/ip protocol installed and bound to the card
-Workgroup: SUPERTOM
-Access Control: Share Level
-Logon and Restore network connections selected in "Client for Microsoft Network" Properties
-Network Card: Linksys LNE 100TX Fast EtherNet (this card is auto-sensing)

Machine 2 (notebook):
-Windows 95 "A" (as in not OSR2)
-ip: 192.168.1.2
-subnet: 255.255.255.0
-tcp/ip protocol installed and bound to the card
-Workgroup: SUPERTOM
-Access Control: Share Level
-Logon and Restore network connections selected in "Client for Microsoft Network" Properties
-Network Card: Linksys EtherFast 10/100 PC Card

### Machines 1 and 2 can and always have seen each other ###
### The hub: Linksys 5 Port Hub 10Mbps (3 green lights)###
### The cable between linux and hub: previously used successfully networking another windows pc

Machine 3:
-RedHat Linux 6.1
-ip: 192.168.1.3
-subnet: 255.255.255.0
-gateway: 192.168.1.1 (machine 1)
-Network Card: Linksys Ether16 (ne2000 compatible)
***************
#When I run a ifconfig, I get
eth0      Link encap:Ethernet  HWaddr 00:40:05:6E:A6:A3
          inet addr:192.168.1.3  Bcast:192.168.1.254                  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:6
          TX packets:15 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          Interrupt:3 Base address:0x300

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:3924  Metric:1
          RX packets:11 errors:0 dropped:0 overruns:0 frame:0
          TX packets:11 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
***************

#When I run route, I get

Destination      Gateway      Genmask            Flags      Metric      Ref      Use      Iface
192.168.1.3      *      255.255.255.255      UH      0      0      0      eth0
192.168.1.0      *      255.255.255.0      U      0      0      0      eth0
127.0.0.0      *      255.0.0.0      U      0      0      0      lo
default            emily      0.0.0.0            U      0      0      0      eth0
***************

#When I run netconf:
Enabled is checked
Config: manual
Primary + domain: elissa.SUPERTOM
IP: 192.168.1.3
net device: eth0
kernel module: ne
I/0 port: 0x300

***************
#/etc/resolve.conf is blank
***************
ifcfg-eth0
DEVICE="eth0"
IPADDR="192.168.1.3"
ONBOOT="yes"
BOOTPROTO="none"
NETMASK="255.255.255.0"
(LOTS OF IPX STUFF BELOW - I'VE TRIED DELETING THIS WITH NO LUCK)


***************
#/etc/sysconfig/network
NETWORKING=yes
FORWARD_IPV4=yes
HOSTNAME=elissa
IPADDR=192.168.1.3
GATEWAY=192.168.1.1
***************

Please let me know if you need any more information, as this is certainly a learning experience for me as well.

Tom

</pre>
0
Comment
Question by:tom419
  • 4
  • 3
  • 3
  • +1
11 Comments
 
LVL 7

Expert Comment

by:lewisg
ID: 2578726
Check and be sure COM2 is not using IRQ3. If it is and you need COM2 cahnge the network card to an unused IRQ.

If this does not help please post /etc/conf.modules
0
 

Expert Comment

by:tom0475
ID: 2580248
Thanks for your comments
How would I check the IRQ for COM2?  I meant to post /etc/conf.modules and will do so shortly.
0
 

Expert Comment

by:tom0475
ID: 2580277
*****************
/etc/conf.modules
alias eth0 ne
options ne io=0x300
*****************
0
 
LVL 7

Expert Comment

by:lewisg
ID: 2581008
running cat /proc/interrupts will tell you what interrupts are in use by Linux (cat /proc/ioports will do the same for IO's).

On most modern motherboards to disable COM2, or to see if it is enabled, you got to CMOS setup and look for a section called "intergrated peripherals". The other choice is to find a unused IRQ like 10, 11 or 5 and use the netcard's DOS setup program to set it to one of those.
0
 

Expert Comment

by:tom0475
ID: 2581105
ok, I'll try that this evening and get back to you.  When I originally used the dos setup, I just took the defaults. So when I look in the interrupts file, if there is a conflict, I should see two devices using the same IRQ, right?  I'll also look at the ports file and post them both so you can see it anyway.
Thanks for your help.
0
Zoho SalesIQ

Hassle-free live chat software re-imagined for business growth. 2 users, always free.

 

Author Comment

by:tom419
ID: 2581983
Here are the files.  Incidently, just for a sanity check, I tried the different ports in the hub and still had no luck.  When I do a ping from the linux machine, the light on the network card flashes in sync with the "Destination Host Unreachable" error. Let me know what you think.
*********************
#/proc/interrupts
      CPU
0:      29259      XT-PIC      timer
1:      101      XT-PIC      keyboard
2:      0      XT-PIC      cascade
3:      1      XT-PIC      NE2000
8:      1      XT-PIC      rtc
12:      1      XT-PIC      PS/2 mouse
13:      0      XT-PIC      fpu
14:      44666      XT-PIC      ide0
15:      5      XT-PIC      ide1
NNI:      0

*********************
#/proc/ioports
0000-001f : dma1
0020-002f : pic1
0030-003f : timer
0060-006f : keyboard
0070-007f : rtc
0080-008f : dma page req
00a0-00bf : pic2
00f0-00ff : fpu
0170-0117 : ide1
01f0-01f7 : ide0
0300-031f : NE2000
0376-0376 : ide1
03c0-03df : vga+
03f6-03f6 : ide0
03f8-03ff : serial(auto)
4000-4007 : ide0
4008-400f : ide1
*********************
0
 
LVL 7

Expert Comment

by:lewisg
ID: 2582233
Two thoughts:

I just ran cat /proc/interrupts on two machines here and both of them show no IRQ 3 or 4 usage. Both of these machines have both COM1 & COM2 available in hardware. Linux boes not use ether com port currently so? I always feel more comfortable with IRQ 5 or 10. If you change the netcard IRQ you don't have to change anything in Linux.

Your routing table shows "default emily 0.0.0.0 U 0 0 0 eth0" as the default gateway. I don't think this has anything to do with the problem since default gateways only come into play when a routing off the subnet is needed. However the 0.0.0.0 entry is disturbing. It should be the IP address of a machine on the subnet that can route packets off the local subnet.
0
 

Author Comment

by:tom419
ID: 2582381
I changed my IRQ successfully to 9 with the dos program(the card seems to work the same as before and it changed the IRQ to 9 when I did ifconfig), but no luck connecting to the network.  I then tried the following command to add my windows machine as the default gateway

route add default gw 192.168.1.1
and I got:
File exists

Am I doing the right thing to add this gateway?  Where is this file that exists and how can I remove it? Should I remove it?
0
 
LVL 7

Accepted Solution

by:
lewisg earned 125 total points
ID: 2582435
Since you don't need a gateway just delete it:

/sbin/route del default

Is it a ISA or PCI netcard? Any chance the network is not running at 10Mb? Is 192.168.1.254 really eth0's broadcast?
0
 
LVL 3

Expert Comment

by:alien_life_form
ID: 2582879

I suppose you entered  the boradcast manually?

Bcast:192.168.1.254

Can well be the problem here.

Cheers,
      alf
0
 

Author Comment

by:tom419
ID: 2583068
Thanks for all of your help.  I really learned alot, and I got my network up too!
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
This video shows how to remove a single email address from the Outlook 2010 Auto Suggestion memory. NOTE: For Outlook 2016 and 2013 perform the exact same steps. Open a new email: Click the New email button in Outlook. Start typing the address: …

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now