Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win


Modem Connection - Cannot logon

Posted on 2000-03-02
Medium Priority
Last Modified: 2010-08-05
I am using a Supra 14.4 modem on an RS6000-380 running AIX4.2.   When I call into the system (have tried several different locations, computers, & os'), I am getting all uppercase display and it is passing "CONNECT", "9600", "RING" etc. to the loging prompt - and then kicks me off the system.

This configuration previously worked & I suspect that someone has changed something but don't know what.

What would cause this?   How can I correct it?

Question by:b_hardin
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
LVL 21

Expert Comment

ID: 2581072
Sounds like the modems are connecting & negotiating a link OK, but the system modem is failing to communicate properly with the host.

You need to check the configuration of the server port (SMIT?) and that the port is talking to the modem ("echo ATH1 > /dev/tty02", [or whatever port the modem is connected to] - This should cause the modem to go off-hook).

It's possible that there are processes hanging the port. When you know which port it is, you can check with "ps -ft /dev/tty02".

You may need to reconfigure the modem, which can be done by echoing AT commands to the port [AT&F should reset it to defaults] or by connecting it to a PC.

Whatever you do, don't save the modem configuration changes with AT&W until you're sure you have the config right - Until you save them, power-cycling the modem will reset it to the last saved state.

Hope this helps - I hate modem problems!
LVL 12

Expert Comment

ID: 2581679

Tim's suggestions sound all good to me.  Just to clarify, IN CASE YOU DON'T KNOW, you can use:
# smit tty
to take you straight into to the tty config area of smit, and:
# cu -dml tty1
should allow you to enter AT commands from the host side (assuming your modem is on tty1), eg: AT&V will display the register settings on some modems.  This is an alternative to connecting it to a PC.  You could even try dialing OUT from here, to see if that works.
NOTE: To exit cu (Communication Utility), type ~. (tilda, dot) and Enter.

1. Have you tried turning the modem off/on?  I've seen the same symptoms as yours this week and this fixed it.
2. What settings have you got for this tty in smit?  You might like to paste them in here for us to peruse.
LVL 21

Expert Comment

ID: 2620794
Hi b_hardin - Did tel2's suggestions solve the problem or give you any more info?

Expert Comment

ID: 2643340
although I am not an AIX guru, the following may help:

check that there is a getty process or alike running on the port that the modem is attached to and that it is running at the right speed.

possibly /etc/inittab for this.

check that there are not strange characters in the /etc/issue /etc/motd or other configuration files for issued prompts.

connect a dumb terminal or pc (via null modem cable) directly to the host, and fire up hyperterm or alike with the debug options (monitor i think) turned on. This will tell you what is being sent to the port and if it is in the correct format/speed.

under solaris sending a break (ctrl-b) will cause the port monitor to reset the port speed to the current speed, similar may be available via aix within smit or alike.

if all of these work out fine (usually the terminal will find it pronto) then you need to look at the pc end, try checking the local connectivity, set some debugging options on the pc, hard set the port at 2400 and keep trying to connect (incrementing the speed as you go) this can identify incorrect speed negotiation sequences in the inittab.

check also that the data word is set correctly, these are usually 7 data bits Even Parity 1 stop bit (7E1) or
8 data bits No parity 1 stop bit (8N1)

Kind Regards,

Accepted Solution

festive earned 150 total points
ID: 2643359
I just re-read your message: you need to issue the following commands to your modem (host end)

Your problem is as follows:
at some stage your modems responses have been switched on, this is confusing AIX's port monitors/login program.

you need to disable this message from the hosts modem.

tip or cu -s9600 to the comms port device.
type the following commands:


then switch the modem off and on again
and it should now be fine:
if this does not solve it then refer to my previous comments.

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

A metadevice consists of one or more devices (slices). It can be expanded by adding slices. Then, it can be grown to fill a larger space while the file system is in use. However, not all UNIX file systems (UFS) can be expanded this way. The conca…
I have been running these systems for a few years now and I am just very happy with them.   I just wanted to share the manual that I have created for upgrades and other things.  Oooh yes! FreeBSD makes me happy (as a server), no maintenance and I al…
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
This video shows how to set up a shell script to accept a positional parameter when called, pass that to a SQL script, accept the output from the statement back and then manipulate it in the Shell.
Suggested Courses

618 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question