Solved

Modem Connection - Cannot logon

Posted on 2000-03-02
5
238 Views
Last Modified: 2010-08-05
I am using a Supra 14.4 modem on an RS6000-380 running AIX4.2.   When I call into the system (have tried several different locations, computers, & os'), I am getting all uppercase display and it is passing "CONNECT", "9600", "RING" etc. to the loging prompt - and then kicks me off the system.

This configuration previously worked & I suspect that someone has changed something but don't know what.

What would cause this?   How can I correct it?

0
Comment
Question by:b_hardin
  • 2
  • 2
5 Comments
 
LVL 20

Expert Comment

by:tfewster
Comment Utility
Sounds like the modems are connecting & negotiating a link OK, but the system modem is failing to communicate properly with the host.

You need to check the configuration of the server port (SMIT?) and that the port is talking to the modem ("echo ATH1 > /dev/tty02", [or whatever port the modem is connected to] - This should cause the modem to go off-hook).

It's possible that there are processes hanging the port. When you know which port it is, you can check with "ps -ft /dev/tty02".

You may need to reconfigure the modem, which can be done by echoing AT commands to the port [AT&F should reset it to defaults] or by connecting it to a PC.

Whatever you do, don't save the modem configuration changes with AT&W until you're sure you have the config right - Until you save them, power-cycling the modem will reset it to the last saved state.

Hope this helps - I hate modem problems!
Tim
0
 
LVL 11

Expert Comment

by:tel2
Comment Utility
b_hardin,

Tim's suggestions sound all good to me.  Just to clarify, IN CASE YOU DON'T KNOW, you can use:
# smit tty
to take you straight into to the tty config area of smit, and:
# cu -dml tty1
should allow you to enter AT commands from the host side (assuming your modem is on tty1), eg: AT&V will display the register settings on some modems.  This is an alternative to connecting it to a PC.  You could even try dialing OUT from here, to see if that works.
NOTE: To exit cu (Communication Utility), type ~. (tilda, dot) and Enter.

Questions:
1. Have you tried turning the modem off/on?  I've seen the same symptoms as yours this week and this fixed it.
2. What settings have you got for this tty in smit?  You might like to paste them in here for us to peruse.
0
 
LVL 20

Expert Comment

by:tfewster
Comment Utility
Hi b_hardin - Did tel2's suggestions solve the problem or give you any more info?
0
 
LVL 2

Expert Comment

by:festive
Comment Utility
although I am not an AIX guru, the following may help:

check that there is a getty process or alike running on the port that the modem is attached to and that it is running at the right speed.

possibly /etc/inittab for this.

check that there are not strange characters in the /etc/issue /etc/motd or other configuration files for issued prompts.

connect a dumb terminal or pc (via null modem cable) directly to the host, and fire up hyperterm or alike with the debug options (monitor i think) turned on. This will tell you what is being sent to the port and if it is in the correct format/speed.

under solaris sending a break (ctrl-b) will cause the port monitor to reset the port speed to the current speed, similar may be available via aix within smit or alike.

if all of these work out fine (usually the terminal will find it pronto) then you need to look at the pc end, try checking the local connectivity, set some debugging options on the pc, hard set the port at 2400 and keep trying to connect (incrementing the speed as you go) this can identify incorrect speed negotiation sequences in the inittab.

check also that the data word is set correctly, these are usually 7 data bits Even Parity 1 stop bit (7E1) or
8 data bits No parity 1 stop bit (8N1)

Kind Regards,
Festive
0
 
LVL 2

Accepted Solution

by:
festive earned 50 total points
Comment Utility
I just re-read your message: you need to issue the following commands to your modem (host end)

Your problem is as follows:
at some stage your modems responses have been switched on, this is confusing AIX's port monitors/login program.

you need to disable this message from the hosts modem.

tip or cu -s9600 to the comms port device.
type the following commands:

ATQ0
AT&W0
AT&W1
AT&W

then switch the modem off and on again
and it should now be fine:
if this does not solve it then refer to my previous comments.
0

Featured Post

Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

Join & Write a Comment

Suggested Solutions

Using libpcap/Jpcap to capture and send packets on Solaris version (10/11) Library used: 1.      Libpcap (http://www.tcpdump.org) Version 1.2 2.      Jpcap(http://netresearch.ics.uci.edu/kfujii/Jpcap/doc/index.html) Version 0.6 Prerequisite: 1.      GCC …
FreeBSD on EC2 FreeBSD (https://www.freebsd.org) is a robust Unix-like operating system that has been around for many years. FreeBSD is available on Amazon EC2 through Amazon Machine Images (AMIs) provided by FreeBSD developer and security office…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now