Solved

Windows 98 and Winsock ?

Posted on 2000-03-03
17
150 Views
Last Modified: 2013-12-28
I need some advice on how to resolve a Winsock problem.  Basically we have installed the Apache web server on a machine. However when we use the URL 127.0.0.1 it says that it cannot find the specified page and then asks we want to connect to our ISP (in this case it is Freeserve).

However,  if we use this URL when on line the Apache web server on his machine does respond with the correct page.

How can this problem be resolved so that we can use the 127.0.0.1 url when offline.

I will be grateful for all advice offered regarding this.

John
0
Comment
Question by:johnclarke
  • 4
  • 3
  • 2
  • +5
17 Comments
 
LVL 32

Expert Comment

by:jhance
Comment Utility
"127.0.0.1" is not a valid URL.  How are you specifying it exactly?

The correct way would be:

http://127.0.0.1

Apache has the ability to bind to a specific IP address.  Does your Win98 computer have a network card?  What interface is Apache binding to?

It's not 100% clear but are you running the Apache server on this Win98 computer or some other computer on your network??
0
 

Author Comment

by:johnclarke
Comment Utility
The URL we used was http://127.0.0.1.  The machine in question is a Stand Alone Windows 98 machine with no network card.

I am not sure what Apache is binding to.  How can I find out what it is binding to ?

John
0
 
LVL 12

Expert Comment

by:pjknibbs
Comment Utility
jhance: 127.0.0.1 *is* a valid URL, but it's reserved for the loopback address--in other words, it always refers to the local machine, regardless what its actual IP address is.
0
 
LVL 32

Expert Comment

by:jhance
Comment Utility
pjknibnose,

127.0.0.1 is a valid _IP address_ but NOT a valid URL.

URL is NOT THE SAME THING as IP address.  And in fact, they are unrelated.
0
 
LVL 12

Expert Comment

by:pjknibbs
Comment Utility
jhance: Sorry, I misunderstood your original post. No reason to get offensive, though.
0
 
LVL 63

Expert Comment

by:SysExpert
Comment Utility
Since you have no Network card, it is probably binding to the dial-up interface, which is why it asks you to connect to your ISP. That's why it does work when you are connected. Please give a broader descriptio of what you are trying to achieve so that we can solve your problem.
I hope this helps.
0
 
LVL 27

Expert Comment

by:Asta Cu
Comment Utility
Listening.

Asta
0
 
LVL 10

Expert Comment

by:trekie1
Comment Utility
me 2 Asta
0
Do email signature updates give you a headache?

Do you feel like all of your time is spent managing email signatures? Too busy to visit every user’s desk to make updates? Want high-quality HTML signatures on all devices, including on mobiles and Macs? Then, let Exclaimer solve all your email signature problems today!

 

Author Comment

by:johnclarke
Comment Utility
Basically we want to be able to connect to the Apache Web server without having to be connected to Freeserve.  However,  we don't want this to interfere with our ability to use Freeserve.

John
0
 
LVL 63

Expert Comment

by:SysExpert
Comment Utility
I think you are going to have to add a dummy modem-direct serial connection interface that you can bind TCP/IP to instead of the dial-up device. You can do this by adding the adapater - microsoft - loopback adapter  connection in the network aplet- adapaters- Add - choose the microsoft loopback adapter. This should solve your problem.  I hope this helps !
0
 
LVL 12

Expert Comment

by:Housenet
Comment Utility
Create a Hosts. file in c:\windows have the first line say this
127.0.0.1     localhost
0
 
LVL 12

Expert Comment

by:Housenet
Comment Utility
Housenet changed the proposed answer to a comment
0
 
LVL 12

Expert Comment

by:Housenet
Comment Utility
-Change your control panel internet settings to NOT dial a connection. Change the setting to "USE LAN"
0
 
LVL 12

Accepted Solution

by:
Housenet earned 100 total points
Comment Utility
-Change your control panel internet settings to NOT dial a connection. Change the setting to "USE LAN"
0
 
LVL 27

Expert Comment

by:Asta Cu
Comment Utility
Any news, John?

Good morning, Housenet.  Two concurrent "answers"; most interesting.  Comments vs. answers, in my humble opinion, serve our clients best since the Q isn't 'locked' and encourages others with input to participate.  Experts-Exchange has been reprogrammed to allow our clients to convert the 'best comment' to an answer directly, but this flexibility is taken away when answers are posted and rejected.



Asta
0
 
LVL 27

Expert Comment

by:Asta Cu
Comment Utility
I'd sure love it if someone could explain this one to me.

What, ultimately, was the fix?

Thanks a bunch, and sorry for being stupid, it's been a long week, and my hair braids are tied up in cables.

Asta
0
 

Expert Comment

by:boatman9999
Comment Utility
What worked for me was:

1. Find the 'hosts' file in the Windows directory (it may be a sample file hosts.sam). Add or amend the a line to be 127.0.0.1 localhost name1 name2 name3 etc where name 1 (etc) are the names of your virtual hosts. Keep the entry on one line. Seperate each word separeted by at least one space. Save the file as hosts (there is no file extention!). Reboot the machine.

2. Stop Internet Explorer from trying to access the internet automatically via dialup (autodial). See http://www.geocities.com/Athens/Troy/6883/password.html#Fix%201.%20DUN's%20Autodial%20Feature

or:
GO TO:
1. Start, then Run, then in the command line type in "regedit" without the quotes
2. Click on Registry, then export the registry file to a holding directory,
EXAMPLE: C:\1\BACKUP.REG
3. Expand the HKEY_CURRENT_USER
4. Expand Software
5. Expand Microsoft
6. Expand Windows
7. Expand Current version
8. Expand Internet settings
Now look in the right hand panel and check if the "EnableAutodial" is set to 0000 00 00
9.If not set it to 0 (turns off autodial).

3 Add <virtual host> entries to your hppd.conf file in Apache (see Apache documentation). Make the server names (1, 2, 3 etc) the same as those in the 'hosts' file. Start Apache.

Hope this helps.
0

Featured Post

Shouldn't all users have the same email signature?

You wouldn't let your users design their own business cards, would you? So, why do you let them design their own email signatures? Think of the damage they could be doing to your brand reputation! Choose the easy way to manage set up and add email signatures for all users.

Join & Write a Comment

A few months ago I had an issue with LaserJet 1020 printer which was installed to XP and Windows 7.  It was installed to XP and working, but when I tried to connect from a Windows 7 PC, it would attempt connection and then fail.  Sometimes the Spool…
Today, still in the boom of Apple, PC's and products, nearly 50% of the computer users use Windows as graphical operating systems. If you are among those users who love windows, but are grappling to keep the system's hard drive optimized, then you s…
Windows 8 comes with a dramatically different user interface known as Metro. Notably missing from the new interface is a Start button and Start Menu. Many users do not like it, much preferring the interface of earlier versions — Windows 7, Windows X…
Windows 8 came with a dramatically different user interface known as Metro. Notably missing from that interface was a Start button and Start Menu. Microsoft responded to negative user feedback of the Metro interface, bringing back the Start button a…

744 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now