Solved

WINS and DNS resolution in wrong order?

Posted on 2000-03-03
9
3,369 Views
Last Modified: 2013-12-23
We have a network of W95 PCs and an NT server. An ISDN router connects us to the Internet.
We only use the TCP/IP protocol, and allocate IP addresses using DHCP.
The DHCP server and a WINS server are installed on the NT box.

All PCs need to browse the Internet so we have set up DHCP to allocate the following entries:-

Router: (IP address of ISDN router)
WINS/NBNS Server: (IP address of NT server listed twice for primary and secondary)
WINS/NBT Node Type: 0x8
DNS Servers: (IP address of ISP's DNS server)
Domain Name: (i.e mycompany.co.uk)

Whenever we start the Exchange client on a PC, the ISDN router makes a call as if it is trying to resolve the name of the server via DNS...

We have done some tests, such as trying to ping the local server from a PC. When I type "ping servername", the router makes a call as if it is attempting to resolve the name via our ISP's DNS server. After a few seconds the IP number is resolved and we receive ping responses from the server.
Why does the PC seem to use DNS resolution instead of WINS resolution?
The ISP's DNS doesn't have an entry for our server, so I would assume the final resolution is being done by WINS anyway!

If I remove the DNS server entries from the DHCP scope the PCs resolve immediately using the WINS server, and don't force the router to make a call.

If I set up a W95 PC to have a fixed IP address instead of DHCP the problem remains... The router makes a call before the IP number is resolved.

If I disconnect the ISDN line from the router so it can't call, the ping command takes an absolute age to respond before it eventually resolves the IP address. Is this DNS timing out, and then attempting to resolve using WINS?

So - WHY doesn't the PC use WINS in preference to DNS? Every document I can find says that this is the way it should work!
0
Comment
Question by:tena
9 Comments
 
LVL 8

Expert Comment

by:netmage
Comment Utility
Yep, it should do. When using netbios names to ping, DNS should be last.

I tend to think you may have a WINS problem and your name resolution is achieved via Broadcast.


To test this,
 
change DHCP OPT46 WINS/NBT Node Type: 0x8
 to P-Node (0x2)(Peer to Peer Node)

This will remove network broadcasts and only allow a lookup in order of  Cache, Wins, Hosts, DNS.

Renew your IP address leases prior to testing.

If the system fails to resolve a name then i'd say wins need to be checked.

0
 
LVL 6

Expert Comment

by:sgenther
Comment Utility
Actually if you have DNS enabled,by default the look up order is:hosts,DNS,WINS, broadcast,lmhosts.
If you change to WINS only then the order is NBT cache,WINS,broadcast,lmhosts.
0
 
LVL 8

Expert Comment

by:netmage
Comment Utility
yes sgenther,Dns is used prior to wins when querying a fully qualified domain name.
This name reference is actually unclear in the question.

But since DHCP rules here,

The "C"an "W"e "B"uy "L"arge "H"ard "D"isks lookup is the way DHCP opt46 0x8 hybrid node type is working.

I would hope that in setting up DHCP for the intranet that the wins option to point to a DNS server is not being set to point to a server that has no authority within this network.

Perhaps a fix that would give a cure to this problem would be to install a primary DNS server  on this intranet and let it do forward lookup to an external ISP caching nameserver instead of each client resolving names for itself.

Generally this is alot smoother in operation.

0
 
LVL 12

Expert Comment

by:Nenadic
Comment Utility
PING is an internal TCP/IP command and is used with hostnames. There is no choice in this, so DNS is expected to be used to resolve the name.

If DNS exist, it will be contacted. If it doesn't, then through MS enhancements to hostname resolution, it will attempt other methods.

The only think you can do in order to speed up PINGing is to set DNS for WINS resolution.

0
New My Cloud Pro Series - organize everything!

With space to keep virtually everything, the My Cloud Pro Series offers your team the network storage to edit, save and share production files from anywhere with an internet connection. Compatible with both Mac and PC, you're able to protect your content regardless of OS.

 
LVL 3

Expert Comment

by:klover
Comment Utility
To get around this you can very easily host your own DNS server.

or you can place a call filter on your router so the calls are never made...
Here is an example of how and why for a Netgear ISDN router...
http://www.netgearinc.com/support/support_rt328/RTapps/Using_Filters.html
0
 
LVL 23

Expert Comment

by:Tim Holman
Comment Utility
Do you have WINS client installed on each PC ?
Is the correct WINS server listed in client settings ?
Do you have a static entry for your Exchange server in WINS ?
If you have WINS client setup properly, and start up Exchange, resolution will only go to DNS if everything else fails.
I think maybe your WINS is having problems ?
Is you Exchange server multihomed ?
0
 

Accepted Solution

by:
IrvingLD earned 200 total points
Comment Utility
Ok I remember this one, searched through my stuff and found references to the following ;

http://support.microsoft.com/support/kb/articles/Q163/5/76.ASP

This goes into great detail about how Outlook / Exchange clients talk to the server.

By default Windows 95/NT workstations use the following protocol order

1. TCP/IP
2. SPX
3. Named pipes
4. NetBIOS
5. VINES IP (Windows NT Server and Windows NT Workstation only)

I may be wrong on this but the client only uses WINS for netbios name resolution and therefor unless binding order is changed the default would be DNS for name resolution.

So changing your binding order should sort this out.

0
 
LVL 12

Expert Comment

by:Housenet
Comment Utility
-Make sure the WINS server IP is listed for the right network card on your server. (The inside card). The Nic on the routers subnet shouldnt have wins servers definded. Dont check use DNS for WINS resolution.
Use options type=44, & 46 in WINS. You're already using one of them I see. Try creating a host file & on a workstation using inside addess resolutions. Lmhost like this
 "192.168.1.2 server1  #PRE #DOM:domain"
0
 

Author Comment

by:tena
Comment Utility
The commments from IrvingLD hit the nail right on the head. The initial question was about the Exchange client using DNS rather than ping. The techniques discussed in the KnowledgeBase article have cured the problem! Thanks to everyone for their help and advice.
0

Featured Post

Better Security Awareness With Threat Intelligence

See how one of the leading financial services organizations uses Recorded Future as part of a holistic threat intelligence program to promote security awareness and proactively and efficiently identify threats.

Join & Write a Comment

Have you ever set up your wireless router at home or in the office to find that you little pop-up bubble in the bottom right-hand corner of Windows read "IP Conflict - One of more computers on the network have been assigned the following IP address"…
This article offers some helpful and general tips for safe browsing and online shopping. It offers simple and manageable procedures that help to ensure the safety of one's personal information and the security of any devices.
Excel styles will make formatting consistent and let you apply and change formatting faster. In this tutorial, you'll learn how to use Excel's built-in styles, how to modify styles, and how to create your own. You'll also learn how to use your custo…
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

7 Experts available now in Live!

Get 1:1 Help Now