Solved

Unknown disk found by Win98 (WinNT dual boot)

Posted on 2000-03-05
15
250 Views
Last Modified: 2013-12-28
I have a dual boot configuration between Win98 and WinNT.  Whenever I boot on Win98, I have a drive seen as F: which is not accesable by the system.  When I click on F:, it gives the following error:
"F: is not accesable.
 A device attached to the system is not functioning."
I do have a partition on one of my disks which has NTFS, but it is my understanding that the NTFS partition won't be detected by Win98.  Also, whenever I try to empty my recycle bin I get an error for F:.

Any suggestions on how to "remove" this non-existant device?
0
Comment
Question by:cwirrgan
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 4
  • 3
  • +2
15 Comments
 
LVL 5

Expert Comment

by:compmania
ID: 2585653
How many partitions do you have installed?
0
 
LVL 10

Expert Comment

by:tonnybrandt
ID: 2585759
Try this:
Run regedit in win98.
Look at HKEY_LOCAL_MACHINE\ENUM\SCSI
and remove the item that has the driveletter F:
Close and reboot.
Let us know how it turned out.
0
 
LVL 7

Expert Comment

by:sorgie
ID: 2585921
If you don't find it in SCSI (where cdrom drives are listed) Look in the same folder key but in the ESDI folder were hard disk are listed
Good Luck
0
Get 15 Days FREE Full-Featured Trial

Benefit from a mission critical IT monitoring with Monitis Premium or get it FREE for your entry level monitoring needs.
-Over 200,000 users
-More than 300,000 websites monitored
-Used in 197 countries
-Recommended by 98% of users

 

Expert Comment

by:kkemper
ID: 2586304
you did not say what the control panel shows.

Does it show such a drive?

if so, your problem is solved. If not,
what does scanning do for you?

I am not NT skilled. so I am shooting from the hip.
0
 

Author Comment

by:cwirrgan
ID: 2591220
My control panel only lists the Drives that I would expect to see.  I looked under system/device manager and  the floppy drive and my two hard drives are listed.  The controllers look fine to me too.  The drive F: isn't recognized, so it can't be scanned.

I've created two machines as dual boot using Partition Magic.  One machine has the problem and one doesn't.  I've currently logged a question with them, but while I was waiting I wanted to ask the experts.  

I looked in the registry, and did find a suspect entry under LOCAL_MACHINE/ESDI.  I removed it, but Win98 still sees the "extra" F: drive.  I have since put the registry entry back.

I've got several partitions.  

Drive 1:
G: FAT - (where NT is)
C: FAT32 - (where 98 is)
Drive 2:
D: FAT
E: FAT
*: NTFS (F: when booted into NT)


Any other thoughts?
0
 
LVL 10

Expert Comment

by:tonnybrandt
ID: 2591309
Question:
You did look in the registry under LOCAL_MACHINE/SCSI ?.
My machines CD and HD's are listed here although all are IDE-devices.
0
 

Expert Comment

by:kkemper
ID: 2591431
what sin might be committed if you got rid of Partition Magic?
and did an operational undelete?
0
 

Author Comment

by:cwirrgan
ID: 2591515
I did look under LOCAL_MACHINE/SCSCI in the registry and that is indeed where all my HD and CD drives were listed.  Since those all matched my machine configuration, I did not modify those.  As I mentioned before, I did get rid of the one in ESDI, rebooted, but it didn't seem to matter.

OK kkemper, how do you go about an operational undelete?  I've already got my machine partitioned so I don't really need Partition Magic anymore.  But I do not want to mess up the valid partitions!
0
 
LVL 10

Expert Comment

by:tonnybrandt
ID: 2591686
Have you tried Tweakui ?. It is supposed to be able to delete phantom-drives. Here is a URL, if you haven't tried it.
http://www.annoyances.org/win98/features/tweakui.html
Good luck
0
 

Author Comment

by:cwirrgan
ID: 2592840
I just tried Tweakui.  It did hide F: from the user interface, but every time I boot into Win98, I get an F: error.  Also, my norton utilities errors out every time it tries to check F:
0
 
LVL 5

Expert Comment

by:compmania
ID: 2592859
Have you tried hiding the NTFS partition from the windows one?
Partition Magic should do it if not then this will:

http://download.cnet.com/downloads/0-10096-100-914828.html?tag=st.dl.10001_103_1.lst.titledetail
0
 

Expert Comment

by:kkemper
ID: 2593373
i withdraw my suggestion.  The others' ideas were better.  
0
 
LVL 10

Expert Comment

by:tonnybrandt
ID: 2593529
I searched the net for similar problems, and found that severel Q&A sites had the question. The answers given to the questions were practically the same:
The say that it might be unused space on your hd that windows 98 detects and assigns a driveletter. Meaning that it might not be your NTFS partition that is causing the driveletter to be assigned, but a small free space. They mention that space as small as 1 or 2 Mb unpartitioned space on your hd can cause this.
Do you have any free space on your hd ?
0
 

Author Comment

by:cwirrgan
ID: 2600563
Well, I've finally gotten rid of the extra drive letter.  I didn't have any extra space on the disk, so I continued to investigate the existing partitions.  For whatever reason, Win98 was always creating an extra drive F: whenever I had my WinNT as a FAT and Win98 as a FAT32.  I converted my WinNT partition to NTFS and the extra drive F: has gone away!  I don't know why it was different on this machine than my other, since my other machine has WinNT on a FAT and Win98 as a FAT32 and there is no problem there.  The only difference I can see is that the drive sizes are different.

Anyway, the partition manager tonnybrant suggested using was very helpful in diagnosing and deleting existing partitions.  As well were your other comments and research.  I would like to award the points to you.
0
 
LVL 10

Accepted Solution

by:
tonnybrandt earned 100 total points
ID: 2600620
I'm glad you solved you problem, and that i could be of help.
I'm posting this as an answer. I belive that's what you want me to do.
0

Featured Post

Manage your data center from practically anywhere

The KN8164V features HD resolution of 1920 x 1200, FIPS 140-2 with level 1 security standards and virtual media transmissions at twice the speed. Built for reliability, the KN series provides local console and remote over IP access, ensuring 24/7 availability to all servers.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

A project that enables an administrator to perform actions within a user session context not just at the time of login but any time later on day(s) or week(s) later.
Ever visit a website where you spotted a really cool looking Font, yet couldn't figure out which font family it belonged to, or how to get a copy of it for your own use? This article explains the process of doing exactly that, as well as showing how…
With the advent of Windows 10, Microsoft is pushing a Get Windows 10 icon into the notification area (system tray) of qualifying computers. There are many reasons for wanting to remove this icon. This two-part Experts Exchange video Micro Tutorial s…
In this video, viewers are given an introduction to using the Windows 10 Snipping Tool, how to quickly locate it when it's needed and also how make it always available with a single click of a mouse button, by pinning it to the Desktop Task Bar. Int…

623 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question