Defragging in DOS

I am having a problem defragging one of my logical drives in Windows, but when I go to DOS to try--it tells me I must use Windows. Is there a DOS command I can use? Thanks for any help. Sally
smassoAsked:
Who is Participating?
 
AjninConnect With a Mentor Commented:
Sorry I gave the wrong information the AppLog is a folder and microsoft says to delete everything in that folder
0
 
hewittgCommented:
Smasso,
Have you tried defrag in safe mode?

Glenn
0
 
sorgieCommented:
Are you booting to Dos or going to the dos prompt from Windows?
0
Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

 
celticsCommented:
Be careful what version of Defrag you use.  If you use the old dos one it will chop off the long names if you get it to run.  

What you are trying to run now is the Windows base Defrag so it will not run in DOS mode.

If you are trying to run it without nothing else running, the best you can do is to boot into Safe mode and run it from there.  To get into Safe Mode press <F8> after the memory post several times until the boot menu appears, then select Safe Mode.
0
 
AjninCommented:
Win98 comes with a defrag that runs before any TRS are loaded just goto X:\tools\mtsutil (given X is the CD-ROM drive) and RIGHT CLICK on Defrag.inf & choose install. Then reboot your machine. This only works once so if you want to do it again you need to install the inf again.
0
 
pcchiuCommented:
Run "scandisk" in windows and run the defrag again in windows and that may work.
0
 
sgentherCommented:
Easy way of getting the "dos" version to run...shut off the pc without shuting down, 98 will think there is a problem and run scandisk on boot.
0
 
smassoAuthor Commented:
Thanks all--I ran in safe mode and it would not defrag, saying it "encountered a problem--do scandisk first and then retry". Did a thorough scan on my D drive(in safe mode)and it said "no bad sectors" and apparently no problems for the scan. So tried the defrag again (in safe) and it stopped again on about 15% saying same encounter of problem.  How can this happen to a logical drive?  My primary C: drive is OK.  I also tried Norton first, and it did the same thing. So shut it down and went this route.

This really puzzles me.
Sally
0
 
AjninCommented:
Forgot to ask the obvious. What the problem with the defrag
0
 
sgentherCommented:
opps, sorry I miss read, though you said scandisk.
0
 
smassoAuthor Commented:
Adjusted points to 400
0
 
smassoAuthor Commented:
Ajnin--did what you said with the defrag.inf and came up with same--"enounter a problem--Defrag00205".Think I've got an extraordinary problem, so am upping the points.  Thanks--Sally
0
 
rayt333Commented:
smasso
You may want to reject the proposed answer, alot of experts will not look at or comment on locked questions. If that proposed answer was no help then reject it to open the question back up.
0
 
smassoAuthor Commented:
apparently can't keep it open unless i reject
0
 
AjninCommented:
do a search for applog. then delete the file. apparantly this is a known issue
0
 
SysExpertCommented:
Have you tried booting from the norton utilities CD and running the version on the CD ?  This may help pinpoint whether it is a hardware or software problem since it is in DOS mode. I hope this helps.
0
 
centervCommented:
Defrag Error Message: ID No:DEFRAG00205



   The information in this article applies to:

         Microsoft Windows 98
         Microsoft Windows 98 Second Edition



   SYMPTOMS

   When you run the Disk Defragmenter tool in Windows 98, you may receive the following error message:

         Error Defragmenting Drive C

         Windows cannot finish defragmenting this drive because it has encountered a
         problem. Click Help and carry out the instructions for running Scan Disk, and then
         try defragmenting again.

         ID No:DEFRAG00205


   CAUSE

   This issue can occur if the Applog file in the hidden C:\Windows\Applog folder is damaged.


   RESOLUTION

   To resolve this issue, follow these steps:

       1.Right-click an empty area on the desktop, and then click Properties.

       2.On the Web tab, click Folder Options.

       3.Click Yes.

       4.On the View tab under Hidden files, click Show all files, and then click OK.

       5.Click Start, point to Find, and then click Files or Folders.

       6.In the Named box, type applog, click C: in the Look in box, click to select the Include subfolders
         check box, and then click Find Now.

       7.Double-click the Applog folder to open it.

       8.On the Edit menu, click Select all.

       9.On the File menu, click Delete, and then click Yes when you are prompted to confirm the deletion.

   Additional query words:

   Keywords : kbenv kberrmsg defrag win98 win98se
   Version : WINDOWS:
   Platform : WINDOWS
   Issue type : kbprb



                                     Last Reviewed: November 24, 1999
                          © 2000 Microsoft Corporation. All rights reserved. Terms of Use.
0
 
centervCommented:
Link for the above article.

This should resolve your problem.

Dos defrag does not work in Win98,
and you'll encounter same error in safe mode, as mentioned above.

Ajnin was on the right track.  Not a problem if you wish to accept his answers.

Good luck.


http://support.microsoft.com/support/kb/articles/Q238/1/65.ASP
0
 
netmageCommented:
If the above doesn't work, this wasn't asked so here goes, How much free space is on the drive?

0
 
smassoAuthor Commented:
Ajnin was the first one to give the applog answer--but I don't know how to award it to him. Someone please explain

Sally
0
 
smeebudCommented:
Restart the computer, press <CTRL> or <F8> key before win98 logo appears, At the boot menu, go to the command mode.

At the C:\ prompt, type "scandisk /all /autofix /nosave /nosummary /surface" without the quotation mark and press enter. It will scandisk and fix errors and a detail surface scan.

It looks like this: -

C:\>

C:\>scandisk /all /autofix /nosave /nosummary /surface

After finished, it will return to C:\> prompt. The bad sector will be marked out.

Regards,
Bud
http://www.geocities.com/~budallen/
Bud's Win95 Win98 Tips and Troubleshooter
0
 
centervCommented:
If the answer worked for you, just accept his
comment as the correct answer.

Good luck.

0
 
SpikYCommented:
It's only a comment....
ok 2 things to try...
1. in dos mode (enter windows and shut-down in ms-dos mode)
   Goto d:\
   type regscan
   do the regscan
   reboot the systeme an try defrag again...

2. Move all your files on an other HD (virtual or not)
   Then format d:\
   replace your files
   do the defrag

If it works fine GREAT

Remember the last comment is ONLY A "WAR" methode for the system
0
 
compmaniaCommented:
Have you tried doing a normal scandisk on all your drives? (except the floppy and cdrom) I am not talking about through but standard.

Try making a boot disk (control panel, add/remove programs, startup disk) then restart and type scandisk c: at the a:\> prompt.
0
 
canUCmeCommented:
Do you have warranty left ..I think you hd is damaged..Some REaly bad sectors..Most of disks comes with 3 year warranty.Call your  hd vendor..if you have warranty left..
0
 
netmageCommented:
You can see who reads the whole of a questions thread through before they post comments :-)

I thought this problem was resolved.
0
 
canUCmeCommented:
I readed the first and last one..I have to admit...Didn't see the ...aargh...
0
 
morbiusxCommented:
there is no defrag in dos because it is a windows only program. I would make sure nothing is running in the background, like a virus scan utility or any other programs that may be running besides what is supposed to running:explorer
        rnaapp
        systray
then go to scan disk do a normal scan then retry defrag. if none of this works im at a loss.

  morbiusX
0
 
celticsCommented:
From the comments I have seen from smasso this problem has been resolved by Ajnin.  So unless smasso states otherwise :

Ajnin,
Please post your comment on Applog as an answer so we can close this question.

- or -

smasso,
Please accept Ajnin comment as an answer, you have that option.
0
 
smassoAuthor Commented:
Thanks Ajnin--Worked great! Sally
0
 
compmaniaCommented:
Did read the comments, must have missed that one...
0
 
smassoAuthor Commented:
Yes, I did accept Ajnin's answer
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.