We help IT Professionals succeed at work.

LNK1104 fatal error when compiling a DLL

jonjon
jonjon asked
on
708 Views
Last Modified: 2013-11-20
I am compiling an MFC DLL project using Visual C++ 6.0.  It compiles and Links fine in Release mode.  However, If compiling in Debug mode, when it tries to link, I get the fatal error: "LNK1104 cannot open file '/Debug/Gp.dll'".  MSDN help suggested a few things that could be the problem:  low on disk space, the file does not exist, wrong filename or path, drive is invalid etc.  None of these appear to be the problem. Also I've checked PView.exe and Task Manager to make sure the DLL is not still running somewhere.  I'm stuck, not being able to link in debug mode for I need to debug a problem in the code.
Thanks,
jonjon
Comment
Watch Question

Vinayak KumbarSr Program Manager

Commented:
Hi,

Is 'Gp' is the project workspace name?. If not, then go to project->settings, choose the link->, there give the correct name.

It is surely something to do with Ur project settings. Check the settings once.

VinExpert
Vinayak KumbarSr Program Manager

Commented:
Hi,

One more crude method....

Restart Ur PC. delete the debug directory. And say ReBuildAll. Then it may solve Ur prob. I told this because, there may be a instance though U have checked....!!!!(I guess)

Try it out.

VinExpert

Author

Commented:
Yes, 'Gp'is the name of the workspace.  I agree that it is probably something in the settings.  I'm just not sure what it is.  I even put the full path for the output file:  "d:\Gp\Debug\Gp.dll"
Any other ideas?
Thanks
Vinayak KumbarSr Program Manager

Commented:
Hi,

I can't guess any more. Have U restarted and seen?. The last thing, that I can help U is, send me that dll workspace if u want, to k_bbb100@hotmail.com and I will check it once.

VinExpert

Author

Commented:
Yes, I deleted the /Debug directory and restarted my machine.  No effect.  Still no linking in Debug mode.
Sr Program Manager
Commented:
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION

Author

Commented:
You are the Man!

Author

Commented:
WOW!, that worked.  I completely overlooked the reset button, I've never had to use it.  Something in the Link settings must have gotten corrupted.  Thanks for taking the time to review my workspace, I really appreciate the speedy solution.
Thanks
JonJon
Vinayak KumbarSr Program Manager

Commented:
HI,

That was learning experience for me too..

VinExpert
Vinayak KumbarSr Program Manager

Commented:
And...

I have deleted it....


VinExpert

Author

Commented:
Thank You

Gain unlimited access to on-demand training courses with an Experts Exchange subscription.

Get Access
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Empower Your Career
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.