Linux refuses to boot!

Hi there,

I have a problem trying to get my linux PC to boot. The machine must not have been cleanly shutdown and now every time i try and boot it i get the following :-

...
...
INIT version 2.74 booting
Loading default keymap/etc/rc.d/rc.sysinit: /dev/null: Read-only file system    [FAILED]
Setting default font     [OK]
Setting hostname inet.com [OK]
Checking root filesystem

This is were it hangs, i get no disk activity at all, and i have left it for about 40mins+

Any help with this would be greatly appreciated.

Regards
Lee.

(By the way i am running RedHat 6.0)
LEEJGAsked:
Who is Participating?
 
jyu_88Connect With a Mentor Commented:
did you upgrade kernel or sth along that line lately? You also needs to upgrade  a package called 'e2fsprogs' or 'e2fsutils' whichever contains e2fsck.

I did a 5.2->6.1 jump and had similar problem. upgrade the above-mentioned pacakge, then, I am there.
0
 
jlevieCommented:
It sounds like the state of the file systems at boot wasn't clean and fsck, when it ran, couldn't fix them. Try booting single user ("linux single" at the lilo boot prompt) and running fsck manually on each file system. You could have a damaged file system or, worst case, a failing disk drive. If it looks like the disk, it would be good to check the biso settings to be sure they haven't changed.
0
 
LEEJGAuthor Commented:
Hi jlevie

Thanks for you quick response :-)

I can now get to a bash# prompt and see my filesystem (Using "linux single"), but everytime i try and use :-

fsck -t ext2 /dev/hda5
or
fsck /
or
fsck -t ext2 /

I get the following :-
Parallelizing fsck version 1.14 (9-jan-1999)

With no disk activity at all or any messages.

Any Ideas?

Thanks
Lee.
0
Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

 
LEEJGAuthor Commented:
also if i shutdown the PC again i get the original problem

0
 
bernardhCommented:
try the command e2fsck -p /dev/hdXX where XX is the device needed to get fixed, say /dev/hda5.

answer all questions with the default (usually yes or ignore). basically, e2fsck is run in similar situations as scandisk would be run during startup in a windows box.

after all the check, shutdown your box with the command: shutdown -r now, reboot or halt
0
 
freesourceCommented:
-p    Automatically  repair  ("preen")  the  file  system without any questions.

It's possible your superblock is corrupt, so you may have to do something like this:

e2fsck -b 8192 /dev/hdXX

You'd be better off doing all this from an emergency disk with the partition you want to fix unmounted.
0
 
LEEJGAuthor Commented:
Thankyou jyu_88, i downloaded the latest version and installed,

Its Now working!!!!!

Many thanks, to all the experts that have helped me.

Lee.
0
 
ibwanCommented:
how to upgrade 'e2fsprogs' and upgrade kernel
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.