Cache

When I try to play a Klingon Cd-Rom game my system displays a cache error.
Excersion failed. Cache item=no d://klingon History FMEM Cache error.
The error has some more text in it; it looks like computer code or something. The game works fine on other systems, I have tried other disks that seem to work fine. I have a Celeron 466 with 64M memory and have Win98. The disk is not partitioned.
If you need more info I can get it for you. I am somewhat familar with computer systems so if you could point me in the right direction it would be much appreciated. Thank in advance.
montes72Asked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
sunsetyangConnect With a Mentor Commented:
sorry for my doing.
I want to point one thing,the cable connected between the Cirrus Logic adapter and the Monster3D adapter was to handling the display signals.If the signals are just no 3D computations,the cable pass through the
whole signals right to the monitor;If there are some 3D computations,the signals will be combined with the computation result then pass to the monitor.
  You forgot to metion one thing:If you choose no to the 3D card question,Would it report the cache error?
  In my view,this problem was probably
caused by your display adapters.You can reference the documents with the game to check whether Monster3D is in the support list Or anything further the game needs.
 
0
 
hewittgCommented:
Is your disk partitioned, it seems to me that it is looking for cd on d:

Is this the case?

Glenn
0
 
montes72Author Commented:
No the disk is not partitioned.
0
Improved Protection from Phishing Attacks

WatchGuard DNSWatch reduces malware infections by detecting and blocking malicious DNS requests, improving your ability to protect employees from phishing attacks. Learn more about our newest service included in Total Security Suite today!

 
montes72Author Commented:
Edited text of question.
0
 
sorgieCommented:
if not set already try opening system properties.
Open the properties for your CDROM and check the DMA box see if it makes a diff.

Have you played this game before on your machine?
How old is your CDROM?
How new is the game?
0
 
montes72Author Commented:
No I havent but it has played on other systems. I can play other cd-roms with no problems. It is a new game Klingon Honor Guard which has been replaced. It is a new system. I tried DMA with no difference.
0
 
montes72Author Commented:
The exact error Im getting is:
Critical Error:CacheItems=Null
(file d:\klingons\core\src\uncache.cpp(line:44)
History:FMEMCache::flush fglideRenderDevice::flush
VGlideRender::Init VgameEngine::Init
InitEngines
This comes up after I click the icon and it goes through what looks like file installations.
I have tried removing and reinstalling but that didnt help; actually there was a problem removing the game. It didnt remove some of the files I think.
I have tried disabling the internal and external cache.
0
 
sunsetyangCommented:
It does not seem to be anything wrong with your cdrom,but your display adapter.The error may be something wrong with your graphic acceletator adapter,Either software or hardware.
The error message shows that it was doing some VGA or display activities when this problem occured.You'd better to describe your machine's configuration
and the display adapter.
0
 
sorgieCommented:
sunsetyang

Please follow protocol and post your suggestions as comments
Unless you are absolutely sure you have the solution to a problem.
By posting your suggestion as an answer you lock the question to other experts and most won't look at a locked question so you may stopped the person from receiving a solution

Thanks and Welcome
0
 
montes72Author Commented:
Well this is where it gets interesting; there are two video adaptors in the system. There is a Cirrus Logic 5464 (I think that is the proper number) and there is a 4m Diamond Monster3d. The system is setup for the cirrus logic card (drivers loaded) but there is a cable going from the Monster card to the cirrus logic card (on the outside of the cards) I have tested both cards seperately and found out that the cirrus logic card works but the Monster does not (getting no video whatsoever) When setting up the game it asks whether or not you have a 3d card. I have said yes and have found that the game does not work but when I say no the game works but does not display 3d graphics. I'm not sure what the cable does; if it takes the memory from the monster and embeds it to the cirrus logic card. I should mention that the game will run with 3d graphics for some time but will start to get grainy (this is even after i say no to the question "do u have a 3d graphics card" during installation.
0
 
sorgieCommented:
Montes

Check this site it is the lastest monster3D and monsterII driver

 http://www.diamondlegacy.com/products/drivers/driver-index.htm
0
 
waynebCommented:
It is possible that the cache in the cdrom is defective, as these cdroms get faster and faster they utilize cache memory to offset the speed difference.
0
 
waynebCommented:
Another thing you may want to check is,
right click on my computer and then goto performance, there are some settings there that may help you troubleshoot this problem.
0
 
montes72Author Commented:
No the error did not appear after saying no. I put the monster in another system and i did not get any video whatsoever. So is the cirrus logic card using the memory from the monster even if i cant get video from the monster. Is there any tests i can run to verify cd-rom cache.
0
 
montes72Author Commented:
NP sunsetyang. thx for the info sorqie.
0
 
netmageCommented:
This game is based on the "Unreal" Game engine.

There are some fairly comprehensive options to be edited in that script you see failing but first could you try getting the game update patch.

Unforatunately, the game didn't get the same attention as "Unreal" but the fixes are the same.

You could also try loading the game in its safe mode and adding featured one by one till the error reoccurs.

get directX 7.0a.
You will then have options to try the game in d3d,glide or software.
 
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.