Solved

trouble configuring kernel

Posted on 2000-03-07
5
251 Views
Last Modified: 2013-12-16
I am trying to configure a new kernel to compile.  When I run 'make config' or 'make xconfig' I get the error

no rule to make target 'config'. Stop.

What would cause this error?  I am using Mandrake dist of Linux version 7.0.  

I am in the /usr/src/linux directory when issuing this command.
0
Comment
Question by:maharusty
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 
LVL 2

Accepted Solution

by:
Reinier earned 50 total points
ID: 2592354
Do you actually have the kernel sources installed? Is there a file "Makefile" in that directory?
0
 
LVL 1

Author Comment

by:maharusty
ID: 2592686
No there was not a Makefile in the directory.  I downloaded the latest kernel source and it worked well.  Thanks.  I am not sure why Mandrake did not put that stuff in the directory but I got it working now.  The only thing is to get the new kernel working now.  But I guess that is just trial and error eh??
0
 
LVL 2

Expert Comment

by:Reinier
ID: 2593698
Not just trial and error. It helps if you have a correct list describing your peripherals, including brand, chipsets, etc. It also helps to know which modules your present kernel uses to access your hardware. The rest is trial and error. Call it learning.
0
 
LVL 1

Author Comment

by:maharusty
ID: 2595744
I had succesfully put together one kernel and rebooted to it.  It worked but there was no sound support or support for supermounter (what ever that is).  I put together another kernel with sound support and the load dies.  Like you said it is learning.  I know that I have the right sound card but I must have done something wrong.  Oh well I will have to learn some more I guess.  At least I do not have to completely reinstall like I would have to with Winblows NT!!!!  ;-)
0
 
LVL 2

Expert Comment

by:Reinier
ID: 2595928
Compile your sound support as a module. It is much easier to pass parameters to the driver that way. Probabely the parameters are still in /etc/conf.modules

0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

rdate is a Linux command and the network time protocol for immediate date and time setup from another machine. The clocks are synchronized by entering rdate with the -s switch (command without switch just checks the time but does not set anything). …
Setting up Secure Ubuntu server on VMware 1.      Insert the Ubuntu Server distribution CD or attach the ISO of the CD which is in the “Datastore”. Note that it is important to install the x64 edition on servers, not the X86 editions. 2.      Power on th…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial

737 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question