Transplanting a hard drive between machines

I've transplanted a WIN95 drive from a Pentium 75 to a Pentium 133. Both machines are AST.

I've done this before, and usually after a few reboots and removing question marks and/or Exclamation point items from the System Applet of the Control Panel, I can usually get things to work.

Problem:  In the Device manager I have 3 hard disk controllers that look like this:
! Primary IDE Controller (Single fifo)
! Secondary IDE Controller (Single fifo)
Standard Dual PCI IDE Controller

I try to remove the two top ones with the ! next to them, but they come back.

The CDROM drive (which is on the secondary controller) is not recognized.

Main objective is to get the CDROM drive recognized....I assume that means I got to get the "ghost" controllers removed permanently.

How do I fix This???
laroucheAsked:
Who is Participating?
 
SysExpertCommented:
Have you tried to update the IDE drivers form the AST site ? Can you check what chipset  the motherboard is using ?
One other thing- rename your config.sys and autoexec.bat to *.old - Any drivers in there could be causing problems.

Remove all 3 devices from the device list. Also check the BIOS to make sure it is set for PNP mode.

In addition - try to check the performance tab under System properties- If everything is in DOS mode, then it may run you thru a wizard to get everything to 32 bit mode and solve your problem.
More information about details of the hardware/chipset etc, would be helpful.
I hope this helps !
0
 
sgentherCommented:
Try rerunning the hardware detection in control panel.After you go through that see if you can remove them...usualy you have to remove the standard dual controller to get the Primary and Secondary to be removed.
0
Cloud Class® Course: Python 3 Fundamentals

This course will teach participants about installing and configuring Python, syntax, importing, statements, types, strings, booleans, files, lists, tuples, comprehensions, functions, and classes.

 
AjninCommented:
Try removing all IDE controllers and let windows redetect them. Note system will lock after removing the one being used.
0
 
tonnybrandtCommented:
Check the Bios and see if secondary channel on the ide controller is enabled.
0
 
compmaniaCommented:
Try going to safe mode and remove them (hit f8 when it says "starting windows" and select safe mode)
0
 
TascanCommented:
Well to get the CD Rom up and running you have to put it as a slave
to a harddrive.. that should get it going again.
As for the multiple IDE devices.. as mentioned by AJ above
remove all of them and reboot.. usually the hard way..
turn off and count to 10 then turn on..
there actually should be three controllers showing up
there should be a Primary and Secondary under another named
IDE controller.. usually for the chipset that is controlling it all
Win 95 has a bit of a glitch that most IDE CD Rom's have
to be on a channel that is also used by a HD... which is very stupid
of them as that slows down both CD and HD..... meaning total system performance takes a hit.
0
 
rayt333Commented:
Check the following key in REGEDIT and see if there is a NOIDE entry listed there, if there is then remove the NOIDE entry from the following registry key:
HKEY_LOCAL_MACHINE\SYSTEM\CURRENTCONTROLSET\SERVICES\VXD\IOS
0
 
laroucheAuthor Commented:
Rayt333,

Thanks for the winning answer!  I had tried to find something in the MS Knowlege base...but obviously didn't have the right "key" words.

v/r
Chip
0
 
TascanCommented:
Isn't the knowledge base fun? heh.. keywords are never what you'd
expect them to be... oh well..
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.