Expiring Today—Celebrate National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

xterm: Text not visible!

Posted on 2000-03-08
5
Medium Priority
?
650 Views
Last Modified: 2013-12-15
I have installed Red Hat Linux 6.1 on my PC at work and my PC at home.

At work the text in Gnome Terminal is invisible: I just see a grey background  with the current position of the cursor a black rectangle and the command prompt and any text I type invisible.  

When running xterm I see a white background and the command prompt and cursor position one long black rectangle.

At home everything is normal.

If in order to answer this question, you need any particulars on my hardware, I'll be happy to supply them.
0
Comment
Question by:arieverburgh
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
5 Comments
 
LVL 3

Expert Comment

by:freesource
ID: 2599573
This sounds like a problem related to the way the Xresources are set-up for the two applications.

For xterm you could edit $HOME/.Xresources ($HOME =' ~/) and add a line to change the text color.

Like this:

XTerm*foreground: gold

Run this from the command line after you make the changes, and then run a new xterm:

xrdb -merge $HOME/.Xresources

You can find all the resources in "man xterm" and the same for the gnome terminal.  Maybe your display doesn't support all colors, in that case, just find one which works.

Tell me how it goes.
0
 
LVL 3

Expert Comment

by:freesource
ID: 2599584
And, yes, if this is a situation where you are not properly displaying certain colors, you might as well tell me which video card you are using, which X server, and the depth you are running at.
0
 
LVL 2

Expert Comment

by:Reinier
ID: 2600147
Are you by any chance using a graphics card with the SiS 6326 chipset, like the diamond speedstars? Go read the http://www.xfree86.org/XFree86/FAQ about them.
0
 
LVL 1

Accepted Solution

by:
raks04 earned 300 total points
ID: 2611462
your prob is with the graphics card.
so pal visit the SUSE linux website for the required drivers.But lets just say you dont have the patience for all this then your best option would be to run X-windows like this:
startx -- -bpp 24
this starts X at 24 bit depth and you will be able to see the characters in the xterm
0
 

Author Comment

by:arieverburgh
ID: 2619752
Yes, I have a SiS 6326 chipset in my graphics card, and have the required driver suggested on the SUSE website.

Both Reinier and raks04 provided good answers (although I haven't tested raks04's advice, as I have the required driver).  I visited the website suggested by Reinier and followed the FAQ's suggestion to add option "nolinear" to my xf86config file, and ,voila, it worked.  Amazing!
0

Featured Post

Congratulations! You’re Certified – Now What?

Starting a new career can be overwhelming. Becoming certified in your field of expertise is a great start, but where do you go from here?  Here are some tips to help you on your career journey.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The purpose of this article is to demonstrate how we can use conditional statements using Python.
Fine Tune your automatic Updates for Ubuntu / Debian
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.
Suggested Courses

719 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question