[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 7407
  • Last Modified:

Fatal disk error.


I have a problem on a nt 4.0 network,on the server is installed an
oracle database,the computers on
the net are all windows 98 and the problem is
this:sometimes,randomly,some pc (not the same pc)
loose the network connection ,on all the pc there is a map on a shared
disk on the server
where there is the application files (powerbuilder) of the application
that uses the oracle database,
during the work appear a messag saying "fatal disk error"  then click on
ok,the application end and
if I go in my computer I see a red X on the mapped drive,if I click on
the mapped drive with the red X
the connection is reestablished and I can continue to work (relaunch the
application and all is fine
for some time ).

Anyone has an idea about this problem .

Thanks

DAN
0
danilop
Asked:
danilop
  • 5
  • 5
  • 3
  • +3
1 Solution
 
andrewbrazierCommented:
Looks like a network problem. What sort of cabling do you use? What brand of NIC's are in the PC's and server? Are all the clients and the server on the same local LAN?
0
 
danilopAuthor Commented:
The cable is cat.5 utp ,with hubs 10/100 autosensing,most of the pc's have a nic at 100 Mbps ,the server has a 10/100 nic ,all the clients
and the server are on the same lan .
I see in the nt diagnostics ,network,statistics
some counter like Server disconnects but i have
no documentation about what exactly means.

0
 
andrewbrazierCommented:
Go into the LAN card settings on the clients and the server. Nail the speed to 100MBps (if a 100Mbit card) and nail the duplex to half. Autosensing sucks, fix it to the correct values and there is no chance of it autosensing wrongly and screwing things up.
What brand of network cards and hub do you have?
0
Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
Tim HolmanCommented:
It looks like the client end is not able to recognize disconnected drive mappings, or maybe it is, but doesn't give the system long enough to reconnect.
What sort of LAN have you got ?
Is it busy ?
Any routers in between client and server ?
0
 
danilopAuthor Commented:
No routers ,the lan is twisted pair (utp) cable cat.5
There is an HUB HP SUPERSTACK 3300 24 ports
100 Mbps and a switch (i don't know the brand
again ,i have to go to the customer to verify it)
with ten ports at 10 Mbps and two ports at
100 Mbps .
The NIC on the server is a compaq NETELLIGENT
10/100 ,for other information i have to wait
for a response of the customer.
The traffic on the lan isn't heavy.
0
 
XcesCommented:
I dont think that you problem be the network, I think that the problem is the disk that it revolutions sometimes is less than the normal, backup the information and check the disk, I think that because if the problem be the network you will have problem with another shared resources.
0
 
andrewbrazierCommented:
Disagree with Xces, danilop mentions seeing "server disconnects". That's the kind of thing I have seen when autosensing doesn't work and the client has to re-negotiate with the hub/switch causing temporary loss of connection.
0
 
FBONINCommented:
What Service Pack do you have on your server ?
SP6a is said to improve numerous files sharing (the case of PBuilder apps)

How do you map you drive on your Win 98 station?
Do you use a script, or through the Explorer -ie permanent share ?
Check you CONFIG.SYS file for the LASTDRIVE= Statment. Remove it or use for your share a drive letter inferior to the one mentioned in it.

If your PowerBuilder application is rather big, does not change very often,  and the network load balance is critical issue, try considering moving the sources localy.
You just send a Bat file to copy the new sources form that share anytime required.

As for the Lan state, I also encountered very bad performances when I tried 100Full duplex on my Compaq Server connected to a HP Switch.
Came back after I forced the setting to 100 Half Duplex on both (X2 global perf inc...)


0
 
ganishaputraCommented:
In almost all of these cases, the user is compiling on their A drive and running out of space. Or maybe your network "full".
0
 
andrewbrazierCommented:
Still think speed/duplex needs sorting. If the hub/switch the various devices connect to are intelligent and will allow it nail their speed and duplex as well. FBONIN's comment about poor performance when connecting a server to a switch is exactly this problem, autosensing does a poor job so one end runs at 100/half and the other at 100/full and both ends constantly throw errors, re-negotiate, get it wrong again, more errors and so on. The ONLY answer is nail the intelligent end to the speed/duplex of the dumb end OR if both ends can be nailed, nail to 100/full.
0
 
danilopAuthor Commented:
I don't understand your answer ,can you explain me better? What means "the user is compiling on their A drive and running out of space. Or maybe your network "full"." ?
0
 
andrewbrazierCommented:
I keep saying it, speed & duplex need checking and nailing. The "Fatal Disk Error" is probably a red herring, it's using the only error message it knows as it probably doesn't have one to suit the circumstances.
0
 
danilopAuthor Commented:
The LASTDRIVE statement is not used in CONFIG.SYS, and the mapping is
done through the Explorer , with a  permanent share .
I have again to investigate in the type of connections with the NIC (speed
nail to 100/full ..... ) ,i have to wait for a response of the customer about
the brand of the PC's NICS and on the type of speed,if autosensing ,if not,
which of them are fix to 100 ....
0
 
FBONINCommented:
In my case, the PC's are not directly connected to the same Switch : only the servers are (back bone equipment).
The PC's (400+) are of very different brands and use networks parameters set to 10/Auto, resulting in actual negociated speed of 10/HD.
On HP Switch, though I tried to set my server's port to 100/full, matching the Compaq's ethernet card setting, the performance did not improve.
We had to set both to 100/half before it came to a reasonable level of performance (same as the other servers).

Maybe this can help you.
You should also, if not already done,  verify that you use the last Compaq NIC driver..., and that your cables are not dammaged...
I know it may sound stupid but many networks issues I encountered in my company came from defected cables or slots.

P.S.: I'm french so don't be too regarding for my english.
0
 
danilopAuthor Commented:
Sorry for the delay to accept the response,but
i have had to go to the customer to verify the lan,
to make the change to 100 MB fix ,without autosensing and to verify that all was ok.
Now it's working and seems that the problem went away.

Thanks again.

DAN
0
 
FBONINCommented:
Glad you eventually had your problem fixed!

Sincerly
0

Featured Post

The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

  • 5
  • 5
  • 3
  • +3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now