• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 188
  • Last Modified:

Displaying image on the top left without border

I'm trying to make my image flush to the top-left of the screen with no white space around it.  It looks great in Frontpage but when previewed in a browser I get a thin white space on the top of the image and going down the left side.  I tried putting it in a table and turning the cell-padding to zero but that did not seem to work.
0
snocross
Asked:
snocross
  • 3
  • 2
  • 2
  • +3
1 Solution
 
TTomCommented:
Have you tried putting the image at the top of your page and adding:

<body topmargin=0 leftmargin=0>

You may also need some other variation to deal with NS, but this might work for IE.

Tom
0
 
fibdevCommented:
Tom's suggestion will solve the problem in msie, but netscape does not support 0 margins :(  I very badly wish that it did.  You could also use absolute positioning, but only newer versions of netscape will support it, and not very well from a stability point of view I might add.

<span style="position: absolute; left: 0; top: 0"><img border="0" src="images/myimage.gif" width="100" height="50"></span>

It's worth a shot.
0
 
snocrossAuthor Commented:
I did have my topmargin and leftmargin set to zero and it does work in IE but not Netscape
0
Cloud Class® Course: CompTIA Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

 
READERCommented:
I think your problem has to do with "Browser Offset".

If so you will find an explanation and some solutions to this problem  at the following address

http://www.dsiegel.com/tips/wonk14/
0
 
bark10Commented:
for netscape use "marginheight="0"" and "marginwidth="0"" along with topmargin and leftmargin in the body tag.  this may not help your problem but if you frequently set the top and left margins for ie it is good practice to use these two also.
0
 
ProWebSitesCommented:
  Put this in you body tag:
<BODY topmargin="0" leftmargin="0" marginheight="0" marginwidth="0">

   This should work in any browser that happens by your site.

  This has already been answered in this thread, but in code, like above.

Warmest Regards,
Steven Fredette
President ProWebSites.net
Indianapolis, Indiana. USA http://www.prowebsites.net
Site includes: FrontPage help, and links to other FrontPage help sites.
For the rest of this sig. file http://www.prowebsites.net/sig.htm
0
 
bark10Commented:
Steven

If you admit that these answers have already been given by others, then why resubmit them as yours for points?
0
 
ProWebSitesCommented:
  So I don't receive the points is why. The reason I even answered is it wasn't in code form, and thought the person asking the question might not understand the other folks that answered, but didn't spell it out in coding for both IE and NN.

Warmest Regards,
Steven Fredette
President ProWebSites.net
Indianapolis, Indiana. USA http://www.prowebsites.net 
Site includes: FrontPage help, and links to other FrontPage help sites.
For the rest of this sig. file http://www.prowebsites.net/sig.htm 
 
0
 
snocrossAuthor Commented:
Thanks for trying to help but It's only fair I give the points to bark10...
0
 
snocrossAuthor Commented:
This worked, thank you.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

  • 3
  • 2
  • 2
  • +3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now