Solved

Install program tar.gz (or something)

Posted on 2000-03-11
22
386 Views
Last Modified: 2013-12-15
I recently downloaded Acrobat 4.0 for Linux to my new Linux machine, and I got something like root/linux-ar-40.tar.gz   And i don't know what to do with it(or where it is).  Remember that Caldera 2.3 comes with the KDE interface for us Windows dependents, and I can run Konsole and not much else.
0
Comment
Question by:richardwilkins
22 Comments
 
LVL 40

Expert Comment

by:jlevie
ID: 2608864
You've accidentally managed to get two copies of your question enterd. I suggest that you request to have the duplicate deleted.

Who were you logged in as when you did the download and what did you use (netscape?). The downloaded file is probably in the home dir of what ever user did the download. From the "root/linux-ar-40.tar.gz", I'd suspect that root did the down load and it is likely in the /root dir.

The permissions on root's home dir are such that you have to be root to see its contents. In this case that's okay because you need to be root to extract the data and install Acrobat. So to find where the file is, first login as root or su to become root. Then look in /root for the file (ls /root). If it not there we'll have to locate it with the Unix find command.

The Unix find command will recursively examine files and directories and can be used to locate a specific file anywhere on the entire system or located within a spcific directory tree. In this case we want to do "find / -name linux-ar-40.tar.gz". That will start the search at the root of the file systems and examine everything. Eventually it will emit a line containing the location of the file, perhaps something like "/dir1/dir2/linux-ar-40.tar.gz".

Once the file has been located we want to move it to root's home dir to have a place to unpack it. So you'd do "mv /dir1/dir2/linux-ar-40.tar.gz /root" and cd to /root (cd /root).

Now that the downloand in in root's home dir and we're in that dir, the first step in the install is to unpack the compressed tar archive. The command to use is "tar xvzof linux-ar-40.tar.gz". This will create a new directory that contains the installation data. I don't rmember what the driectory name is offhand, but it should be obvious. Cd to that directory and you'll find a file that when executed will do the install. The name as I recall is INSTALL and you do the install by typing "./INSTALL" (note that's period slash INSTALL) and then follow the instructions.

you can find out more about the commands that I've mentioned (find and tar) from their man pages, try "man tar" for an example of what's there. Most all of the Unix commands have their own man page.
0
 
LVL 1

Author Comment

by:richardwilkins
ID: 2610492
Well, thanks.  I must have been having an adult beverage when I posted twice, but no matter.  The other question resulted in a similar comment, but I notice one inconsistency.  He suggested the command xvzf to unzip the file, and yours was xvzof.  Typo?  Anyway, tomorrow I'll try these things, particularly the man command.  Must be like help in old MSDOS.  I'll bet it is not as arcane as it first appears -- that is, cd and mv seem obvious.  But tar xvzof?  And will the man display the switches? Symantics are very important.  My efforts seem recursive, maybe algorithmic.
0
 
LVL 40

Expert Comment

by:jlevie
ID: 2610519
Nope, not a typo. Let me take the options apart...

x - extract from tar archive (data extracted always goes into the current dir)

v - be verbose and show what's being done

z - use gzip to decompress the archive on the fly

o - make the current user the owner of all data extracted. Otherwise they'll be owned by whoever made the archive (ownership/group is preserved by default)

f - use the next argument as the file name and/or device to operate on, in this case the downloaded file

Using the "o" option is, in almost every case, a good thing to do. If root happens to create a tar archive and the permissions on the files in it are rw-------, you, as an ordinary user, wouldn't be able to read or delete the data. On a system where you don't have root privs this can be annoying...

And yes, the man pages show the options as well as the syntax. I think you'll find that there's a lot more information in the man pages than you'd see in DOS help. You have to remember that until only recently the Unix man pages were pretty much the only documentation for Unix, and as such they have to be pretty darned complete.
0
 
LVL 3

Expert Comment

by:alien_life_form
ID: 2611828
Greetings:

as a small aside check on the xman (GUI oriented) and info (Konsole oriented) help systems, that may take some of the pain off the man experience.

Cheers,
    alf
0
 
LVL 1

Expert Comment

by:KURGAN
ID: 2614110
Well, I suggest to do this:

With user root:
1)copy the tar.gz file into /usr/local/src (directory normaly used to compile user's programs which is not incuded by default system)
2)execute: gunzip linux-ar-40.tar.gz
3)execute: tar tvf linux-ar-40.tar
 in order to see if when you're going to untar this file, it creates its own directories or not. If it doiesnt, you mast to create it.
4)execute tar xvf linux-ar-40.tar
5)cd into the directory recently created.
6)normally it works with threes steps:
../configure
../make
../make_instal
anyway I suggest you to read the README file.
0
 
LVL 1

Expert Comment

by:toneus
ID: 2614930
tar -xvzf "file.gz" would do the trick to unzip and untar your zipped tar-file in ONE command (as root of course).

Then look for the documentation how to install the stuff.

And indeed follow up KURGAN's advise to first copy this file to /usr/local src, and then do the tar-command!

Hope it helps!
0
 
LVL 1

Author Comment

by:richardwilkins
ID: 2618030
Now I am struggling with copy and move.  I have unzipped the file into several files and read the instguid.txt.  Please see the other posting for more details.  I have created under /opt an Acrobat directory.  I need to move the files there and run install.  Let me try it before my dial up connection goes down.  I'm not ready to quit tonite, as business has been slow and I'm on the learning curve.
0
 
LVL 40

Expert Comment

by:jlevie
ID: 2618074
You don't need to move the files at all. Once they were unpacked you've got a directory containing:

ILINXR.TAR
INSTALL
INSTGUID.TXT
LICREAD.TXT
READ.TAR

Simply cd to that directory and type "./INSTALL". That'll run the install script, which will ask some questions (that you agree to the license & where to install (I use /opt/Acrobat4)). When the install finishes it'll make the /opt/Acrobat4 dir and populate it with the acrobat reader application.

To run acrobat reader, type "/opt/Acrobat4/bin/acroread some-file.pdf". I create an alias in my .bashrc file like:

acroread=/opt/Acrobat4/bin/acroread

so that I can just type "acroread some-file.pdf"
0
 
LVL 1

Author Comment

by:richardwilkins
ID: 2618163
Tried that and (before Netscape crashed) the command ./INSTALL (why so case sensitive?) merely ran the license agreement, nothing more.
What's up?
0
 
LVL 40

Expert Comment

by:jlevie
ID: 2618205
Unix is case sensitive... When you say the first page of the license agreement did you try hitting the space bar to "page" through it. Eventually it'll get to a point that says "Please type "accept" to accept the terms and conditions license agreement; Type "decline" to exit." Type accept at that point and hit return. I think te rest will be obvious.
0
 
LVL 1

Author Comment

by:richardwilkins
ID: 2618217
No.  The license agreement appears, and at the bottom of the page, it says 'your installation of the program indicates your acceptance.

Incdentally, I am off the SE Proxy Server and on the Linux server.  Hooray for little things.
0
Top 6 Sources for Identifying Threat Actor TTPs

Understanding your enemy is essential. These six sources will help you identify the most popular threat actor tactics, techniques, and procedures (TTPs).

 
LVL 40

Expert Comment

by:jlevie
ID: 2618259
Yeah, and you need to hit the space bar to get to the place you can type in "accept".
0
 
LVL 1

Author Comment

by:richardwilkins
ID: 2625631
As noted in the other posting (damn, I should have taken your advice to delete one of them), I navigate to the /root/ILINXR.install directory, run ls -f --color and note that INSTALL is an executable.  ./install INSTALL continues to run the License Agreement, but paging to the bottom finds that : "YOUR ACCEPTANCE OF THE FOREGOING AGREEMENT WAS INDICATED DURING INSTALLATION".  Could I have installed it someplace?  It's not in /opt/acrobat which I created, and find -name, etc., worked to find the downloaded file (not find / -name . . .  as suggested above).  So, find -name acrobat or something like that ought to find out if I installed it someplace, but the Konsole locks up if you mistype a command, and restart it  --  well, that's not a big deal, but why can't you continue to type commands, changing arguments?  This is true with the KDE Konsole, the Linux Console and the Root Console.  After I lock up all three, I have to restart Konsole.

I'm not about to give up because we are using this puppy as our Proxy Server now, and I need to learn how to install a program, because, ultimately I am going to install pcAnywhere on it, the goal being to allow remote control of our Novell/NT network thru the Linux Proxy Server.
0
 
LVL 40

Expert Comment

by:jlevie
ID: 2625704
I don't understand about Kconsole locking up. Could you be hitting ctrl-s, that stops it from scrolling and is released with ctrl-q. The other possibility I can think of is hitting ctrl-z, which in Unix means to suspend the current process (ctrl-c means abort the current process).

Okay, I'm downloading the acrobat reader tar file right now. Got it and since I was logged in as an ordinary user (the preferred way to use a Linux box... don't routinely log in as root, it's too dangerous if you make a mistake) it downloaded to "/nfs0/levie/linux-ar-405.tar.gz". Here's a copy of what I did:

levie> su
Password:
root> cd /root
/root
root> tar xzof ~levie/linux-ar-405.tar.gz
root> ls
Desktop/  ILINXR.install/  autosave/  capture
root> cd ILINXR.install/
/root/ILINXR.install
root> ls
ILINXR.TAR  INSTALL*  INSTGUID.TXT  LICREAD.TXT  READ.TAR  ReadMe
root> ./INSTALL

I kept hitting the space bar as it presented the license agreement and finally wound up at the end where it said, "YOUR ACCEPTANCE OF THE FOREGOING AGREEMENT WAS INDICATED DURING INSTALLATION.". Hitting the space bar one more time put:

"To accept the terms and conditions of this agreement enter "accept".
To decline the terms and conditions of this agreement enter "decline".

Please type "accept" to accept the terms and conditions license agreement; Type "decline" to exit. "

 on the screen and I type "accept" and hit return. It then says:

"This installation requires 16MB of free disk space.

Enter installation directory for Acrobat 4.0 [/usr/local/Acrobat4] "

Obviously you aren't getting this far. All that I can think of is that you aren't using the space bar to get to the first question.
0
 
LVL 1

Author Comment

by:richardwilkins
ID: 2625855
Locking up of the Konsole is a relative thing.  It simply doesn't give me another command prompt, which is in this case [root@noname /root]#   For example, after the license agreement appears, that is all.  No further prompt.  Not the case in ls, etc.

I have successfully moved the directory ILINXR.install to /opt/Acrobat.  Finding no files there, I moved the several files (I didn't get a ReadMe) back into the Acrobat directory.  With the INSTALL* file therein, I run  ./INSTALL, and the license agreement appears.  Space bar, page down, arrows down, and then hitting the space bar does nothing, and no command prompt appears.  I'll logout as root, and run su, to see if I can duplicate the problem.  Stay tuned...
0
 
LVL 1

Author Comment

by:richardwilkins
ID: 2625903
Sorry:  Logout out as root, in as richard.  Then run the Konsole, and type su and root's password, and get [richard@noname richard]#
Then cd to /opt/Acrobat   ...   run ./INSTALL (in caps) and the license agreement appears.  Space to the bottom, and NOTHING.  I'm learning to use the Caps Lock key.  

And further, everything you say above I've seen, except the  tar xzof ~levie/linux-ar-405.tar.gz
That is, I ran from the root directory, tar -xzof /root/linux-ar-40.tar.gz.  I expect the ~levie tells it to run from the desktop of ~levie, and the version is now 4.05.  Maybe I should download the new version and try again.  

I'm going to have to quit now, and pursue another job, but thanks again for your persistence.  You (and I) can look thru this post and see how far I've come.  Unfortunately, Symantec does not indicate that a Linux version exists.  But that's another project.  Tomorrow!!!
0
 
LVL 40

Accepted Solution

by:
jlevie earned 100 total points
ID: 2626248
The stuff about ~levie is just there because I downloaded as an ordinary user. It isn't exactly relevant to your case, but since I was pasting output from a terminal window into the comment I felt I had to mention it.

If I understand correctly, after paging through the license, when you hit the space bar after the page with "YOUR ACCEPTANCE" nothing else happened. It's just a guess at this point, but try a q there and see if you move to the question. I don't have a Corel around here to test with, but the pager may be configured to require a q rather than a space to terminate after the last page.
0
 
LVL 1

Author Comment

by:richardwilkins
ID: 2626289
Had to leave it at the office, but I'll try a "q" in the morning.  10-4  or as we said during the war, Roger, Willco, Over and Out.
0
 
LVL 40

Expert Comment

by:jlevie
ID: 2626451
Or as we used say on recon opns, "Waiting for words..."
0
 
LVL 1

Author Comment

by:richardwilkins
ID: 2629832
Progress!! the q worked.  I typed accept and the program was installed to /usr/local/Acrobat4.
cd to that directory revealed Reader, bin, Browsers and Resource, all executables.  cd to Reader, and there are 3 exe files, intellinux, help, and res.  3 .pdf files  and a ReadMe and AcroVersion.

Knowing this much was dangerous.  Back in the KDE Disk Navigator, I clicked on one .pdf file, and got Acrobat 3.0, while another brought up 4.0.  

Then, wondering if the "q" command would work again, I went to /root/opt/Acrobat, ran ./INSTALL, then the 'q', etc., and reinstalled.  Same result, that is, having 3.0 and 4.0.

I'm going to shut this one down, with thanks, and go on to another question.  Come back!
0
 
LVL 1

Author Comment

by:richardwilkins
ID: 2629838
See the above.  The 'q' command worked.  Some ought to tell Caldera.
0
 
LVL 40

Expert Comment

by:jlevie
ID: 2629972
Okay the reason you get two different versions of acrobat is that are both installed on the system. That in and of itself isn't a problem, but you have to tell KDE that you want to use the 4.0 version when you "click" on a file. Since I never use GUI's, and don't have a copy of Corel ariund, I can't say for sure, but I believe it'll be controlled by the mime type in "Disk Navigator". I know that I did see it in the KDE docs... take a look and if you can't figure it out, let me know and I'll look it up.

The behaviour of the pager can be probably be changed pretty easily. Take a look at the man page for more .
0

Featured Post

Highfive Gives IT Their Time Back

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

Suggested Solutions

Setting up Secure Ubuntu server on VMware 1.      Insert the Ubuntu Server distribution CD or attach the ISO of the CD which is in the “Datastore”. Note that it is important to install the x64 edition on servers, not the X86 editions. 2.      Power on th…
The purpose of this article is to demonstrate how we can use conditional statements using Python.
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now