• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 213
  • Last Modified:

Getting online through dial up networking in linux

Okay, I was able to dial up under gnome interface and the pppd program but once connected could not visit any webpages through netscape. Is there something I can do or forgot to do so I can "surf the web?" Or am I not really connected to the internet at all?
If you could email me and help me out I would appreciate it. Thanks
1 Solution
If the connection was actually made, and you'd have to look at "ifconfig -a" to see if there was a ppp instance, you may not have gotten a proper default route or name service information set up.

You can check for a default route with "netstat -rn". there should be an entry with a destination of and a device of ppp0. A quick check for name servers is to look at /etc/resolv.conf, it should exist and contain a "nameserver n.n.n.n" entry with "n.n.n.n" being one of your ISP's nameservers.
Did you fill in your proxy-settings under netscape?

If you have a connection, you still need to tell netscape what the IP-addresses of your internet-servers are.
Your ISP can give you this. Also you can setup netscape with an auto-proxie script (also given by your ISP).

Go look under edit, preferences, proxies.

Hope it helps!
I would guess that /etc/resolv.conf does not contain the IP's of your ISP DNS servers.

like this

search mupp.net

you will have to replace the "mupp.net" with the domain of your ISP. and the nameserver IP's with the numbers of your ISP DNS.

A proven path to a career in data science

At Springboard, we know how to get you a job in data science. With Springboard’s Data Science Career Track, you’ll master data science  with a curriculum built by industry experts. You’ll work on real projects, and get 1-on-1 mentorship from a data scientist.

wizrd79Author Commented:
Thanks, I figured it out right after I posted this but thanks for your help. I forgot that windows automattically detects DNS and linux does not. Thanks again for your help. Wizrd
Actually linux does that too... if you tell PPPD to modify the file for you. Cant remember the option tho.
wizrd79Author Commented:
J2, Oh okay, I didn't know that. Thanks I will look into that.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Build your data science skills into a career

Are you ready to take your data science career to the next step, or break into data science? With Springboard’s Data Science Career Track, you’ll master data science topics, have personalized career guidance, weekly calls with a data science expert, and a job guarantee.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now