Failed to read Registry

Posted on 2000-03-13
Last Modified: 2013-12-29
Since I reinstalled my computer with Windows ’98 (German version), my system often brings the following error message  “Konnte nicht auf Systemregistrierung zugreifen”, what means as much as “couldn’t read registry”, after booting. Every time that happens the system settings are set back to default after reboot.  

I’ve tried to exchange the CPU and hdd and reinstalled the system, but that didn’t work.

Could there be a compatibilityproblem with my hardware?

Here’s what I’ve got:

Intel Pentium !!! 550MHz
Asus P3B-f
Matrox Millennium  G400, DH, MAX
SB-Live Platinum with Live Drive II
Fast Trak DIE RAID Controller
2 x IBM Desktstar GXP 13,6 GB (on RAID)
1 x Maxtor Diamondmax 8,4 GB (contains OS)

the country and language settings are correct. The country is Switzerland & the language is German (Swiss).  I’ve previously installed win98 from the same cd wihtout any problems.
The problems began after I made a dual boot with win98 and win 2000, but I’ve deleted win2000, repartitioned all my harddisks and formatted them. Now I’m only running win98, but the problems still there.


Question by:cyrot
  • 4
  • 2
  • 2
  • +2
LVL 12

Expert Comment

by:Patricia Siu-Lai Ho
ID: 2615222
cyrot, At the initial stage of installation of Win98 (German version), you have to choose your country as Germany other than selecting your real local state/country (USA or other countries that you're actually resided).
Otherwise, you will have a language problem in the Win98 core. There is no way to adjust within Win98 except for a clean reinstallation to change the country during the process of installation.

Let me know if it worked.  pslh

Author Comment

ID: 2615292
Edited text of question.

Expert Comment

ID: 2615314
Boot 98 dos mode and do FDISK /MBR
that will resore the boot record

also if you got the system to boot the
first time... try this:

Boot dos mode
cd windows
attrib *.dat -r -s -h
xcopy *.dat c:\sysold\
del system.dat
attrib *.1st -r -s -h
copy system.1st c:\windows

also there backups of the registry
in c:\windows\sysbkup\rb???.cab
and you can see what ones worked
by typeing scanreg at dos command promt.

also try booting safe mode and running
SFC and check for corrupted files, especially if this is a CLEAN install and you have no other programs loaded.
(note: you have to goto the settings tab and check the boxes for changed and deleted files, also the advanced tab and INCLUDE ALL directories (set to yes)) ... I've had the vmm.vxd file get corrupted on install before...
possible bad/compatible ram/cahce timeing issues...

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.


Expert Comment

ID: 2615373
opps BUG in last line of command:

copy ssytem.1st c:\windows
copy system.1st c:\windows\system.dat

then reboot...

Expert Comment

ID: 2615460
Coming at this from a different angle, I once had this same error occurring everytime Windows started up which turned out to be (to my surprise) a bad memory module...

Author Comment

ID: 2615569
where can i get a test-prg to check my memory modules?

Expert Comment

ID: 2615757
Registry errors at boot are often due to memory problems,as msledd stated.

I assume with 512MB of RAM that you have multiple modules.Try pulling all but one,see if the errors stop.Don't forget to swap the one remaining module if they don't.
Your errors may disappear after simply pulling/re-inserting the modules: 168-pin sockets that are'nt properly supported underneath may 'bow' in the center when you insert the module or nearby disk cables.Look closely along the length of the module at the pin-socket connection; make sure it's straight and even.

A surprisingly good memory test is built into Win9X: Himem will run a short test if you start in Safe mode.I've seen it find bad memory when high-end diagnostic programs reported no errors.

Author Comment

ID: 2617444
himem didn't find any bad memory. i've tried switching modules but the thing is, the error message doesn't appear every time. any other ideas?

Expert Comment

ID: 2619483
Like they say: if it ain't broke,you can't fix it.Intermittant problems such as yours are always a pain to track down.You'll have to establish an approximate failure frequency so that you know about how long to wait after making a change before declaring it 'gotten'.

-By 'switching modules' do you mean completely removing one and leaving it out until you get a failure?

-What system settings get set back to default?

-Are you overclocking the processor?


Author Comment

ID: 2619686
- by 'switching modules' i mean removing the module; replaceing it by a new one; changing slots.

- the display settings are set back, the configuration in my soundblaster software(lava, playcenter, etc...) and some settings ofgames.

- i'm not overclocking the cpu.

Accepted Solution

msledd earned 100 total points
ID: 2621254
Hi cyrot,

Sorry it took me so long to get back to you. The method I used to detect my memory problems was a combination from the MSKB, I went back and found the articles I had read... rather than posting the text here, I'll give you the URLS:

*another note* In between trying different methods to correct this error, you may need to *use* your computer without the hinderance of the error message, since you know that your registry is not really corrupted there are two things you can do: {note: these things do not FIX the problem, but may make life a bit easier until a fix is found}

    1. You can CTRL+ALT+DEL and "end task" the error message that pops up claiming you must restart to restore the registry to continue working in Windows.

    2. Disable scanregw completely from running automatically at Windows startup. Go to START>RUN typing "MSCONFIG" then uncheck ScanRegistry from the Startup tab. However, this will prevent Windows from making daily backups of your registry which can be used to restore in the event of *another* "real" registry problem. You can manually make backups by typing "SCANREGW /BACKUP" at the START>RUN command however.

Good luck!

Featured Post

Is Your AD Toolbox Looking More Like a Toybox?

Managing Active Directory can get complicated.  Often, the native tools for managing AD are just not up to the task.  The largest Active Directory installations in the world have relied on one tool to manage their day-to-day administration tasks: Hyena. Start your trial today.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Our Group Policy work started with Small Business Server in 2000. Microsoft gave us an excellent OU and GPO model in subsequent SBS editions that utilized WMI filters, OU linking, and VBS scripts. These are some of experiences plus our spending a lo…
NTFS file system has been developed by Microsoft that is widely used by Windows NT operating system and its advanced versions. It is the mostly used over FAT file system as it provides superior features like reliability, security, storage, efficienc…
The Task Scheduler is a powerful tool that is built into Windows. It allows you to schedule tasks (actions) on a recurring basis, such as hourly, daily, weekly, monthly, at log on, at startup, on idle, etc. This video Micro Tutorial is a brief intro…
Windows 10 is mostly good. However the one thing that annoys me is how many clicks you have to do to dial a VPN connection. You have to go to settings from the start menu, (2 clicks), Network and Internet (1 click), Click VPN (another click) then fi…

821 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question