chmod

i try chmod -R a+w *.* .* *
to allow all users to wirte to all dirs below the current one
but it says that it cant access *.*

i just want it to enable access to all users to be able to create
files and dirs in all dirs below this one

can anyone help?
boofullsAsked:
Who is Participating?
 
GP1628Connect With a Mentor Commented:
I would do

chmod -R a+w *
chmod -R a+w .???*

I find that * usually covers *.*

The .???* makes sure you wont have the problems caused by .* being equal to . and ..

If these are home directorys for users on the system then look at what settings you have for all the files in /etc/skel so that you dont have to keep doing this.

0
 
tfewsterCommented:
       
Be careful with this one -  chmod -R a+w .* expands to include ..
i.e. it goes up a level before recursing down =8-O
                     
I don't know about *.*
                     
For what you want to do, find . -exec chmod a+w {} \; would be safer, but even this will follow links in the subdirectories and change the permissions on what the link points to.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.