Help with Linksys Ether16 Lan card

Im trying to get my Linksys Ether16 ISA non-PnP Lan card working under Mandrake 7.0. Apparently, when I boot up, linux does not detect the card. I have recompiled the kernel with the ne2000 driver suggested by the linksys web site. Anyone else have any success with this card? Im too lazy to buy a pci card.
shawzAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
GregCConnect With a Mentor Commented:
I also had some trouble with the same network card on my Mandrake 6.0 system.

In terminal window type, "cat /proc/interrupts" then type
"cat /proc/ioports".  Read the outputs and look for conflicts with resources. Is the eth0 card sharing an IRQ or base address with any other device?  If so,
check for an IRQ that is unused, I'm using IRQ = 5 and address 0x260.

If this is the problem, then continue with next paragraph, if you don't see anything wrong here...post the results of the two "cat"s.

In terminal window type "linuxconf"  
(I think you may have a shortcut on the desktop in 7.0, DraxConf? or something like that)
Once in select "Networking", "Basic Host Information", Adapter 1 tab.  Here you can change the module you want to use "ne" = NE2000 i think.  And you can change your IRQ assignments and base address.  

Do you know the remaing information?  IP address, netmask, host name, domain?
If not check with your network administrator.  Anyway, you can check out your eth0 card by typing "ifconfig" in a terminal window.  Does your eth0 settings show up on the last line?  If not, you may need to stop the ne2k module and then restart.  Type "modprobe -h" for more info on modules.

Hope this helps!
Greg

0
 
jlevieCommented:
What IRQ/IOport do you have set on the card? It has to one that's free and you might also need to the the bios to reserve that IRQ for ISA use.
0
 
GregCCommented:
oops,
I forgot something
"jlevie" is correct, you should check to see how the LinkSys card is currently configured.  You may need to force new settings.  Do you have the utility diskette that came with the card?

And as "jlevie" said, make sure you check your bios settings to enable that IRQ for ISA cards.

Thanks
0
 
shawzAuthor Commented:
Thanks for the tips, both of you.  Ill give linuxconf a try.  The card is on irq 9 port 0x300.  It has no trouble in windows98 if that has any relevance.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.