Solved

linux and win98 - can't ping

Posted on 2000-03-15
8
317 Views
Last Modified: 2010-03-18
2 machines Redhat 6.1 and win 98
192.168.1.1/255.255.255.0 and 192.168.1.2/255.255.255.0
When attempting to ping linux to win98 get 'destination host unreachable' and win98 to linux 'request timed out'
eth0 is a 3c509, Linux also has modem and ppp interface which is working.
Linux machine dual boots with win98 and then both machines can ping each other, so not a physical problem.
What am I missing?

/etc/sysconfig/network:

NETWORKING=yes
FORWARD_IPV4=no
HOSTNAME="localhost.localdomain"
GATEWAY=
GATEWAYDEV=


/etc/sysconfig/network-scripts/ifcfg-eth0:

DEVICE="eth0"
USERCTL=no
ONBOOT="yes"
BOOTPROTO="none"
BROADCAST=192.168.1.255
NETWORK=192.168.1.0
NETMASK="255.255.255.0"
IPADDR="192.168.1.1"
IPXNETNUM_802_2=""
IPXPRIMARY_802_2="no"
IPXACTIVE_802_2="no"
IPXNETNUM_802_3=""
IPXPRIMARY_802_3="no"
IPXACTIVE_802_3="no"
IPXNETNUM_ETHERII=""
IPXPRIMARY_ETHERII="no"
IPXACTIVE_ETHERII="no"
IPXNETNUM_SNAP=""
IPXPRIMARY_SNAP="no"
IPXACTIVE_SNAP="no"


netstat -r:

Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
192.168.1.1     *               255.255.255.255 UH        0 0          0 eth0
192.168.1.0     *               255.255.255.0   U         0 0          0 eth0
127.0.0.0       *               255.0.0.0       U         0 0          0 lo


ifconfig eth0:
eth0      Link encap:Ethernet  HWaddr 00:A0:24:F0:4F:5B  
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:9 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          Interrupt:10 Base address:0x300
0
Comment
Question by:joegass
  • 4
  • 3
8 Comments
 

Expert Comment

by:suguinha
ID: 2621435
I'd say your NIC isn't properly set up. :-)
0
 
LVL 40

Accepted Solution

by:
jlevie earned 110 total points
ID: 2621613
I'll bet that you've got a 3c509b and the card is in PnP mode. Either that or it's set to an IRQ that conflicts with some other device.

To fix it you need to use the 3c5x9cfg utilitiy that came with the card. Boot from a DOS or windows diskette, change floppies and run 3c5x9cfg. Manually turn PnP mode off (if it's a3c905b) and then let it "Auto Configure" and save the config to the card. If you don't have the 3Com utility, I can chase down the page on their site that you can ndownload it from.

You may also still have problems if the Bios has PnP mode enabled. You don't want it for Linux, and it won't cause any harm in windows if it's off. Unually, configuring the card with a fixed IRQ & IOport and tunrning off PnP in the bios is sufficient to get the card to work under Linux. Sometimes it's also necessary to set the PCI config in the bios to reserve the 509's IRQ for ISA use only.
0
 
LVL 2

Author Comment

by:joegass
ID: 2622549
Adjusted points from 100 to 110
0
 
LVL 2

Author Comment

by:joegass
ID: 2622550
Thanks
Would I use this 3c5x9cfg to set it to irq 10 and base address 0x300, as linux states in ifconfig eth0?
PNP bios is disabled on the system board, though I haven't reserved an IRQ for this device (it's ISA, is that relevant?)
0
Control application downtime with dependency maps

Visualize the interdependencies between application components better with Applications Manager's automated application discovery and dependency mapping feature. Resolve performance issues faster by quickly isolating problematic components.

 
LVL 2

Author Comment

by:joegass
ID: 2622687
Thats done it!!!
I ran the 3c util but it still didn't connect, I then reserved irq 10 for legacy ISA in the bios and it worked.
I'm not sure if it was just the irq reservation or a combination of the two, but who cares.
Thanks a lot
0
 
LVL 40

Expert Comment

by:jlevie
ID: 2623324
It sounds like the card was already at IRQ 10, which is a good place for it to be. However, the PCI allocator in the bios didn't know the card was there and was assigning IRQ 10 to a PCI card. When you reserved 10 for ISA, that kept the allocator from from being able to use it. And Volia, no interrupt conflict.

0
 
LVL 2

Author Comment

by:joegass
ID: 2623964
Your right.
Win98 didn't like the cards pnp being disabled (or rather I couldn't get it to work...) so I re-enabled it but kept the reserved IRQ and now both win98 and linux are running fine on the same machine.
Once again thanks for your help
0
 
LVL 40

Expert Comment

by:jlevie
ID: 2624201
It's not difficult to get win95/98 to work with a fixed config on the card. Doing so eliminates the possibility that PnP will decide that card is suddenly at some other IRQ, will break networking in Linux.

To tell windows about the fixed config go to:

Control Panel
  System
    Network Adapters
      3c509 device
        Resources

Change the "Use Automatic Settings" to no and select the IRQ/IOport combo that matches the card's setting.
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
Internet Business Fax to Email Made Easy - With eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…
Internet Business Fax to Email Made Easy - With  eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, f…

911 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

21 Experts available now in Live!

Get 1:1 Help Now