termcap VT220

i've got a copy of QVT/Term and every time i press Delete, a funny symbol comes up.  I've tried to match the keyboard keys to their equivalent counterparts in the VT220 specification but with only little success.  

Can anyone guide me how to do the mapping?
crestAsked:
Who is Participating?
 
jacquesc030600Connect With a Mentor Commented:
Would you try in you .profile

stty erase "^?"
stty intr "^U"
stty kill "^x"

0
 
toToCommented:
try this on command line :
stty intr [Del] [Return]

where [Del] and [Return] ares single keys

if it works put that in your .profile
0
 
toToCommented:
oops

that was to intrupt a program
if you just want to erase a char :

 stty erase [Del] [Return]
0
 
lawvdCommented:
Note that
stty erase [Del]
will set you up to delete the character
to the left of the cursor, usually
more expected of [Backspace] or ^H.
Don't know if stty has an option to set
a key to delete at the current position,
the way a word processor normally does.
Of course, command line editing like
ksh's EDITOR=vi will allow it.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.