Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 222
  • Last Modified:

CD not works

Hi,

After formating the hard disk, the d:\ dissapeared from My Computer / Windows Explorer.
The light may still on when turn on the computer and I can still eject the CD bed. When put a CD in the drive, I can hear the noise.
I have checked the two links they are looks OK (by my eyes only).
What I can do now?
0
victorlong
Asked:
victorlong
  • 13
  • 7
  • 3
  • +2
1 Solution
 
jjeff1Commented:
The problem is that you don't have the drivers installed for your CD-ROM. Depending on what kind of CD you have, windows may or may not detect it and install things for you.

Windows 9X needs to have the the drive controller setup correctly for the CD-ROM to work. So if you have an IDE CD-ROM, make sure the IDE controller to which it is attached is detected. If not, run the add new hardware wizard from the control panel to add it.

If you have a SCSI or proprietary CD-ROM, you need to install the drivers for that as well. Windows may detect it with the add new hardware wizard, or you may need to get the drivers for the controller and add it manually.

If you give some more info on how the system is setup I can give you a better answer.

Jeff
0
 
victorlongAuthor Commented:
To jjeff1 :

Thank you.

I have tried to run the Add New Hardware Wizard but the result is "...did not find any new devices on your system."

I am using Windows95.
Something on the CD-ROM controller:
Wearnes
Perlp herals
International
Model: CDs-36x

If you want more infomation, you need to teach me how to find them :-)
0
 
j2Commented:
if this would happen to be the "old" (build 950) of Win95, you probably need to have a real mode cdrom handler loaded while isntalling it.

Let me guess that you formatted the HD, copied the win96 install hive to disk and installed from there?

try ftp://ftp.mitsumi.com/pub/drivers/ide158.exe

It will detect/drive any IDE/ATAPI compliant CDRom i have ever come acros.
0
Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

 
j2Commented:
(of cource you also still need mscdex.exe)
0
 
victorlongAuthor Commented:
To j2:

That might be a great help.

I have just downloaded ide158.exe....it looks for DOS only! Do you think I can use it to install d:\ in Windows95?
0
 
victorlongAuthor Commented:
To j2:

That might be a great help.

I have just downloaded ide158.exe....it looks for DOS only! Do you think I can use it to install d:\ in Windows95?
0
 
j2Commented:
As i said, in some cases the old version of win95 needs "real mode" drivers to pick up the precense of a CD.

Install these drivers to your win95 config.sys and autoexec.bat then reboot, win should now pick up the drive.

You should now be able to comment the drivers back out of the configs. If this makes Win95 "loose" the CD again, you a re probably stuck running real mode drivers which isnt good for performance.

You should have installed a set of drivers before you installed Win95 in the first place. (its in the install guide)

ANd once again, this is valid for the 950 build of WIn95 only. Not 1111 or later.
0
 
victorlongAuthor Commented:
Hi  j2 :

I have just run the setupd.exe successfully. However, after re-booting, I can not see d:\ in My Computer :-(
0
 
j2Commented:
1. Is the driver loaded in config.sys and is mscdex.exe loaded in autoexec.bat?

If they are and the drive still doesnt show up, either you have a bad drive, or you need specific drivers for that drive.
0
 
victorlongAuthor Commented:
to j2:

Yes I think so:

rem ---------------------- MTM ATAPI CD-ROM ----------------------
[COMMON]
LASTDRIVE=M
DEVICE=C:\lin\cd\MTMCDAI.SYS /D:MTMIDE01
rem ---------------------- MTM ATAPI CD-ROM ----------------------

rem ---------------------- MTM ATAPI CD-ROM ----------------------
C:\WINDOWS\COMMAND\MSCDEX.EXE /D:MTMIDE01 /M:10
rem ---------------------- MTM ATAPI CD-ROM ----------------------

Can I check it is good or bad....they said it is a new one...
0
 
j2Commented:
when you boot windows, and see the "Windows logo screen" press "ESC" and you should see the drivers init. Does it actually FIND the CD?
0
 
victorlongAuthor Commented:
j2:

It said

Device driver not found: "MTMIDE01"
No nalid CDROM device dri.......
0
 
victorlongAuthor Commented:
j2:

Sorry, a typing mistake....

It saied:

 Device driver not found: "MTMIDE01"
  No valid CDROM device dri.......
0
 
compmaniaCommented:
Go to your BIOS setup (when you boot you will see a message like "Press del to enter setup" it might be f1 or f2 also)
Go to the auto detect hard disk feature Does it find the drive?
If not then you need to powerdown the computer, open the case and make sure the plugs are in tight connected from the motherboard to the drive.
0
 
victorlongAuthor Commented:
To compmania :

Thank you.

I can not find the "auto detect hard disk" feature in the BIOS setup...there is a similar item is "Integrated Devices\Hard Disk: Auto". It that you mean? That is defualt setted.

>plugs are in tight connected.....

I have checked those connecting: only two connectings, one for the electric power and the other is the cable with manu wires. However, There are some empty sockets.

When I put a CD in the drive, I can hear the noise. Does this means all the connections OK?
0
 
compmaniaCommented:
The power is in good but I am wondering about the long cable, when you look at it do you see a long red strip on one side?
This should be pointing toward the power cable when it is plugged in.
For the hard disk does it have several channels (pri master, pri slave, sec master, sec slave)?
If it does make sure all are set to auto.
Another thing is to make sure it is jumpered correctly, when you look at the back of it do you see some pins sticking out with a black block thing connecting 2 pins?
Check on the case for something that says master, slave, cable select. It should have the jumper settings listed so you can set it to slave.
Is the drive connected to the same cable as the hard drive? (the long one with lots of wires) or is it only connected to your motherboard?
0
 
hewittgCommented:
Victor,
When you opened the case, did you by chance see what type of CDROM it was, ie manufacture and model number.  This may help.

Glenn
0
 
j2Commented:
hewittg: reaD the thread. Its a Wearnes 36x
0
 
victorlongAuthor Commented:
To compmania:

Thank you.

>a long red strip.... should be pointing toward the power cable

Yes it is.

>For the hard disk does it have several channels (pri master, pri slave, sec master, sec
                   slave)?
                   If it does make sure all are set to auto.

Where to find those things? On the hard disk? find them from screen?

> It should have the
                   jumper settings listed so you can set it to slave.

The jumper was setting to master. I have tried to change to slave and other one without success. (btw, why should be setted as slave?)

>Is the drive connected to the same cable as the hard drive?

No, it connected with the motherboard directly; its socket is located by the socket for the hard disk though.
0
 
j2Commented:
"(btw, why should be setted as slave?)
" - If you have two devices on a single cable one _MUST_ be master and the other MUST be slave.

In your case it should be master (since it is the only device on the chain)

Have you tried moving it onto the same chain as the HDD, and setting the CD to 'slave'?

Some motherboards doenst like to have a Secondary Master, without a primary slave.
0
 
victorlongAuthor Commented:
Hi  j2 :

Thank you....you still put one eye on the Q..

>Have you tried moving it onto the same chain as the HDD,

That is an interesting thing, I am going to have a try now.....Don't know if the cable can do that or not....
0
 
victorlongAuthor Commented:
Hi experts,

Report:

 I tried to use the cable for the CD to connect the hard disk and motherboard and got error message.
( I tried also use another spare cable to connect the hard disk but not work.)

Can we say the cable originally for the CD is no GOOD?
0
 
victorlongAuthor Commented:
I disconnected the cable from the CD and use it to replace the one for the hard disk and got error message when switch on the PC.

Is that proved that the cable for the CD is a bad one?
0
 
compmaniaCommented:
Sounds like it, put another one in there.
The channels I am talking about should be in the BIOS, you need to set them all to auto.
Did you try setting the hard drive as master (normal setting for most drives except Western Digitals) and the CD as slave?
Use the cable that is connected to the hard drive.
0
 
victorlongAuthor Commented:
Hi experts,

I have tried to connect the CD (slave) and hard disd (master) to the same cable and same socket in motherboard, and that has been successfull.
I haven't test if the CD can work independently or not because i haven't got a good cable....
I think the points should give to j2 who first suggested me to do the master-slave test. If any one not agree please let me know.

Thank you for all your help.
0

Featured Post

Sign your company up to try the MB 660 headset now

Take control and stay focused in noisy open office environments with the MB 660. By reducing background noise, you can revitalize your office and improve concentration.

  • 13
  • 7
  • 3
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now