Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Beginner in Linux

Posted on 2000-03-17
9
Medium Priority
?
289 Views
Last Modified: 2010-04-20
Hi!!

I´m beginner in linux and having some difficuties:

My linux is installed in a  HD with 406 MB with the following partins:
I think that the kernel version is 2.034.. but I´m not sure!!!

hda - Windows98 and Dos partions

hdb - Linux

296MB - Linux Native:
100MB - Linux Swap
10MB  - Fat  (I think so)

1- How can I write the Fat partion ?
2- How can I access my floppy drive ?   (I access it from my win98)
3- How can I access my CD-ROM Drive ?
4 - How can I print ? My printer is HP 660C

5 - My monitor is LG StudioWorks and it isn´t in the list ... Is it a problem? How can I configure it?

I´ll appreciate any help!!!

Regards,
        mrxz.
0
Comment
Question by:mrxz
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 2
9 Comments
 
LVL 1

Accepted Solution

by:
toneus earned 80 total points
ID: 2628044
It's a lot of questions for just 10 points! But here are some answers:

1. you could just mount your FAT. check your /etc/fstab file if any entry about /mnt/dos or to hda exists. Otherwise create a dir (e.g. mkdir /mnt/dos and mount your hda "mount -t msdos /mnt/dos /dev/hda" (check man mount)

2. If you have installed your mtools there are some dos-like commands available. Try "mdir a:" and "mcopy <file> a:".
Also check your /etc/fstab again for an entry to /dev/fd0. Or use mount like above, but for /dev/fd0.
Also in KDE or Gnome standard icons exist to access your floppys

3. same story.../etc/fstab ....mount.../dev/cdrom....KDE...gnome..standard access...

4. in X, start control-panel, and go to the printer-icon. there add your printer. then it is just a matter of "lpr <file>".
If you don't have X, read the documentation. You should check /var/spool/lp0

5.It is not a problem that it is not in the list. But check your frequences (horizontal and vertical). These are the most important to set! "you could choose a standard vga monitor. Run Xconfigurator or Xf86config. (I don't know which should be capitals in the program names exactly.

6. To find out what type your 10 MB partition is; type "fdisk /dev/hdb" choose p to print the partition table. It will tell you what it is. (m=help)

It's a lot to start with but don't give up!! You will learn a lot about PC's.
0
 

Author Comment

by:mrxz
ID: 2629388
Adjusted points from 10 to 40
0
 

Author Comment

by:mrxz
ID: 2629389
I´m evaluating your answer... and increse the points!
0
Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

 

Author Comment

by:mrxz
ID: 2629419
I´m evaluating your answer... and increse the points!
0
 

Author Comment

by:mrxz
ID: 2629449
I have no kde and X- Window installed !!! there is not much space!!!
I have postgres and I´ll see about mtools

regards,
   mrxz
0
 

Author Comment

by:mrxz
ID: 2631325
Hi!!!
I created /mnt/dos directory with mkdir,
but when I do: mount -t msdos /mnt/dos /dev/hdb6 (my FAT partion) it brings me the followin error:
 /mnt/dos is not a block device.

what is this?

thanks for any help !!!
0
 
LVL 1

Expert Comment

by:toneus
ID: 2636699
have you checked your fstab? If it is setup there the mount automaticly performed at boot.
0
 

Author Comment

by:mrxz
ID: 2639797
I looked at fstab file and saw something like that :

there is other things, but cann´t remember now

/dev/fd0         /mnt/floppy
/dev/cd          /mnt/cdrom

Is it means that my floppy and CD-ROM are already mounted?
How can I do to access? Please note the error message when I tried to mount
mount -t msdos /mnt/dos /dev/hdb6 (my FAT partion) it brings me the followin error:
 /mnt/dos is not a block device

The Fat partion isn´t in fstab, but when I did something likely with floppy it brings a similar error.

regards,
      mrxz
0
 

Author Comment

by:mrxz
ID: 2672740
I finally made it.
I helpped very much ... but you passed me a misplaced syntax of mount.

The syntax that worked was:

to mount the FAT partion:
mount -t auto /dev/hdb6 /mnt/dos

and the others followed the same syntax!
(just changing the parameter!!!)

Thank you!!!!
Regards, mrxz.



0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

1. Introduction As many people are interested in Linux but not as many are interested or knowledgeable (enough) to install Linux on their system, here is a safe way to try out Linux on your existing (Windows) system. The idea is that you insta…
Fine Tune your automatic Updates for Ubuntu / Debian
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial
Suggested Courses

609 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question