We help IT Professionals succeed at work.

Root: man and RPM problem

crain asked
Last Modified: 2013-11-13
I have been unable to get RPM files to install as root.  I can upgrade but not install.   Errors like

file: package.tar.gz action: unkown

pop up when I use

rpm -ivv package.rpm.

I started having this problem with the netatalk rpm, but the ksciplot and C++2LaTeX packages give me the same error that the action for each file is unknown.

Also, as root, any man topic I can think of is unavailable.  Even simple ones like ls and cd.   Could these issues be related via a corrupted .bashrc file or its equivalent?  I rarely use bash. I am running RedHat 6.0 and my user tcsh account works fine.

Watch Question

MANPATH needs to be set properly to access man pages.
1) setenv MANPATH /usr/man:/usr/local/man:.
2) or the 'manual' way: you may find where the interested man pages are at by
'locate ls.1',
then do
groff -Tascii -man </path/to/ls.1 | more

interesting RPM problem:-(
Without further ado to diagnose, if it were me, I'd just try to upgrade RPM package itself, rebuild rpm database, then try again.

to check out where this 'tar.gz' file comes from:
rpm -qlp problematic.version.rpm

'rpm -ivv' is just a typo, or something I dono?


the 'rpm -ivv' installs with 'vv' for very verbose tracking of the installation process.  Thats where I get  the

file:  file.in.rpm action: unknown


What is the error? The error is different from your first post? If you don't mind, please tell which RPM and where to download, I'd be very interested to try it out. And, what's RPM's own version, and stuff?


Sorry.  Below is some output that should clarify what I get when I try to install C++2LaTeX-1.1-2.src.rpm (although I get the same kind of action: unknown when I have tried to install ksciplot or netatalk).  If this gets involved I can bump up the points for this question.

[root]# rpm --version
RPM version 3.0.2  
[root]# ls
C++2LaTeX-1.1-2.src.rpm  netatalk-1.4b2+asun2.1.0-5.src.rpm  voodoo
SNNS-4.1-2.i386.rpm      netatalk-1.4b2+asun2.1.3-6.src.rpm
cdwrite-2.0-1.src.rpm    rpm-3.0.2-6.0.i386.rpm
[root]# rpm -ivv C++2LaTeX-1.1-2.src.rpm
D: counting packages to install
D: found 1 packages
D: looking for packages to download
D: retrieved 0 packages
D: New Header signature
D: Signature size: 236
D: Signature pad : 4
D: sigsize         : 240
D: Header + Archive: 48836
D: expected size   : 48836
D: found 1 source and 0 binary packages
D: New Header signature
D: Signature size: 236
D: Signature pad : 4
D: sigsize         : 240
D: Header + Archive: 48836
D: expected size   : 48836
D: installing a source package
D: sources in: //usr/src/redhat/SOURCES
D: spec file in: //usr/src/redhat/SPECS
D:    file: C++2LaTeX-1.1.tar.gz action: unknown
D:    file: C++2LaTeX-1.1-2.spec action: unknown
[root]# rpm -qlp C++2LaTeX-1.1-2.src.rpm


Oops, I got the C++2LaTeX RPM from ftp://contrib.redhat.com.  As for the output from 'rpm -ivv' once I run that nothing has actually been installed.  That is the error.  Its like rpm can't figure out what to do with any of the files in the package.rpm file although is recognizes all of the pieces contained in the rpm.

Also, I tried setenv as root and never managed to get my MANPATH to change:

[root]# setenv MANPATH /usr/man:usr/local:man:
bach: setenv: command not found.
[root]# echo $MANPATH

Is setenv not available under bash? Curiouser and curiouser....


Adjusted points from 50 to 75
This one is on us!
(Get your first solution completely free - no credit card required)
A bad, embarassing, case of keyboard faster than brain. I am just *NOW* reading the output log you posted above. I'd give rpm --install a try, regardless...




That did the trick with no fuss!  Thanks alot.

Weird though that -i and --install are different in rpm.



Gain unlimited access to on-demand training courses with an Experts Exchange subscription.

Get Access
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Empower Your Career
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.


Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.