Solved

Backgrounds are disappearing

Posted on 2000-03-18
11
201 Views
Last Modified: 2010-04-25
I'm having a frustrating problem where a background for several tables are not showing.
I've check the links, source code to see if everything is correct. (it seems to be) I've tried publishing it to no avail. The image is online (it works fine for every other page. Is there any option or anything in dreamweaver that would do this? What else could cause it? There are form objects within these tables, could that be linked to the problem???

Thanks
Jason
0
Comment
Question by:schlitz100
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 4
  • 2
  • +1
11 Comments
 
LVL 17

Expert Comment

by:inthe
ID: 2631368
Hi
can you reproduce the problem on test page and send me via email the html page & image to take a look at.
we had similar problem here a few weeks ago but i cant remember offhand what it was to fix it.

Regards Barry

legend@enterprise.net

0
 
LVL 17

Expert Comment

by:inthe
ID: 2631911
hi,
it worked fine in dreamweaver and ie etc .
as long as you put the image in the "Media" folder then it shows up as it should..
if your web site is on unix server make sure your case is correct (ie check folder name is Media not media )
i see no option in dreamweaver(3) to turn off the background.
i cant think what else could be wrong.


0
 

Author Comment

by:schlitz100
ID: 2632087
It does not work for me. I'm using an NT server. I'm rippping my hair out! Did it work for you in the link? Or only when you saved the source?

Jay
0
Enroll in May's Course of the Month

May’s Course of the Month is now available! Experts Exchange’s Premium Members and Team Accounts have access to a complimentary course each month as part of their membership—an extra way to increase training and boost professional development.

 
LVL 17

Expert Comment

by:inthe
ID: 2633059
Hi
no it didnt appear on the web page(that why i wondered about the case of the directory name "Media" on your server).

i got the source saved as d:\test.html,went to the submit link to get the picture ,saved the picture in a directory called d:\Media\bg5.jpg then opened the test.html file in dreamweaver and background appeared fine ..

i'd suggest you try putting the picture in the same directory as the html file and change the links in your html file to point at picture in same dir and re-upload to test.


0
 

Author Comment

by:schlitz100
ID: 2633236
Tried it, didn't work.
Even tried typeing out the entire url in the bg link in dreamweaver but that didn't work either.

If I use Media/bg5.jpg as the background for the entire page it works fine (or anywhere else on any other page) but I did try your suggestion.... there has got to be something else...
0
 
LVL 4

Expert Comment

by:chewymon
ID: 2633436
Are you dealing with IE or Netscape?  They deal with table backgrounds differently.  Do you have an example up that we all can look at?
0
 

Author Comment

by:schlitz100
ID: 2633607
Here's the link:
http://infomerket.com/test3.htm

I'm using IE. This one uses 4 different url's for the background image. All work everywhere else except for this web page.  

Media/bg5.jpg
bg5.jpg
http://infomerket.com/bg5.jpg
and
http://infomerket.com/Media/bg5.jpg

none work. they are all visable working under Dreamweaver....

Jay
0
 

Accepted Solution

by:
robjgreen earned 20 total points
ID: 2633823
Hi Jay,

Just a thought, try putting the background in the <td> tag rather than the <tr> tag.

Regards,

Rob Green.
0
 
LVL 4

Expert Comment

by:chewymon
ID: 2633898
File>Check Tareget Browsers...

This will generate a report similar to the following.  This is from DW3.


Error The background attribute of the Table Row tag is not supported.
Microsoft Internet Explorer 4.0, Microsoft Internet Explorer 5.0, Netscape Navigator 4.0
line 027 <tr background="http://infomerket.com/bg5.jpg" valign="middle">
also lines 045, 077, 109, 141, 173, 205, 241, 255, 275, 295, 315, 341, 417, 431, 525, 619, 721

End of report.
0
 

Author Comment

by:schlitz100
ID: 2634017
That worked...
Thanks alot

Jay
0
 
LVL 17

Expert Comment

by:inthe
ID: 2634059
according to html 4 standards all the ie versions 2-5 support background tag in tables whereas all the netscape versions dont...

0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

For those who don't know, Adobe Dreamweaver is a popular commercial web editor that enables you to design, build and manage complex websites. The editor is a WYSIWYG (What You See Is What You Get) web editor, which means that you can create your web…
I still run into .cgi files every now and then. In some instances, I actually prefer the simplicity of a .cgi script to other options. Since I use DreamWeaver extensively, what I needed was a way to open .cgi scripts in Dreamweaver. And I wanted to …
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question