Solved

set default OS on dual boot

Posted on 2000-03-19
8
358 Views
Last Modified: 2010-04-20
I'm using Calder OpenLinux 2.3 and I'm trying to set my dual boot system to select Win98 as the default OS.  Below is /etc/lilo.conf

#
# /etc/lilo.conf - generated by Lizard
#

# target

boot = /dev/hda
install = /boot/boot.b

# options

prompt
delay = 50
timeout = 50
message = /boot/message

default = win

image = /dev/hda1
        label = win

image = /boot/vmlinuz-2.2.10-modular
        label  = linux
        root   = /dev/hdb1
        vga    = 274
        read-only
        append = "debug=2 noapic nosmp"
                                     
which I would have thought would let it boot to Win98 by default, but it doesn't. Any ideas greatly appreciated.      
0
Comment
Question by:tvanlint
8 Comments
 
LVL 1

Expert Comment

by:soulmate022700
ID: 2633241
change:

image = /dev/hda1
        label = win

to:

other = /dev/hda1
        label = win
        table = /dev/hda

0
 
LVL 1

Author Comment

by:tvanlint
ID: 2633970
I've tried changing the image= to other=, what does the table= do?
0
 

Expert Comment

by:DaveWho
ID: 2634389
Do you have access to LILO graphical interface? If you do, go to configure LILO and delete linux and right away add linux again, this should solve your problem. It solved my problem. By the way, don't delete win.
0
Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

 
LVL 1

Author Comment

by:tvanlint
ID: 2634393
how do I bring up the "LILO graphical interface"?
0
 
LVL 1

Accepted Solution

by:
friebele earned 50 total points
ID: 2634555
solemate is correct. Change the 'image' reference as above. In your configuration, remove the line with 'default'. Lilo automatically assumes the first operating system on the list as the default. Remember, from a console as superuser, type "lilo" to initiate the changes.
0
 

Expert Comment

by:vvijayk
ID: 2634729
Have u done
#lilo
so that this info is written in mbr ?
0
 
LVL 1

Expert Comment

by:hansendc
ID: 2640923
It might be worth a shot to try this:
> lilo -D win
That is the command line option to specify the default lilo entry to boot.  Maybe your lilo.conf is being parsed incorrectly or something.  Stranger things have been known to happen.  This will override any default boot entry in lilo.conf
0
 
LVL 1

Author Comment

by:tvanlint
ID: 2642455
the various config I tried would have worked if I had known to type lilo to make the update 'stick', so thanks friebele.
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

This document is written for Red Hat Enterprise Linux AS release 4 and ORACLE 10g.  Earlier releases can be installed using this document as well however there are some additional steps for packages to be installed see Metalink. Disclaimer: I hav…
The purpose of this article is to fix the unknown display problem in Linux Mint operating system. After installing the OS if you see Display monitor is not recognized then we can install "MESA" utilities to fix this problem or we can install additio…
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.

808 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question