Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 265
  • Last Modified:

DHCPCD

Whenever I run DHCPCD it will do this:

eth0:Setting Rx made to 0 addresses.
eth0:Setting Rx made to 1 addresses.

Then it will time out waiting for valid DHCP services. How can I fix this?
0
AlexPierce
Asked:
AlexPierce
  • 3
1 Solution
 
jlevieCommented:
Do you know for sure that your ethernet interface is working properly, with linux? If there's some resource conflict with the IRQ/IOport or speed negogiation problem you won't be able to get dhcpd to work. Check the interrupts by looking at /proc/interrupts & /proc/pci and see what IRQ and IO port linux is using for the card. BTW what card (make/model) is it?

Another clue as to what's going on can frequently be found by looking at the output of "ifconfig eth0". If you see a transmit packet counts, but no received packet counts, it usually means that there's an IRQ conflict.
0
 
AlexPierceAuthor Commented:
jlevie,

Hi, I think you have hit it on the nose. I did ifconfig eth0 and here's what I got:

Link encap:Ethernet HWaddr 00:10:4B:24:FC:48
BROADCAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:12 errors:0 dropped:0 overruns:0 carrier:0
Collisions:0 txqueuelen:100
Interrupt:10 Base address:0x300

As you can see, there are several transmits, but nothing being recieved, so I think your right about the IRQ conflict. I have a 3COM 509B ethernet card. If you could also, tell me your e-mail address.

Thank You,
Walter Waltz
0
 
jlevieCommented:
Argh, the dreaded 3c509b disease. Don't panic, I'm just kidding. The problem with 3c509b's is that they are shipped with PnP enabled, but Linux doesn't use PnP and things get confused. It's pretty easy to fix.

First go into the Bios and disable PnP, life gets simpler and more pleasant with it off. You'll need the 3Com diskettes, disk1 of which has 3c5x9cfg. That's the configuration tool for the card and can be used to take it out of PnP mode and autoconfigure the card (or manually set the IRQ & IP port).

The process goes like this. Boot from a DOS or win95/98 bootable diskette. change to the 3Com disk and run 3c5x9cfg. It should start up ready for you to configure the card, if not use the menu items to select configure. Tab/up/dn to the PnP line and disable it. Then go to the auto-configure button and let it do it's thing. Take note of the IRQ that's been programmed onto the card and save the config onto the card.

Go back into the bios and reserve that IRQ for use by ISA in the PCI config area. Reboot and your ethernet ought to work. You can check the IRQ with "ifconfig eth0" to be sure Linux is using the right stuff, but I'll bet it will.

If you don't have the diskettes they can be downloaded from 3Com's site.
0
 
moheynowCommented:
testing, please disregard
0
 
jlevieCommented:
Well now that things are woring again, my email is jlevie@bellsouth.net
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

A proven path to a career in data science

At Springboard, we know how to get you a job in data science. With Springboard’s Data Science Career Track, you’ll master data science  with a curriculum built by industry experts. You’ll work on real projects, and get 1-on-1 mentorship from a data scientist.

  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now