?
Solved

.htaccess & .htpasswd is working but user not found

Posted on 2000-03-19
4
Medium Priority
?
2,491 Views
Last Modified: 2013-12-25
I tried to configure authfile on my folder
i create .htaccess, .htpasswd, configure access.conf

when i trying accessing that folder
apache said authoprize fail.

when i looking what happened, in error_log, its say

"[Mon Mar 20 10:34:23 2000] [error] [client 204.158.21.2] (13)Permission denied: Could not open password file: /home/myhome/authfiles/.htpasswd"

"[Mon Mar 20 10:34:23 2000] [error] [client 204.158.21.2] user myname not found: /secretfolder"


contents of : /home/httpd/domains/mydomain/secretfolder/.htaccess
===================================================
AuthUserFile /home/myhome/authfiles/.htpasswd
AuthGroupFile /dev/null                    
AuthName "My Secret Folder"              
AuthType Basic                              
require valid-user                          
===================================================

contents of : /home/myhome/authfiles/.htpasswd
===================================================
myname:QQv2f0YGhTpdc
hisname:Fav2f0YG3dpcc
hername:QRx2f0eGghrgc
===================================================


contents of : access.conf
===================================================
<Directory /home/httpd/domains/>      

AuthUserFile /home/myhome/authfiles/.htpasswd    
AllowOverride All                              
       
order allow,deny                                
allow from all                                  </Directory>
===================================================

any one know, what happend exactly ?

Thanks
Rizal
hrizal@royal.net

0
Comment
Question by:hrizal
  • 2
4 Comments
 
LVL 2

Author Comment

by:hrizal
ID: 2634720
also i have chmod 777 to .htacess file
0
 

Expert Comment

by:fatguy
ID: 2636872
My guess is that the access.conf or httpd.conf should be like:

DocumentRoot /home/httpd/domains
AccessFileName .htaccess
AllowOverride All

0
 
LVL 2

Author Comment

by:hrizal
ID: 2686504
fatguy,
i was checked on mu httpd.conf and access.conf
and its was setting like thats
and its still not work ... :(

i think the problem is on access right on "/home/myhome/authfiles/.htpasswd"
its not readable by other users ..


0
 
LVL 2

Accepted Solution

by:
jonalee earned 200 total points
ID: 2739640
Your setting is OK.
Just set the access mode your .htpasswd and .htaccess to 0600

All the security seeting in your home folder needs to be set as 0600, like .netrc, etc.

0

Featured Post

[Webinar On Demand] Database Backup and Recovery

Does your company store data on premises, off site, in the cloud, or a combination of these? If you answered “yes”, you need a data backup recovery plan that fits each and every platform. Watch now as as Percona teaches us how to build agile data backup recovery plan.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In threads here at EE, each comment has a unique Identifier (ID). It is easy to get the full path for an ID via the right-click context menu. However, we often want to post a short link within a thread rather than the full link. This article shows a…
Originally, this post was published on Monitis Blog, you can check it here . In business circles, we sometimes hear that today is the “age of the customer.” And so it is. Thanks to the enormous advances over the past few years in consumer techno…
Learn the basics of if, else, and elif statements in Python 2.7. Use "if" statements to test a specified condition.: The structure of an if statement is as follows: (CODE) Use "else" statements to allow the execution of an alternative, if the …
The viewer will learn the basics of jQuery, including how to invoke it on a web page. Reference your jQuery libraries: (CODE) Include your new external js/jQuery file: (CODE) Write your first lines of code to setup your site for jQuery.: (CODE)
Suggested Courses

621 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question