kdevelop installing problems

I'm trying to install kdevelop using the rpms with the following command :

rpm -Uvh kdevelop-1.1-1.i386.rpm

but I get the following errors :

error : failed dependencies:
          libjscript.so.2 is needed by kdevelop-1.1-1
          libkdecore.so.2 is needed ...

7 libraries are needed. I located the lib's in the /usr/lib directory so they are installed.
LVL 1
940961slAsked:
Who is Participating?
 
torabConnect With a Mentor Commented:
Come to think of it, it's quite possible I was talking bullshit there. The LD_LIBRARY_PATH variable is (AFAIK) only used when compiling / linking programs, and not when running them. If you're primarily installing from binary RPMs you won't need to set it.

If you do want to set it you could do so in your .bashrc file (assuming you are using bash-shell) using the command:

export LD_LIBRARY_PATH=/usr/lib;...

The same command can be run "manually" in a shell, but then you'll have to do it every time you need the variable.

Regards,
Tor Arne
0
 
torabCommented:
If the libraries are already installed there is an option for the rpm command to ignore dependencies. It's either
--nodep or
--nodeps

the command should then be (assuming --nodeps is it):
rpm -Uvh --nodeps kdevelop-1.1-1.i386.rpm

If the libraries are correctly installed (usr/lib is presumably in your PATH and LD_LIBRARY_PATH environment variables) so that the app finds them runtime, it shouldn't be a problem.

I hope this solves your problem!

Regards,
Tor Arne
0
 
940961slAuthor Commented:
well, I solved my problem by reinstalling the kdelib rpm and now it works. But I don't have the LD_LIBRARY_PATH environment variable. How do I create it??
0
Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
torabCommented:
It's obvious my answer didn't solve your problem, so I'm withdrawing it...
0
 
940961slAuthor Commented:
Well, it's not the answer to my question, but I didn't know how to set an environment variable. So after all, I learned something new.

For those after me reading this question : I had to use the option --force to install the rpm again.
0
 
torabCommented:
Glad to have been of some help :)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.