• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1482
  • Last Modified:

Strange Error - "Access can’t change the working directory to ..."

Hello Experts,

 "M$ Access can’t change the working directory to "F:\Projects\Files\MSS_disabled\625.”  Verify that the drive is valid and the path is 260 characters or less in length."

F:\ is a mapped drive from the file Server.

"MSS_disabled" is a subdirectory that was renamed to "MSS_CBV" and has nothing to do with this or any other .mdb above that "Files" subdirectory, but I can't open ANY .mdb or even Access.exe without getting this error.

If I rename it back to "MSS_disabled", than all is well, but it shouldn't do this, and I don't want the folder called that.

What can I do to stop Access from giving this error whenever anything is opened in Access or Access itself.

This error only appears on the workstation I used to create and rename the directory.

Thanks,

Mac
0
MacRena
Asked:
MacRena
  • 3
  • 2
1 Solution
 
paaskyCommented:
Hello MacRena,

Wild guess:
Check Tools | Options -> General Page that your default working dir in that machine is not "F:\Projects\Files\MSS_disabled\625"

This may be causing the problem..

Hope this helps,
Paasky
0
 
simonbennettCommented:
I'm with paasky on this one. If it isn't that though try a registry search for "F:\Projects\Files\MSS_disabled" - - this ay provide a clue.

Good Luck

Simon
0
 
simonbennettCommented:
..whoops - I meant to add it may be your system.mdw that is the prob.

Simon
0
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

 
MacRenaAuthor Commented:
Hi paasky,

When I start Access97, I get the error, then the "Open File" dialog is presented.  Being a modal form, I can't open Tools|Options until I close it, so I close it.  With no database open, Options is gray (not enabled) in Tools.

If I open an .mdb or .mde from here, the error does not reappear, so it is in the opening of Access that this error is generated, even when I am opening an .mdb on the C:\ drive (not associated with the network or the Programs\Files path.

Access itself is choaking on the fact that a file server directory is not there, so Access itself needs to be adjusted, not any one database.


Hello simonbennett,

It seems that you found the problem.  There is a key in "HKEY_CURRENT_USER/Software/Microsoft/Office/8.0/Access/Settings" called "Default Database Directory" with this path in it.  I Modified it out (so it is "") and the error went away.  Thank you!

My workstation has several "Default..." settings.  Some others are called "Default Window On Top", "Default Cell Effect", "Default Column Width", "Default Field Type", etc.  Most have hex values.  There are 19 "Default..." Keys, but a different workstation here (does very little Access work) has none of these keys in the same Registry Key.

So, the error is gone and I have something else to figure out "why did that happen?" - love those.

Thanks for the help to you both.

Mac
0
 
paaskyCommented:
Glad you problem is solved.

The key you found from registry (HKEY_CURRENT_USER/Software/Microsoft/Office/8.0/Access/Settings) is just that particular setting what I was expecting to cause the problem. That setting is workstation setting, not just database setting (or you would get that same error with that database in all workstations).

Good luck!
Paasky
0
 
paaskyCommented:
one correction to my previous comment: it's user setting - so if you had logged into workstation as a different user it would have been worked ok.

Paasky
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now